Funny Little Problem

Discussion in 'Wii - Backup Loaders' started by KevinPatrickConn, Oct 6, 2012.

Thread Status:
Not open for further replies.
Oct 6, 2012
  1. KevinPatrickConn
    OP

    Newcomer KevinPatrickConn Member

    Joined:
    Sep 21, 2012
    Messages:
    46
    Location:
    Mesa, AZ
    Country:
    United States
    Here is a funny one! So, I up till today had my Wii in pieces sine my drive is dead and I was attempting repairs until I got DM to work acceptably well. (BTW I spent over seven years of my life as a professorial video game console repair man so I do know my shit when it comes to hardware at least :)) I stitch my Wii up and I also decide to switch out my tiny little external 2.5 western digital 160GB to an old school PATA maxtor 300GB 3.5 drive in an external enclosure plugged into the wall for power and whatnot. So, after copying my entire Wii collection and, Finally, my entire GameCube collection fitting at the same time on the same drive, YAY. I get the worst news ever. I didnt test the Wii closed up first before the HD swap AND I didn't actually test the drive and enclosure for compatibility before I spent hours and hours doing the transfers.

    First thing, wont see the HDD at all... ACK! I about cried, or screamed.... but after switching USB ports and powering down like three time I got it to show up in Wiiflow For testing I tried MKDD and it wouldn't load up. Now, I have had issue with Wind Waker and other before but never ever with double dash so I was a little freaked out.

    I switched to the 160GB original drive and low and behold it shows up but the GameCube controller ports simply wont accept any input, strange, and now double dash and FzeroGX and like two other GameCube games lock up randomly as well!

    I didnt change the config at all so I suspected I may have inadvertently loosened up a ribbon cable or maybe even shorted something out!

    Now, my Wii battery, the CR2032 that is screwed in on the side of the unit has a stripped screw hole since I have opened this thing at least 10 times and even before I owned it the unit was a customers at my shop who simply left it there forever since the drive was needing a replacement laser and they didnt want the expense... anyways... I had taped the battery in place as the last thing I did to close the Wii up. I took the tape off and popped out the battery and remembered a VERY specific issue with PS2 hardware where when the battery runs out the blue balls in the firmware stop spinning, it causes no hard to the units ability to play games and you can even replace the battery and it will save the date and time settings but those damn balls wont ever spin again.

    So just for kicks I plugged my Wii in with no battery in at all just to see if maybe there was some freaky thing going on and can you guess what happened next?

    The Wii worked just fine and the drive showed up, both drives, and I am currently playing my Wii without issue with absolutely no battery installed and no problems, whatsoever. I didn't know it the battery is dead and somehow DM or IOS XXX has an issue with attempting to save the date and time settings when the battery is dead and it perhaps bypasses those steps when the battery is removed entirely as I do not have another CR2032 to try it but, what the hell! who would have thought the flipping watch battery in the side of the Wii could actually cause issues!

    It's fine with me but I just though you guys might enjoy this rather odd problem and the unorthodox fix required to make it work again.

    Cheers all! :)

    Kevin
     
  2. wiimanofthenorth

    Member wiimanofthenorth GBAtemp Regular

    Joined:
    Jan 18, 2011
    Messages:
    285
    Country:
    United Kingdom
    Nice little story. I've changed the wii's battery at least twice since I've had it from new when they first came out. I noticed that sometimes it wouldn't boot up at all or wouldn't let wiiflow start, if it didn't have a working battery in. I've always stuck in a well named battery, not just some cheap rubbish, because that way I know I'm going to get a good fews years out of it.

    It's pretty much the same sort of problem you can get with a PC's CMOS battery failing it seems.

    As for the PS2, I didn't know about the blue balls, but I've still got a FAT PS2 I got for free because it wasn't working. All I didn't was open it up and hoover it out while using a can of compressed air, and replaced the battery (It wasn't keeping time at first). Still works fine today, and I've got a HDD in that too!
     
  3. Cyan

    Global Moderator Cyan GBATemp's lurking knight

    Joined:
    Oct 27, 2002
    Messages:
    16,437
    Location:
    Engine room, learning
    Country:
    France
    Converted to blog
     
Thread Status:
Not open for further replies.

Share This Page