Flashcarts work on v1.4??

Discussion in 'NDS - Flashcarts and Accessories' started by SamAsh07, Jan 13, 2010.

  1. SamAsh07
    OP

    SamAsh07 GBAtemp Addict

    Member
    2,696
    67
    Jan 27, 2009
    Bosnia and Herzegovina
    Bahrain
    Just need a heads-up, I'm getting a DSi next week (already got DS and DS lite xD! I love having all the DS! 'cept for the ugly DSi XL...thats too large...) and most probably it will have either 1.4 or 1.3 -just a hunch-

    Another question: Which is the best DSi Flashcart??
     
  2. Aeladya

    Aeladya *mistressOFtheCLOW

    Member
    759
    1
    Nov 13, 2004
    United States
    Idaho Falls, ID
    Only DSi specific flash carts work with 1.4. I'd say the Acekard 2i is one of the most well known flashcarts and I believe it's the best, it's cheap and does the job it needs to. Mine came with 1.3 (bought it Sunday). With AKAIO, the Acekard 2i is amazing, it gets updated very quickly, works with the Wii and I've had no problems with it.
     
  3. lolzed

    lolzed The GBAtemp Pichu

    Member
    2,466
    13
    Sep 13, 2008
    There
    since AKAIO is now dead updates will be slower,also wait for the Supercard DSTWO
     
  4. RedBaron

    RedBaron GBAtemp Advanced Fan

    Newcomer
    519
    0
    Dec 7, 2009
    Is AKAIO DEAD, when did this happen
     
  5. anaxs

    anaxs got milk, got candy

    Member
    2,208
    1
    Mar 23, 2009
    Canada
    your moms jeans pocket
    akaio is not dead, where do guys get this stuff from
     
  6. SamAsh07
    OP

    SamAsh07 GBAtemp Addict

    Member
    2,696
    67
    Jan 27, 2009
    Bosnia and Herzegovina
    Bahrain
    Acekard2i, got it! Thanks for giving your opinions!! Today's the day the DSi will be bought xD Although I won't get it until 24th, since my parents are buying it and are in another country for a tiny 12 day visit xD