Firmware questions

Discussion in 'PSP - Games & Content' started by luke_c, Feb 9, 2010.

Feb 9, 2010

Firmware questions by luke_c at 7:07 PM (948 Views / 0 Likes) 9 replies

  1. luke_c
    OP

    Member luke_c Big Boss

    Joined:
    Jun 16, 2008
    Messages:
    3,587
    Location:
    Land of England
    Country:
    United Kingdom
    Which firmware will run the latest games? Is there like a compatibility list or something? I am assuming GEN-D or whatever it's called will run the more later games than M33
    Also, what's the advantages/disadvantages of M33 over GEN and vice versa;
    I know M33 is more stable but that's about it?
    Also just wondering if GEN will run Dante's Inferno [​IMG]
     
  2. prowler

    Member prowler Sony

    Joined:
    Jul 14, 2009
    Messages:
    9,473
    Location:
    Ragol
    Country:
    United Kingdom
    You have no idea what you are starting [​IMG]

    Assuming Dante's Inferno has protection just like Kingdom Hearts and God Eater, you will not be able to play it unless a patch and/or new CFW gets released.

    Go with M33 if you don't mind patching all of the new games (You can easily find pre-patched games on warez sites) and if you are wanting to play PS1 games (M33 has more compatibility with PS1 games see here).

    ... Ha, getting ready to sell my PSP has changed my mind about GEN... Get M33 [​IMG]

    EDIT: Also forgot to mention Homebrew, M33 has more compatibility with Homebrew too.
     
  3. Jamstruth

    Member Jamstruth Secondary Feline Anthropomorph

    Joined:
    Apr 23, 2009
    Messages:
    3,456
    Location:
    North East Scotland
    Country:
    United Kingdom
    As long as Xist doesn't see this we're OK.

    GEN is best for beginners as it will run most UMDs and most ISOs as well as PS1 and Homebrew games without any patching.
     
  4. luke_c
    OP

    Member luke_c Big Boss

    Joined:
    Jun 16, 2008
    Messages:
    3,587
    Location:
    Land of England
    Country:
    United Kingdom
    So with M33 I would have to patch most of the latest games? Is there just one patcher for these or is it different for every game? :\
    Only things Homebrew wise I would be running is Popsloader for PSX/1 and the GBA emulator, with that down I should go for GEN right?
    Also I heard that PSN still works on GEN and on M33 it doesn't?
     
  5. prowler

    Member prowler Sony

    Joined:
    Jul 14, 2009
    Messages:
    9,473
    Location:
    Ragol
    Country:
    United Kingdom
    No. PSN is blocked for all firmware below 6.20
    Though there is a PSNabler, the games that it worked for are nearly all blocked now.
    Resistance: Retribution is the only game so far I know about works fully.
     
  6. luke_c
    OP

    Member luke_c Big Boss

    Joined:
    Jun 16, 2008
    Messages:
    3,587
    Location:
    Land of England
    Country:
    United Kingdom
    Alright, so i'll go for GEN then, can I go straight to GEN with the Pandora or what? I'm not too fussed about PSN really it just would of been a nice extra.
     
  7. xist

    Member xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Joined:
    Jul 14, 2008
    Messages:
    5,861
    Country:
    United Kingdom
    To add a little here....

    Yes GEN is better for beginners, noobs and lazy people.
    Yes in the vast majority of games it's a single patcher but a couple of games require additional fixes on top of that.
    I'd argue about PSX gaming and GEN D3. If it's important to have maximal compatibility in the end GEN isn't the firmware for it.
    Meh PSN....adhoc Party should work though if and when it gets released...
     
  8. luke_c
    OP

    Member luke_c Big Boss

    Joined:
    Jun 16, 2008
    Messages:
    3,587
    Location:
    Land of England
    Country:
    United Kingdom
    Bleh, so stuck for choice right now, i'm not so much worried about patching games i'm more worried about actually finding the correct patches for the games, I would be playing a lot of PSX games so that will play a big factor towards my choice. As for the patcher I assume this is what you're talking about?
    Also, if my PSP comes with 5.03 or below can I just do this?
     
  9. Jamstruth

    Member Jamstruth Secondary Feline Anthropomorph

    Joined:
    Apr 23, 2009
    Messages:
    3,456
    Location:
    North East Scotland
    Country:
    United Kingdom
    You can only softmod from 5.03 downwards over that needs a Pandora-ble PSP.
     
  10. luke_c
    OP

    Member luke_c Big Boss

    Joined:
    Jun 16, 2008
    Messages:
    3,587
    Location:
    Land of England
    Country:
    United Kingdom
    So if I change my mind and decide to go with GEN would I need to go to M33 first, then GEN?
     

Share This Page