Firmware Downgrader v1.11 bug

Discussion in 'Wii - Hacking' started by pcfree, May 25, 2009.

May 25, 2009

Firmware Downgrader v1.11 bug by pcfree at 4:11 PM (1,079 Views / 0 Likes) 6 replies

  1. pcfree
    OP

    Newcomer pcfree Advanced Member

    Joined:
    Mar 29, 2009
    Messages:
    59
    Country:
    Taiwan
    Totally know nothing about Spanish. Could someone help to report bug to Waninkoko?

    Some people in Chinese forum report that they cannot successfully change region settings (error code -102) after installing cross-region SysMenu. I've tried to reproduce the same error and found that it's caused by function __Setting_SetPerms() in setting.c file. The permissions cannot be set as desired.

    Besides, I've found a more severe bug in SYSCONF processing. The function Setting_GetRegion() in setting.c use library function to retrieve region setting instead of using equivalent function in sysconf.c. Although this is not a bug, it seems to cause the author forget to call SYSCONF_Init() in sysconf.c file. The flag __sysconf_inited is still in FALSE state and cause other SYSCON_xxx functions failures.
     
  2. bdr9

    Member bdr9 GBAtemp Advanced Fan

    Joined:
    Jul 21, 2008
    Messages:
    558
    Country:
    United States
    I think Waninkoko speaks English, because when he makes a YouTube video (on his iwaninkoko username), he puts the description and annotations in English.
     
  3. kwirky

    Newcomer kwirky Advanced Member

    Joined:
    Mar 14, 2009
    Messages:
    69
    Country:
    United States
    I think you need to change the console ID first before changing the region if memory serves.
     
  4. chunan

    Newcomer chunan Member

    Joined:
    May 17, 2009
    Messages:
    37
    Country:
    Taiwan
    you might reach him via IRC Channel

    #cIOS @ irc.freenode.org
     
  5. Slimmmmmm

    Member Slimmmmmm GBAtemp MoNkEeE

    Joined:
    Nov 1, 2007
    Messages:
    1,687
    Location:
    the land of lol
    Country:
    United Kingdom
    The bugs been passed on to waninkoko.
     
  6. pcfree
    OP

    Newcomer pcfree Advanced Member

    Joined:
    Mar 29, 2009
    Messages:
    59
    Country:
    Taiwan
    Thanks!
     
  7. Levente

    Member Levente GBAtemp Regular

    Joined:
    Nov 28, 2006
    Messages:
    243
    Country:
    Hungary
    I think I also found a bug, but I in cIOS rev10.

    I updated with waninkoko's 4.0 updater, and I have cIOS rev10 installed now. My problem is that the rebooting with hooks fails on WiiGator's 0.3 gamma with cIOS r10 (the wii freezes after the rebooting before the game is shown in the disk channel), but with cIOS rev9 it is NOT freezing, just after you launch the game in the disk channel, but this is OK because the IOS patch in Backup Launcher 0.3 gamma was not written for System Menu 4.0 and only games which are patched to IOS249 will work.
    Please post this too!

    Thanks!
     

Share This Page