Fire Linker 128mb vs. Fire Emblem

Discussion in 'GBA - Flashing Hardware and Software' started by aleksandar2, Dec 24, 2010.

Dec 24, 2010
  1. aleksandar2

    Newcomer aleksandar2 Newbie

    Dec 24, 2010

    I could really use some help here.
    I have an old Fire Linker 128mb for the GBA which i'm sure most people on this forum are familiar with.
    Anyways It worked great until recently. It loads up good, the speed is fine, even the save games worked good.
    That was until I put fire emblem on it. Long story short, I was able to beat about 40% of the game, when the save feature stopped working.
    I thought one of my brothers did that accidentally so I didn't pay much attention to it, but today it happened again, and I beat about 90% of the game. It's like the game at one point says: You know what, I think I'll just delete your file even though I'm able to save it normally.
    You know that feeling when you work your butt off to achieve something in a video game and then suddenly... poof... all gone, I almost cried! Now I have started the game again just to see if the save feature still works, and wouldn't you know it, IT DOES! Why does the cartridge keep doing that to me?
    So now I have been doing some research (on this site mostly) and have downloaded a bunch of rom patching programs but I don't get half of the stuff.
    I'm sure that the battery is working fine on my Fire Linker so it probably has to do something with the save feature of the Fire emblem game. I have found out that the game uses a SRAM 256 kb something, but I don't get any of that stuff. Can someone help me patch this rom correctly or at least tell me if I should get a better GBA flash card?
  2. Cuelhu

    Member Cuelhu КУ!

    May 19, 2010
    Fantasy Land
    are you sure the battery is working fine? This cart looks pretty old. And you should have backed up your save more frequently..

Share This Page