Failing install CIAs

Discussion in '3DS - Homebrew Development and Emulators' started by codeluca, Dec 9, 2016.

  1. codeluca
    OP

    codeluca GBAtemp Regular

    Member
    147
    19
    Mar 7, 2016
    Italy
    Naples, Italy
    Good day guys,
    It has been a while since I wrote here, hope everything is fine.

    I'm having an issue with my 3DS with my A9LH configuration (with latest FW and latest Luma Version).

    I can't get why I can't install .cia files anymore.

    I mean, I always get an error when I try to install .cia files.

    Files are fine.

    For example, using FBI I get
    Failed to install CIA file.
    Result code: 0xD8E0806A
    Level: Permanent (27)
    Summary: Invalid Argument (7)
    Module: AM (32)
    Desc: Cert signature or hash check failed (106)

    Any help is really appreciated.
    Thank you and have a great day.
     
  2. KunoichiZ

    KunoichiZ GBAtemp Guru

    Member
    7,602
    2,957
    Mar 16, 2012
    United States
    How are you launching FBI?
     
    codeluca likes this.
  3. codeluca
    OP

    codeluca GBAtemp Regular

    Member
    147
    19
    Mar 7, 2016
    Italy
    Naples, Italy
    Through Sysnand using Health & Safety application.
     
  4. KunoichiZ

    KunoichiZ GBAtemp Guru

    Member
    7,602
    2,957
    Mar 16, 2012
    United States
    Can you try reinjecting FBI into Health&Safety?
     
    codeluca and H1B1Esquire like this.
  5. codeluca
    OP

    codeluca GBAtemp Regular

    Member
    147
    19
    Mar 7, 2016
    Italy
    Naples, Italy
    Yes I just need to remember how to do it. I'm searching on the Plailect's guide.

    — Posts automatically merged - Please don't double post! —

    Done, installed the 2.4.2, same issue.
     
  6. HyperT

    HyperT GBAtemp Advanced Fan

    Member
    674
    169
    Jun 4, 2016
    Have enough sd space?
    And check in fbi if there are any Pending Titled
     
    Last edited by HyperT, Dec 9, 2016
    codeluca likes this.
  7. codeluca
    OP

    codeluca GBAtemp Regular

    Member
    147
    19
    Mar 7, 2016
    Italy
    Naples, Italy
    I have enough Space on my SD card and there are no Pending titles.

    What's happening :wacko: ?
     
  8. erman1337

    erman1337 GBAtemp Maniac

    Member
    1,211
    928
    Sep 27, 2015
    Belgium
    Brussels
    Try turning on "Patch SVC/service/archive/ARM9 access" in the Luma3DS configuration screen (hold SELECT whilst booting up)

    If that fixes it, I suggest installing the FBI.cia from the injected H&S app, then turn the patch off (because it's a security risk)
     
    Last edited by erman1337, Dec 9, 2016
  9. Uwabami

    Uwabami GBAtemp Advanced Fan

    Member
    605
    569
    Feb 4, 2014
    Germany
    did you enable luma's devmode? having UNITINFO enabled will cause normal CIAs to fail installing
     
  10. codeluca
    OP

    codeluca GBAtemp Regular

    Member
    147
    19
    Mar 7, 2016
    Italy
    Naples, Italy
    No Devmode enabled and I also tried enabling "Patch SVC/service/archive/ARM9 access" and then installing a .cia through H&S (FBI) but still nothing.
    If it could be helpful, when I updated my 3DS, I updated Luma3DS to the latest Version (using StarUpdater) and then I updated 3DS FW through Update System Software.

    I appreciate your help guys!

    EDIT: I also tried to install a RANDOM .cia from Freeshop or CIAangel, still nothing.
     
    Last edited by codeluca, Dec 9, 2016
  11. Uwabami

    Uwabami GBAtemp Advanced Fan

    Member
    605
    569
    Feb 4, 2014
    Germany
    hm, is it only one CIA that fails or all? could also be the CIAs being corrupt...
     
    codeluca likes this.
  12. erman1337

    erman1337 GBAtemp Maniac

    Member
    1,211
    928
    Sep 27, 2015
    Belgium
    Brussels
    Last edited by erman1337, Dec 9, 2016
    HyperT and codeluca like this.
  13. codeluca
    OP

    codeluca GBAtemp Regular

    Member
    147
    19
    Mar 7, 2016
    Italy
    Naples, Italy
    Seems it's working with the patch enabled now (I updated LUMA manually), I'm gonna try disabling the patch from Luma settings.

    I suppose it was something related to Star Updater.

    I'll let you know in minutes whether it's working or not.

    Thank you guys!
     
  14. Uwabami

    Uwabami GBAtemp Advanced Fan

    Member
    605
    569
    Feb 4, 2014
    Germany
    Last edited by Uwabami, Dec 9, 2016
  15. codeluca
    OP

    codeluca GBAtemp Regular

    Member
    147
    19
    Mar 7, 2016
    Italy
    Naples, Italy
    Ok I confirm that now it is working properly even though it seems I can't update titles.

    I updated a title but even though the updated is installed, the update notification is always there and it doesn't disappear..

    What could it be?
     
  16. Uwabami

    Uwabami GBAtemp Advanced Fan

    Member
    605
    569
    Feb 4, 2014
    Germany
    Is the game from another region? Then you could try updating the game through FreeShop
     
    codeluca likes this.
  17. codeluca
    OP

    codeluca GBAtemp Regular

    Member
    147
    19
    Mar 7, 2016
    Italy
    Naples, Italy
    Yes, it was probably a region problem!

    Guys I really appreciated your help, seems everything is working properly now.

    Thank you all and have a nice day!
     
    Uwabami likes this.
  18. Jao Chu

    Jao Chu GBAtemp Advanced Maniac

    Member
    1,917
    1,211
    Aug 20, 2013
    straya m8
    I find that running NTR first before installing CIA's prevents these kinds of errors. Could be patching out some extra things that Luma doesn't? I don't know, but it works for me.
     
    codeluca likes this.