EZ Flash Omega + Analogue Pocket firmware

0bvious

Well-Known Member
OP
Member
Joined
Oct 1, 2007
Messages
174
Trophies
1
XP
888
Country
I have an EZ Flash Omega. If I run it on an original GBA or a DS Lite it loads up fine. It is updated to v1.09

But with the new Analogue Pocket the EZ Flash Omega asks every time to update from v1.07 to v1.09. If I hold R and boot it seems to update, and then asks this question again. No matter how many times I update it still asks the same thing.

In the EZ Flash system menu it says the Flash cart is updated to v1.09. And yes, if I load the EZ Flash Omega on a regular GBA it doesn't ask the update firmware.

Seems like a bug with Analogue Pocket. Please advise.

Thanks
 

koshi

Member
Newcomer
Joined
Dec 17, 2021
Messages
5
Trophies
0
Age
42
XP
31
Country
Japan
My Omega DE works fine but Mode B doesn't work at all.
This is interesting. I can't get my Omega DE to work (latest firmware) - it only says "link-mode". My Omega (not DE) works fine. Jr. for GB/GBC worked after updating to beta firmware. Which firmware version are you running?
 

koshi

Member
Newcomer
Joined
Dec 17, 2021
Messages
5
Trophies
0
Age
42
XP
31
Country
Japan
My Omega DE works fine but Mode B doesn't work at all.
This is interesting. I can't get my Omega DE to work (latest firmware) - it only says "link-mode". My Omega (not DE) works fine. Jr. for GB/GBC worked after updating to beta firmware. Which firmware version are you running?
 

0bvious

Well-Known Member
OP
Member
Joined
Oct 1, 2007
Messages
174
Trophies
1
XP
888
Country
I hadn't considered it before, but there are SO SOOOOO many different flash carts for the GB and GBA. Analogue might have their work cut out trying to accommodate them all. Either way, I hope this gets fixed.
 

ghjfdtg

Well-Known Member
Member
Joined
Jul 13, 2014
Messages
1,384
Trophies
1
XP
3,373
Country
They probably don't care for the flashcarts. Besides that if they fix their timings (accuracy is the whole goal) the flashcarts will he fixed too.
 

coolbho3000

GBATemp Kikkoman Naturally Brewed SoySauce Fanatic
Member
Joined
Apr 29, 2007
Messages
2,123
Trophies
1
Age
124
Location
Kikkoman Factory
XP
1,098
Country
This is interesting. I can't get my Omega DE to work (latest firmware) - it only says "link-mode". My Omega (not DE) works fine. Jr. for GB/GBC worked after updating to beta firmware. Which firmware version are you running?
The Pocket troubleshooting FAQ says to clean your contacts if this happens.
 

Cheapergamer

New Member
Newbie
Joined
Aug 21, 2017
Messages
4
Trophies
0
Age
38
Location
United Kingdom
Website
cheapergamer.co.uk
XP
55
Country
United Kingdom
This is interesting. I can't get my Omega DE to work (latest firmware) - it only says "link-mode". My Omega (not DE) works fine. Jr. for GB/GBC worked after updating to beta firmware. Which firmware version are you running?
Same here! It states the Bios and Link-mode but does not say Error in red underneath. I've cleaned the pins etc with IPA but it's almost as if a cart is no inserted at all.

Omega Non-DE works as expected and Jr. is working fine also.
 

koshi

Member
Newcomer
Joined
Dec 17, 2021
Messages
5
Trophies
0
Age
42
XP
31
Country
Japan
I really can't image it's the pins. At least not for the folks not getting the red "error"-text. My Analogue Pocket (obviously) and my EZ flash are both brand new...
(But I did try the flash card in an original GBA after running into the problem, so I know it is working)
 

hyuganet

New Member
Newbie
Joined
Jul 15, 2007
Messages
4
Trophies
0
XP
141
Country
United States
Same position. I get "ANALOGUE BIOS 1.4 LINK-MODE". No red ERROR text. It's definitely in GBA mode.

Did same as koshi, plugged in an original GBA cart, it works. I did the firmware update on a DS Lite. Works great, never any trouble booting. Everdrive GB is 100% successful.

Anyone who has had this error manage to get it working?
 

0bvious

Well-Known Member
OP
Member
Joined
Oct 1, 2007
Messages
174
Trophies
1
XP
888
Country
exactly same issue than @obvious (with my Ez flash omega) , if i cancel the update I can boot any game but so far none works.
I can definitely load games. You need to update the cart to the latest firmware, possibly on a device other than the Pocket (GBA etc). Hold down R when you load the cart. Make sure it is with latest firmware. Then reboot.

The message to update remains, but after pressing B you can play any games fine.
 

EZ-Flash2

Official EZ-FLASH Stuff
Member
Joined
Jul 16, 2003
Messages
1,120
Trophies
3
XP
3,534
Country
China
We have tried to contact Analogue by email, if they can adjust the shipping priority, we can buy a sample to participate in the debugging, but I can not find a valid contact email on their website, only a [email protected], yesterday I sent a mail to this email, as of now no response.
 
  • Like
Reactions: koshi

koshi

Member
Newcomer
Joined
Dec 17, 2021
Messages
5
Trophies
0
Age
42
XP
31
Country
Japan
We have tried to contact Analogue by email, if they can adjust the shipping priority, we can buy a sample to participate in the debugging, but I can not find a valid contact email on their website, only a [email protected], yesterday I sent a mail to this email, as of now no response.
They do have a [email protected], but as far as I can tell from monitoring various forums/subreddits they aren't responding to anyone in a timely manner right now. They had the first devices shipped last week with all the bigger and smaller support requests this causes (my power button is slightly deformed, for example). At the same time they launched their biggest pre-order campaign ever - they probably bit off more than they can chew...
 

mephisto_mods

New Member
Newbie
Joined
Dec 21, 2021
Messages
1
Trophies
0
Age
40
XP
25
Country
Belgium
Hey guys, I created an account just to give you a solution that worked for me with the Ez-Flash Omega DE: my card shipped with version "Kernel 1.03 firmware 4.0" so I never bothered to flash it, since it was the same version that is listed on the website. I had the same problem as multiple people: on the analogue pocket, it booted in "link mode". I saw a post on reddit where a guy said his card worked fine, so I downloaded the firmware on the website (so Kernel 1.03 firmware 4.0 too), flashed it using a GBA, and now my card works on the analogue pocket!! My guess is maybe it shipped with a beta version of the firware? anyways, I hope it'll work for you guys too...

edit2: typos
edit: link to the reddit post in question, I left a message there too:
 
Last edited by mephisto_mods,

koshi

Member
Newcomer
Joined
Dec 17, 2021
Messages
5
Trophies
0
Age
42
XP
31
Country
Japan
Hey guys, I created an account just to give you a solution that worked for me with the Ez-Flash Omega DE: my card shipped with version "Kernel 1.03 firmware 4.0" so I never bothered to flash it, since it was the same version that is listed on the website. I had the same problem as multiple people: on the analogue pocket, it booted in "link mode". I saw a post on reddit where a guy said his card worked fine, so I downloaded the firmware on the website (so Kernel 1.03 firmware 4.0 too), flashed it using a GBA, and now my card works on the analogue pocket!! My guess is maybe it shipped with a beta version of the firware? anyways, I hope it'll work for you guys too...

edit2: typos
edit: link to the reddit post in question, I left a message there too:

I just did the same thing. It might even really have changed something, since I now see a very short logo at bootup on my original GBA - I am not sure if this was the case before. However, the behaviour on the Pocket is unchanged...
 

Randomguy1818

New Member
Newbie
Joined
Dec 22, 2021
Messages
1
Trophies
0
Age
40
XP
32
Country
France
I have an EZ Flash Omega. If I run it on an original GBA or a DS Lite it loads up fine. It is updated to v1.09

But with the new Analogue Pocket the EZ Flash Omega asks every time to update from v1.07 to v1.09. If I hold R and boot it seems to update, and then asks this question again. No matter how many times I update it still asks the same thing.

In the EZ Flash system menu it says the Flash cart is updated to v1.09. And yes, if I load the EZ Flash Omega on a regular GBA it doesn't ask the update firmware.

Seems like a bug with Analogue Pocket. Please advise.

Thanks
Hi,
At first glance, mine doesn’t work too, I have updated my firmware on my ez flash and my pocket and it doesn’t work too.
So I checked the settings of my pocket and by default it’s on gb mode so I put my pocket in gba mode and it works just fine !
 

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    K3Nv2 @ K3Nv2: Imagine buying a switch in 2024