Exception DSI error has turned into something much more!

Discussion in 'Wii - Hacking' started by Zroe, Feb 3, 2016.

  1. Zroe
    OP

    Zroe Newbie

    Newcomer
    6
    1
    Feb 2, 2016
    United States
    I followed this tutorial to get HBC going and put some of the common apps on my wii.

    Somehow I ended up in another tutorial for the cios installation that had me using Base 56/248, Base 57/247. At this point I thought I was all set and went to load USB Loader GX and would get an "Exception DSI occured!" error and it would crash. Wiiflow just shows a few blips of colored pixels in the center of the screen and never finishes launching. These two only occured when I had a fat32 formatted external HDD in 32kb clusters plugged in to the leftmost usb port of the wii if it were standing up.

    So I followed the instructions on https://code.google.com/archive/p/d2x-cios/wikis/How_To_Install.wiki and reinstalled d2x-v10-beta52.zip in base 56/249 and 57/250 and tried again.

    Now USB loader boots into the application but nothing loads, just a white background with a bar at the bottom where I assume would have wii options/settings. Wiiflow does the same as before, just stays on a page flickering multicolored distorted pixels.

    If I unplug the HDD USB loader loads fully displaying the apps on my homescreen as if there were no problem as does Wiiflow.

    At this point I'm unsure where to go next. All I want to do is get this HDD recognized so I can start ripping my collection into it and play discless.

    Can anyone give me some direction?

    Edit

    After plugging the HDD back in and attempting to load USB loader again, I'm met with the Exception (DSI) occured! message once again.

    Edit**

    Waked through this guide https://sites.google.com/site/completesg/backup-launchers/installation

    At the point where I was installed cios 249 base 56 v10beta53-alt the installation froze. Waited for the progress bar for about 10 minutes and gave up.

    Moved onto this guide

    https://www.reddit.com/r/WiiHacks/comments/1qq0a0/trying_to_get_cios_rev20b_installer_to_work/

    and ran DOP-Mii, it was going well until it failed to install something because of NAND permissions.

    Went back to d2x and thought I'd keep trying, now it won't let me install CIOS because of an error at the bottom where I should be able to press any button to continue, instead it flashes the error about failed module(can't read it) and then moves back to the HBC.

    What have I done...

    I was going to post a syscheck but running it prompts a big red X and "failed to get the stored TMD for IOS36"

    Any help?
     
  2. Zroe
    OP

    Zroe Newbie

    Newcomer
    6
    1
    Feb 2, 2016
    United States
    So an update for anyone that happens across this thread and finds themselves in a similar situation...

    I came home determined to figure this out.

    Thought to try a new sd card from the ground up, immediately noticed when backing up my old SD card that I had renamed wad folder to wadold for this same notion, well renamed it to wad, ran dop-mii was able to patch, ran d2x installer and was able to get v10 beta53/52 installed into the correct slots.

    So all that mess was a stupid self made problem...


    Updated usb loader, was able to get it to read my HDD, it got to the screen where icons/shortcuts should populated but the cursor finger froze and it wouldn't load anything, just a white background.

    Checked HDD, had GC games not in a folder called "games" and had wii games in a folder "wbfs"

    pulled the GC games into "games" and left the wii in "wbfs"

    Plugged it back in and ran usb loader, it initialized drive then got the old Exception (DSI) occured!

    Freezes on reload.

    Moved 2 wii and 2 GC games into a fat32 128gb usb thumbstick and it started fine. Still not detecting games though, GC nor Wii which are both in (F:/games/GAMENAME/(iso or .wbfs depending on which system)) Do I have the directory conventions wrong? Why won't it recognize games even if it recognizes the HDD/USB stick

    Perhaps it's an issue with my 3TB seagate external? Can't see anything 3tb listed on the compatibility page but it's also formatted to 2TB FAT32/32kb and 1TB NTFS

    Wiiflow still doesn't load but I haven't updated it.

    Here's a syscheck if anyone can see anything glaringly obvious.

    SysCheck HDE v2.4.0 HacksDen Edition by JoostinOnline, Double_A, R2-D2199, and Nano
    ...runs on IOS58 (rev 6176).

    Region: NTSC-U
    System Menu 4.3U (v513)
    Priiloader installed
    Drive date: 05.26.2006
    Homebrew Channel 1.1.2 running on IOS58

    Hollywood v0x11
    Console ID: 67352230
    Console Type: Wii
    Shop Channel Country: United States (49)
    Boot2 v4
    Found 101 titles.
    Found 55 IOS on this console. 5 of them are stubs.

    IOS4 (rev 65280): Stub
    IOS9 (rev 54321): Trucha Bug
    IOS10 (rev 768): Stub
    IOS11 (rev 54321): Trucha Bug
    IOS12 (rev 526): No Patches
    IOS13 (rev 1032): No Patches
    IOS14 (rev 1032): No Patches
    IOS15 (rev 1032): No Patches
    IOS16 (rev 54321): Trucha Bug, ES Identify, Flash Access, NAND Access
    IOS17 (rev 1032): No Patches
    IOS20 (rev 54321): Trucha Bug
    IOS21 (rev 1039): No Patches
    IOS22 (rev 1294): No Patches
    IOS28 (rev 1807): No Patches
    IOS30 (rev 54321): Trucha Bug
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 3351): Trucha Bug, ES Identify, NAND Access
    IOS37 (rev 5663): No Patches
    IOS38 (rev 4124): No Patches
    IOS40 (rev 3072): Stub
    IOS41 (rev 3607): No Patches
    IOS43 (rev 3607): No Patches
    IOS45 (rev 3607): No Patches
    IOS46 (rev 3607): No Patches
    IOS48 (rev 4124): No Patches
    IOS50 (rev 54321): Trucha Bug
    IOS51 (rev 4864): Stub
    IOS52 (rev 5888): Stub
    IOS53 (rev 5663): No Patches
    IOS55 (rev 5663): No Patches
    IOS56 (rev 5662): No Patches
    IOS57 (rev 5919): No Patches
    IOS58 (rev 6176): USB 2.0
    IOS60 (rev 54321): Trucha Bug
    IOS61 (rev 5662): No Patches
    IOS62 (rev 6430): No Patches
    IOS70 (rev 54321): Trucha Bug
    IOS80 (rev 54321): Trucha Bug
    IOS90 (rev 54321): Trucha Bug
    IOS202[60] (rev 65535, Info: hermesrodries-v6): Trucha Bug, NAND Access, USB 2.0
    IOS222[38] (rev 4, Info: hermes-v4): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS223[38+37] (rev 4, Info: hermes-v4): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS224[57] (rev 65535, Info: hermesrodries-v6): Trucha Bug, NAND Access, USB 2.0
    IOS236 (rev 54321): Trucha Bug, ES Identify, NAND Access, Beer Ticket
    IOS245[37] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
    IOS246[38] (rev 21008, Info: d2x-v8final): Trucha Bug, ES Identify, NAND Access
    IOS247[53] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
    IOS248[55] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
    IOS249[56] (rev 21010, Info: d2x-v10beta53-alt): Trucha Bug, NAND Access, USB 2.0
    IOS250[57] (rev 65535, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
    IOS251[58] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
    IOS254 (rev 65281): BootMii
    BC v6
    MIOS v65535
    Report generated on 12/10/2006.


    Thanks in advance
     
  3. portugeek

    portugeek GBAtemp Fan

    Member
    374
    67
    Apr 6, 2013
    United States
    When I come across problems using USB Loader GX after an update, I typically like to delete my GXGlobal.cfg file and let USBLGX auto generate another one. This helps rule out all possibilities. (If you've made a lot of changes to your global settings that you'd like to keep, (or, if you learn that it had nothing to do with your GXGlobal settings) just rename the file ahead of time, to something like "old_GXGlobal". The app will still auto generate a new one and you'll get to keep a backup of your changes.

    Make sure all of your GameCube .iso's are renamed "game.iso" - If you have any 2 disc games then you'll want to make sure that the .iso for disc two is named "disc2.iso" And you'll need to have both .iso's in the same folder.

    Make sure all of your Wii games are each named after their [GAMEID] - For example, Super Smash Bros. Brawl would be named "RSBE01.wbfs"

    Apps like WiiBackupManager will not only let you see the game's [GAMEID], but it'll also help you transfer Dual Layer Wii games to FAT32 drives. Super Smash Bros. Brawl just happens to be a dual layer game, which also means that its .iso is too large to store in a FAT32 drive. Since FAT32 drives don't allow file sizes larger than 4gigs, you'll need WiiBackupManager to help you split these games into workable chunks. This will result in two separate files for each dual layer game. The Super Smash Bros. Brawl files are named "RSBE01.wbfs" and "RSBE01.wbf1" (note that the "E" may be a different letter depending on your region.)

    Use EaseUS Partition Master and make sure that your FAT32 partition is set as both "Primary" and "Active". Also make sure that when you're plug the drive into your Wii that it's plugged into USB port 0. It's the bottom port if your Wii is lying down flat.


    Your cIOS's look fine. The revision number on cIOS250 looks weird, but I don't see anything that stands out. You can always use your syscheck.csv file in conjunction with ModMii to find out if your Wii has any outdated IOS's that you may want to update.
     
    Zroe likes this.
  4. Zroe
    OP

    Zroe Newbie

    Newcomer
    6
    1
    Feb 2, 2016
    United States

    I wanted to say Thank you for all of this, I've been pretty busy but this weekend going to go through all of this with a fine tooth comb and get the last bits working.
     
    portugeek likes this.
  5. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,011
    775
    Mar 2, 2015
    United States
    65535 version number is to keep IOS updates from thinking it's an older version.
     
    Zroe and portugeek like this.
  6. Zroe
    OP

    Zroe Newbie

    Newcomer
    6
    1
    Feb 2, 2016
    United States
    Look like my problem turned out to be having had my 3TB split into 2 partitions. I had a 2tb FAT32 and the leftover as an NTFS partition.

    I deleted the loaders/wiiflow from the sd card and updated those, tried a barebones fat32 usb stick and went ahead and formatted that with easus to fat32 with 32kb clusters. Put a game on it and magically everything is working.

    So went ahead and wiped the hdd and reformatted it to just a 2tb partition with the leftover 1tb unallocated and finally the loaders are picking it up, no crashes or anything to speak of.

    I didn't catch before I wiped the hdd partitions if it had been set to GPT instead of MBR but perhaps that was part of it, or I had incorrectly set the values when dual partitioning it before.

    I only get 1 dsi error and that's trying to launch a homebrew app organizer, otherwise everything is great.

    Hopefully this helps someone else later.
     
  7. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,011
    775
    Mar 2, 2015
    United States
    Is it the Homebrew Browser? That crashes constantly for me.
     
  8. Zroe
    OP

    Zroe Newbie

    Newcomer
    6
    1
    Feb 2, 2016
    United States
    No actually that works great, it's just an organizer application that allows you to move the app selection in the homebrew channel to your liking. I deleted it, forgot the name, had downloaded it from the homebrew browser.