Error: Ret = -1

Discussion in 'Wii - Hacking' started by gigasguy, Jan 18, 2009.

Jan 18, 2009

Error: Ret = -1 by gigasguy at 10:08 PM (8,661 Views / 0 Likes) 33 replies

  1. gigasguy
    OP

    Newcomer gigasguy Member

    Joined:
    Jan 18, 2009
    Messages:
    31
    Country:
    United States
    After hours of working, I finally got the homebrew channel and the wad installer thing. Everything else I try to put on Homebrew channel fails. I go to download some .wad N64 games for my wii. But now it puts up an error that says "Ret = -1" within the first couple seconds. I have tried many files, but they all get turned down with that error.

    My files names with what they have in them are:

    apps (wadmanager)
    pr1vate (wii -> app -> RSBE -> ect.)
    DCIM (CANONMSC)
    private (wii -> title -> ect.)
    WAD Manager for 3.2 (wadmanager -> boot.dol, icon, and meta)
    boot.elf
    wad (wad games)
    IOS360-64-v1042.wad

    My SD card is a Lexar 1GB.

    If I'm missing anything, let me know what to download. Or if you need more info, I'll tell you whatever. Or if you can give me any help, I would be very greatful.
     


  2. Tw1z4st3r

    Newcomer Tw1z4st3r Newbie

    Joined:
    Jan 18, 2009
    Messages:
    9
    Country:
    Canada
    I am also getting the same error.
    Only when i try to install some wads also.

    Or also when i try to remove savegames from my wiii using save-game extracor.

    i would also like help with this situation please
     
  3. gigasguy
    OP

    Newcomer gigasguy Member

    Joined:
    Jan 18, 2009
    Messages:
    31
    Country:
    United States
    I just tried to install the IOS360-64-v1042.wad on my wii. I got error: ret = -1035
     
  4. gigasguy
    OP

    Newcomer gigasguy Member

    Joined:
    Jan 18, 2009
    Messages:
    31
    Country:
    United States
    PS:if you get error = -1035 please follow these steps to solve it ( thanks to OLVAP337 for this infos )
    - First run anytitle deleter and skip errors and if u see ios249 try deleting it is uncessfull (probably)
    - try with cios_uninstaller v1.1 (also fail probably)
    - then use cios_uninstaller v1.0 (sucess probably)
    - then install ios 16 with wad manager and cios_fix with custom wad manager
    - then continue steps wink.gif


    I didn't really understand that. Can somebody explain that and link me to a "cios_uninstaller"?
     
  5. gigasguy
    OP

    Newcomer gigasguy Member

    Joined:
    Jan 18, 2009
    Messages:
    31
    Country:
    United States
    God this is annoying. I'm not even sure if I need to install certain things or not. All I'm sure of is that I need to downgrade my Wii from 3.4 to anything lower.
     
  6. bugaveli

    Banned bugaveli Banned

    Joined:
    Dec 7, 2008
    Messages:
    664
    Location:
    In a remote place
    Country:
    United States
    if you weould all search your problem weouldve been solved a long time ago. No one is going to just hand u what you want SEARCH like everyone else has to
     
  7. gigasguy
    OP

    Newcomer gigasguy Member

    Joined:
    Jan 18, 2009
    Messages:
    31
    Country:
    United States
    Look, I have been searching. I keep on running into dead ends, and could use some help. I have downgraded my Wii to version 3.2, but its still not working. I keep getting Ret = -1. If anyone could help. I would really appreciate it.
     
  8. gambit420

    Member gambit420 GBAtemp Regular

    Joined:
    Jan 5, 2007
    Messages:
    130
    Country:
    France
    try to format your sd card. sounds odd but for me it worked!
     
  9. gigasguy
    OP

    Newcomer gigasguy Member

    Joined:
    Jan 18, 2009
    Messages:
    31
    Country:
    United States
  10. djtaz

    Member djtaz PM's Full - Wadder Me

    Joined:
    Sep 21, 2008
    Messages:
    2,997
    Country:
    Ireland
    JESUS H CHRIST where are u guys getting your files from ?


    Theres a flood of people in here the last few days with messed up ancient unsupported files

    Can you please download files from someone ON this site before you go asking questions about files you got somewhere else - and tell the other idiots to update their files and stop giving us headaches

    download my zip and use that itll stop you spending hours of wasted time on old ELF files that are no longer used or supported.
     
  11. gigasguy
    OP

    Newcomer gigasguy Member

    Joined:
    Jan 18, 2009
    Messages:
    31
    Country:
    United States
    I'm just looking for a way to play SSB64 on Wii. I have tried many files, they all get me the same error code.
     
  12. djtaz

    Member djtaz PM's Full - Wadder Me

    Joined:
    Sep 21, 2008
    Messages:
    2,997
    Country:
    Ireland
    Your using an ELF file for Homebrew channel - they havent been in use for months !
    You also havent told us what verison of firmware your on - 3.3 and 3.4 both disable wad installs
     
  13. gigasguy
    OP

    Newcomer gigasguy Member

    Joined:
    Jan 18, 2009
    Messages:
    31
    Country:
    United States
    So what should I do?
     
  14. djtaz

    Member djtaz PM's Full - Wadder Me

    Joined:
    Sep 21, 2008
    Messages:
    2,997
    Country:
    Ireland
    what you should do is use the SEARCH fucntion on the forums and read up on EVERYTHING.

    You really shouldnt be messing with WAD files (the ones that are most likely to brick a wii) when you dont know what your doing unless you want an expensive paperweight
     
  15. gigasguy
    OP

    Newcomer gigasguy Member

    Joined:
    Jan 18, 2009
    Messages:
    31
    Country:
    United States
    I just want to know how to get rid of this error code. I have been searching the forums along with tons of websites. No luck.
     
  16. djtaz

    Member djtaz PM's Full - Wadder Me

    Joined:
    Sep 21, 2008
    Messages:
    2,997
    Country:
    Ireland
    Your getting that error because your wii wont allow you to install wads.

    If your on version 3.3v2 or 3.4 its happening because you did an update and it removed the trucha bug that allows you to run wads.

    You need to install the trucha bug again for any wads to run... assuming your on 3.4

    also having a really old version of the homebrew channel wont help
     
  17. Tw1z4st3r

    Newcomer Tw1z4st3r Newbie

    Joined:
    Jan 18, 2009
    Messages:
    9
    Country:
    Canada
    To switch your files from .elf to .dol search for a file called .elf to .dol converter.

    That's what helped me switchy everything and get wads to work.
     
  18. gigasguy
    OP

    Newcomer gigasguy Member

    Joined:
    Jan 18, 2009
    Messages:
    31
    Country:
    United States
    Thanks for the help. I'll try that. I already downgraded my wii to V. 3.2, but I'll try the .elf to .dol. Also, how am I going to play Animal Crossing City Folk if every time I click it, it makes me update?
     
  19. gigasguy
    OP

    Newcomer gigasguy Member

    Joined:
    Jan 18, 2009
    Messages:
    31
    Country:
    United States
    Still not working. Oh well.
     
  20. Tw1z4st3r

    Newcomer Tw1z4st3r Newbie

    Joined:
    Jan 18, 2009
    Messages:
    9
    Country:
    Canada
    if your using gamma launcher you dont need to update
     

Share This Page