Error 032-1035 when trying to access GBAtemp on 3DS

Discussion in 'Site Discussions & Suggestions' started by smileyhead, Jan 3, 2019.

  1. smileyhead
    OP

    smileyhead This is definitely not a robotic component!

    Member
    17
    Aug 31, 2015
    Hungary
    Budakeszi, Hungary
    This was first observed by @Glitchk0ud1001 and confirmed by me.
    When I try to access Temp on a 3DS, I get error code 032-1035. According to this Reddit post, which is detailing the same error (but with 3ds.guide), it should have something to do with the site's certificate. (BTW, I've tested 3ds.guide and it seems to have been fixed.)

    upload_2019-1-3_16-7-46.png

    The 3DS browser's Page Info dialogue says that there is indeed a problem with the certificate:
    Warning: Spoilers inside!
     
  2. Issac

    Issac I

    Supervisor
    14
    GBAtemp Patron
    Issac is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Apr 10, 2004
    Sweden
    Sweden
    Nintendo doesn't have support for Let's Encrypt certificates for some stupid reason.
     
  3. smileyhead
    OP

    smileyhead This is definitely not a robotic component!

    Member
    17
    Aug 31, 2015
    Hungary
    Budakeszi, Hungary
    That's weird. 3ds.guide seems to have the exact same certificate but the website works perfectly (apart from an ignorable error dialogue when loading the page, but that doesn't block you from accessing the site, like this does).
     
  4. linuxares

    linuxares I'm not a generous god!

    Moderator
    17
    Aug 5, 2007
    Sweden
    I actually think it's the images that is the issue on GBAtemp. Since most of the images have iffy SSL certs from their respective site. While the 3DS guide have a fullsecure lock in my Chrome.
     
  5. Tom Bombadildo

    Tom Bombadildo ToMClassic

    pip Reviewer
    22
    GBAtemp Patron
    Tom Bombadildo is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jul 11, 2009
    United States
    I forgot
    It's just an issue with the 3DS's SSL certificate compatibility. Let's Encrypt does list the 3DS as known incompatible for their SSL cert, though as you mentioned this may vary depending on the site. It's possible, as linuxares mentioned, that some of the image hosting sites used by users have less compatible SSL certs which could indeed cause the 3DS to freak out, but I'm not sure that'd really be the cause since the error should then only happen on certain pages where third party images are used, not on all pages (ie the front page, since it's all content hosted on the Temp, would be "fine" since everything uses the same cert, but this page probably not because the image in Issac's signature has no SSL).

    Anyways, nothing that can likely be fixed unless we decide to swap to another SSL cert, but that would be silly since I doubt most users aren't actually accessing the Temp from a 3DS anyways.
     
  6. KleinesSinchen

    KleinesSinchen The Backup Reminder

    Member
    9
    Mar 28, 2018
    Germany
    The fault is clearly on the side of this poor browser. Deleting all browser data was necessary in my case and then GBAtemp could be loaded with specifying http:// instead of https:// However trying to switch to the mobile version results in a redirection to https again and the same error (and I would say automatic redirection to https is a good choice nowadays)
    • Unsafe http connections are accepted.
    • Supposedly unsafe https connections are denied - without a possibility to override a security warning. ("Hey, I want to read the start page of a forum and not do banking stuff, so open the site already!")
    It's a shame that there is no proper Browser on the N3DS systems. They are powerful enough for occasionally looking something up. A browser running like a game not an applet with access to more resources (and more configuration options) would probably be usable.
     
  7. jeffyTheHomebrewer

    jeffyTheHomebrewer Neato Burrito!

    Member
    4
    Aug 24, 2018
    United States
    in ur orbit
    agreed.
     
  8. I pwned U!

    I pwned U! GBAtemp Advanced Fan

    Member
    9
    GBAtemp Patron
    I pwned U! is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jun 14, 2013
    United States
    I have the same problem a lot. Just make sure that your URL starts with http.
     
  9. BEEMOO

    BEEMOO Member

    Newcomer
    1
    Nov 8, 2019
    Netherlands
    Some site automatically redirect to https so it might not always work.

    Couldn't someone 'update' the browser so that it would support the ssl?

    Or the coolest would be if someone ported something like firefox or chrome to the 3ds (I know not simple).
     
  10. smileyhead
    OP

    smileyhead This is definitely not a robotic component!

    Member
    17
    Aug 31, 2015
    Hungary
    Budakeszi, Hungary
    The 3DS and Wii U have been whitelisted not to force https on Temp, so you can edit the URL to http and it'll work.
    Also, I can see you're new here, please don't reply to older threads unless you absolutely need to.
     
    FateForWindows likes this.
  11. BEEMOO

    BEEMOO Member

    Newcomer
    1
    Nov 8, 2019
    Netherlands
    Ah I see, sadly Temp only.

    Yep I did notice but most topics regarding the 3DS is before 2018 so it's considered old but for me, it is still relevant and I don't want to create a new thread just for a small question regarding the same topic.
     
    Ammako likes this.
  12. uyjulian

    uyjulian Homebrewer

    Member
    9
    Nov 26, 2012
    United States
    United States
    The 3DS already has support for newer TLS versions in a recent update.
     
  13. BEEMOO

    BEEMOO Member

    Newcomer
    1
    Nov 8, 2019
    Netherlands
    Do you know which version is the latest.
    I'm currently on 1.10.10166
     
  14. smileyhead
    OP

    smileyhead This is definitely not a robotic component!

    Member
    17
    Aug 31, 2015
    Hungary
    Budakeszi, Hungary
    I think it's 1.12

    EDIT: 11.12*
     
    Last edited by smileyhead, Nov 20, 2019
    BEEMOO likes this.
  15. Ammako

    Ammako I like cake.

    Member
    11
    Dec 22, 2009
    Antarctica
    As long as you updated to FW 11.9.0-42 or later, you should be fine.
     
    BEEMOO likes this.
  16. BEEMOO

    BEEMOO Member

    Newcomer
    1
    Nov 8, 2019
    Netherlands
    Thanks!

    Huhm I'm on 11.12 but it seems that my browser is 1.10 and the latest is 1.12 so I might need to manually update it
     
  17. smileyhead
    OP

    smileyhead This is definitely not a robotic component!

    Member
    17
    Aug 31, 2015
    Hungary
    Budakeszi, Hungary
    Sorry, that was a typo. I meant 11.12 as in the system version.
     
    BEEMOO likes this.
  18. BEEMOO

    BEEMOO Member

    Newcomer
    1
    Nov 8, 2019
    Netherlands
    Ooh then it's all good.

    Thanks so much :)
     
    smileyhead likes this.
Quick Reply
Draft saved Draft deleted
Loading...