emuNAND .wad problems?

Discussion in 'Wii - Hacking' started by supremanade, Oct 17, 2018.

  1. supremanade
    OP

    supremanade Newbie

    Newcomer
    1
    Feb 21, 2018
    Finland
    Hello,

    I posted something about this issue a while back into the noob question thread, but I'll go ahead and start a fresh one in hopes of perhaps someone having a clue about this problem. I've been trying to get a few WiiWare and VC titles to work through USB Loader GX and emuNAND, but so far I had trouble.

    Problem is, most WiiWare games do seem to boot, but only to fail on an error message along the lines of "an error has occurred, refer to the Wii Operations Manual for Details", or in some cases, sometimes, an error about corrupted system files. Curiously this only happens with WiiWare games, all of the N64 VC games work just fine: Mario 64, Yoshi's Story, Sin and Punishment... and a few WiiWare games work too, at least Cave Story did - but almost everything else I've tried does not. Also worth mentioning I guess, most Wii games seem to work fine with the emuNAND either on full or partial, and successfully seems to use emuNAND for save files.

    I've set up Neek2o and it seems to work (can boot via USB Loader GX -> features -> boot to NEEK sysmenu) but weirdly this is of no use and I still get the exact same errors so I'm guessing it's not an issue with cIOS/d2x? This led me to try and troubleshoot the NAND dump itself - I've tried to re-dump it (through USB Loader GX -> features -> full NAND dump) as well as generating a NAND with ModMii but none of this seems to make a difference.

    I also tried to find a few different versions of the problematic .wads in case they were corrupt, but that wasn't the problem either.

    Could have I done something wrong?
    I've followed primarily the most recent emuNAND/Neek tutorials I could find by Cyan:
    USB Loader GX -> features -> full NAND dump with both paths set to usb1:/nand/mynand
    Loader settings NAND saves and channel emulation set to full and .wads installed through USB Loader GX .wad manager
    sneek folders generated with ModMii copied to usb1:/sneek and sd:/sneek and neek2o wad installed to emuNAND

    My system is 4.3E PAL Wii (not WiiU)
    System Menu IOS58 (rev 6176)
    USB Loader GX 3.0 r1262
    I've tried both:
    d2x v8final (base 56 at IOS249 and 57 at IOS250)
    d2x v10-beta52 (same base/IOS configuration as above)

    Any further info I'll happily provide to the best of my abilities... I tried to search around for a similar problem but none of them had replies or solid conclusions... Any help at all is appreciated!
     
  2. MrSW

    MrSW Member

    Newcomer
    2
    Sep 2, 2018
    Brunei
    how does your SNEEK folder look?
     
  3. supremanade
    OP

    supremanade Newbie

    Newcomer
    1
    Feb 21, 2018
    Finland
    Hey! My neek folders are set up on my USB drive an SD card as follows.

    Code:
    usb1:/sneek
    di.bin
    diconfig.bin
    font.bin
    kernel.bin
    nandcfg.bin
    rev.txt
    
    sd:/sneek
    kernel.bin
    rev.txt
    ModMii also generated an armboot.bin, intended to replace the armboot.bin in my sd:/bootmii (correct?) but I seem to recall several comments around here stating that it's no longer necessary and was only intended for some other setup entirely.

    I'll also add to this, I went ahead and attempted to update my Wii with the ModMii system update tool and a syscheck output so my IOSs should be mostly up to date. I'll dump the fresh sysconf file shortly, if for nothing else than documentation.

    Updating the IOSes seems to have made some kind of a difference regarding emuNAND, as now all the Wii (disc) backups I previously couldn't run on full emuNAND mode but only partial, now function properly on full. Alas, the WiiWare channels still do not run.

    Worth noting I don't have previous savefiles for any of these WiiWare games, could that cause issues? The way WiiWare saves work seemed to differ from disc backups... though I could be wrong. Might be worth trying to install a wad that should work with cIOS emuNAND to the realNAND and then dump the generated save files to emuNAND and see if that works.
     
  4. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    22
    Oct 27, 2002
    France
    Engine room, learning
    when using cIOS emuNAND, the required cIOS version/base is important and different for many WiiWare/VC game.
    when using neek, the cIOS has no more importance as they are not used at all.


    Did you try to put your emuNAND path to SD instead of usb ?
    which size is your USB FAT32 partition ? emuNAND bigger than 2TB can be a problem (reported negative free space by the Wii, it never expected to need 64bit arrays as NAND is only 512MB).
    If it works on SD, and your USB partition is bigger than 2TB, it's a savegame creation issue. create the savegame on SD, then move it to USB with ShowMiiWad.
    if you can, create a smaller than 2TB first FAT32 partition. (or even smaller, I don't remember the limit which triggered that error, but I suppose it's 2tb)

    That's the first and only issue I can thought of for now.
    You tried different NAND (dump and clean from modmii), different wads, so now try different devices (SD, usb, 512/4k/sectors etc.)
    Also, did you set region free in neek ?
     
    Last edited by Cyan, Oct 20, 2018
  5. supremanade
    OP

    supremanade Newbie

    Newcomer
    1
    Feb 21, 2018
    Finland
    Thanks for the reply, I will try copying my NAND to the SD and see if there is a change. My HDD is just 1TB, single partition formatted to FAT32. I'm not sure on sector size but it's not a very modern HDD so I'd imagine it's not 4k.
    I might have some old smaller USB drives around, if this doesn't work maybe I'll try that although at this point I'm more doing it just to find out what the problem is :P

    How wildly can the cIOS selection vary between WiiWare games? I only have d2x v8 final on 249/56 and 250/57 and other than this the compatibility seems good. (Observation, trying to run La-Mulana with v10 249/56, I got the generic Wii Problem Occurred -error message but when I switch to v8 249/56 the error message looks like it's generated by the game itself...).

    Nonetheless as neek doesn't seem to work either (yep, region free enabled) I imagine cIOS is not the main culprit here.

    Anyways here is the syscheck csv
    Code:
    SysCheck HDE v2.4.0 HacksDen Edition by JoostinOnline, Double_A, R2-D2199, and Nano
    ...runs on IOS58 (rev 6176).
    
    Region: PAL
    System Menu 4.3E (v514)
    Priiloader installed
    Drive date: 12.18.2008
    Homebrew Channel 1.1.2 running on IOS58
    
    Hollywood v0x21
    Console ID: 129890965
    Console Type: Wii
    Shop Channel Country: Finland (76)
    Boot2 v4
    Found 124 titles.
    Found 50 IOS on this console. 5 of them are stubs.
    
    IOS3 (rev 65280): Stub
    IOS4 (rev 65280): Stub
    IOS9 (rev 1034): No Patches
    IOS10 (rev 768): Stub
    IOS11 (rev 16174): Trucha Bug, NAND Access
    IOS12 (rev 526): No Patches
    IOS13 (rev 1032): No Patches
    IOS14 (rev 1032): No Patches
    IOS15 (rev 1032): No Patches
    IOS16 (rev 512): Stub
    IOS17 (rev 1032): No Patches
    IOS20 (rev 16174): Trucha Bug, NAND Access
    IOS21 (rev 1039): No Patches
    IOS22 (rev 1294): No Patches
    IOS28 (rev 1807): No Patches
    IOS30 (rev 16174): Trucha Bug, NAND Access
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 3608): No Patches
    IOS37 (rev 5663): No Patches
    IOS38 (rev 4124): No Patches
    IOS40 (rev 16174): Trucha Bug, NAND Access
    IOS41 (rev 3607): No Patches
    IOS43 (rev 3607): No Patches
    IOS45 (rev 3607): No Patches
    IOS46 (rev 3607): No Patches
    IOS48 (rev 4124): No Patches
    IOS50 (rev 16174): Trucha Bug, NAND Access
    IOS51 (rev 4864): Stub
    IOS52 (rev 16174): Trucha Bug, NAND Access
    IOS53 (rev 5663): No Patches
    IOS55 (rev 5663): No Patches
    IOS56 (rev 5662): No Patches
    IOS57 (rev 5919): No Patches
    IOS58 (rev 6176): USB 2.0
    IOS60 (rev 16174): Trucha Bug, NAND Access
    IOS61 (rev 5662): No Patches
    IOS62 (rev 6430): No Patches
    IOS70 (rev 16174): Trucha Bug, NAND Access
    IOS80 (rev 16174): Trucha Bug, NAND Access
    IOS202[60] (rev 65535, Info: hermesrodries-v6): Trucha Bug, NAND Access, USB 2.0
    IOS222[38] (rev 4, Info: hermes-v4): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS223[38+37] (rev 4, Info: hermes-v4): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS224[57] (rev 65535, Info: hermesrodries-v6): Trucha Bug, NAND Access, USB 2.0
    IOS236[36] (rev 65535, Info: rev 3351): Trucha Bug, ES Identify, NAND Access
    IOS249[56] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
    IOS250[57] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
    IOS254 (rev 65281): BootMii
    BC v6
    MIOS v10 (DIOS MIOS 2.10)
    Report generated on 10/18/2018.
     
  6. supremanade
    OP

    supremanade Newbie

    Newcomer
    1
    Feb 21, 2018
    Finland
    NANDemulation from SD didn't work either. :( I'm starting to think there is just some unknown variable-X here. I'll try and see if installing to realNAND and dumping the save files to emunand helps but if not then I'm giving up.

    What's really discouraging that nothing seems to even change the outcome, same error no matter what I've tried :P
     
Loading...