DSTwo Question about Firmware

Discussion in 'Supercard' started by Shmylann13, Jun 10, 2010.

Jun 10, 2010
  1. Shmylann13
    OP

    Newcomer Shmylann13 Newbie

    Joined:
    Feb 25, 2009
    Messages:
    3
    Country:
    Canada
    Hey. I've been out of the whole flashing loop for about a year now. Just recently bought a DSi again. When I looked into getting a flash card for it, I read and heard about a bunch of firmware issues and how when Nintendo updates it, flash cards don't work or something along those lines, until an update is released for the card.

    My question is, will the DSTwo work out of the box with the newest DSi firmware, which I believe is 1.5? And if not, do I need another DS unit to update? I read for other devices that you do. And if it does work out of the box with the newest firmware, how will it be for updating in the future if Nintendo releases a new firmware?

    Sorry if this is a redundant question. But thanks for anyone who can answer those questions! =)
     
  2. 9th_Sage

    Member 9th_Sage GBAtemp Maniac

    Joined:
    Apr 30, 2008
    Messages:
    1,481
    Country:
    United States
    As has been said a whole bunch of times, yes, it will work on all known DSi firmwares to date without having to be flashed. [​IMG]
     
  3. Matt140

    Member Matt140 GBAtemp Fan

    Joined:
    Mar 1, 2009
    Messages:
    345
    Location:
    England
    Country:
    United Kingdom
    The latest firmware update (as far as I'm aware) is 1.4, and yes the DSTWO comes pre-flashed to work with it [​IMG]
     
  4. tk_saturn

    Member tk_saturn GBAtemp Psycho!

    Joined:
    Jan 26, 2010
    Messages:
    3,327
    Country:
    United Kingdom
    There is no v1.5 firmware, there may never be a v1.5 firmware. V1.4 was released back in July 30, 2009 and even then it only took ~2 weeks for workaround to be found.

    If firmware 1.5 is released, updating your DSi to it is optional.

    The Acekard for example requires the DS into order to perfrom the firmware update. The DSTWO should be able to update it's firmware indepentantly of the DS, it just uses it for it's power.
     
  5. Shmylann13
    OP

    Newcomer Shmylann13 Newbie

    Joined:
    Feb 25, 2009
    Messages:
    3
    Country:
    Canada
    Thanks so much guys. Fast replies! My favorite! [​IMG]

    Again, sorry if it's been asked before, which I'm very sure it has. Haha.
     
  6. nl255

    Member nl255 GBAtemp Advanced Maniac

    Joined:
    Apr 9, 2004
    Messages:
    1,995
    Country:
    The DSTwo comes with firmware 1.4 (at least mine did). There is a 1.5 update but all it does is fix the MicroSD sometimes not working if you use automatic boot on a DS fat or DS lite as some carts don't initialize the SD card quickly enough. Also unlike some other carts like the CycloDS the firmware is completely seperate from the rest of the cart software and it is not necessary to update the DSTwo firmware when new games come out that need updated AP fixes.
     

Share This Page