1. zephonate

    OP zephonate Member
    Newcomer

    Joined:
    Feb 12, 2017
    Messages:
    12
    Country:
    United States
    Hello all,

    Currently running Luma on a New 3DS, latest firmware. Up until recently (probably just before I updated, but not 100% sure), my DSTWO PLUS, which I use mostly for emulating DS games, was working perfectly fine. Now, all of a sudden, when I put the cartridge into my 3DS, half the time it won't even recognize there's a cart in there, the other half of the time the cartridge/Alex Rider: Stormbreaker will appear, but when I select it, I'm taken to a black error screen with white text telling me I need to restart my system by holding down the power button.

    Through Googling, I've read that I perhaps need to update the DSTWO PLUS' firmware. That said, I'm pretty sure everything on it is updated, since I got it less than a year ago and all the most recent versions of the software seem to be way older. If that is the case, how do I go about doing so, and where can I find the update file? Any and all help would be greatly appreciated.

    Thanks.
     
  2. adrifcastr

    adrifcastr GBAtemp Addict
    Member

    Joined:
    Sep 12, 2016
    Messages:
    2,038
    Country:
    Germany
    first of all flashcards aren't emulators. the games run natively in ds mode since the 3DS got the 3DS,DS and GBA Hardware built in, (armV11 armV9 and armV7 Processor) to answer your question simply use twloader/Another launcher to launch your flashcard
     
    Last edited by adrifcastr, Mar 22, 2017
  3. MrMandraque

    MrMandraque GBAtemp Regular
    Member

    Joined:
    Jun 22, 2015
    Messages:
    130
    Country:
    France
    Hello,
    Eject your DSTwo+, press the power button while 25s, switch on your 3ds, insertion your DSTwo+.
     
  4. Dionicio3

    Dionicio3 The Skiddo
    Member

    Joined:
    Feb 26, 2017
    Messages:
    3,784
    Country:
    United States
    I personally would only use a dstwo on a DS lite/DSi. If you need to run NDS games on a 3DS, just use TWLoader.
     
  5. Distrance

    Distrance 矢澤にこ
    Member

    Joined:
    Nov 23, 2008
    Messages:
    1,147
    Country:
    Finland
    You know the compatability on TWLoader is terrible right? Much better to use a flashcard to play NDS games, if you have one.

    @zephonate Have you done a 9.2 ctr transfer recently for any reason? Doing that would break DS/DSi, which would cause it to not work. That would only explain why you get a black screen though, and not why the cart isn't recognized. As such there may be something wrong with the card. Fixing the DS/DSi can be done by following the troubleshooting section of the 3DS.Guide.

    To update the firmware of the card you need the files, and a DS/DSi console to update the cart with.
     
  6. ElConsolero

    ElConsolero GBAtemp Regular
    Member

    Joined:
    Jan 22, 2014
    Messages:
    103
    Country:
    Gambia, The
    For me, it sounds more like it is a hardware problem. Did you tried your cartridge on a different 3DS/NDS? Check the contacts, maybe they are dirty and cause the connection issue?
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - working, longer, DSTWO