DSTWO and Pokemon Rom Hacks

Discussion in 'Supercard' started by ryonbrink, Jul 2, 2014.

  1. ryonbrink
    OP

    ryonbrink Newbie

    Newcomer
    3
    0
    Jul 2, 2014
    Gambia, The
    Hi everyone,

    I just received my new DSTWO in the mail and went about setting it up following the Beginner's Guide on here. So far any clean DS rom that I've tried on it works just fine, but I've run into a White Screen when I try to load romhacks such as the HG/SS hacks Sacred Gold/Storm Silver.

    My setup:
    Supercard DSTWO (looks legit as far as I can tell) with EOS 1.11 (2012-12-12)
    2GB Kingston Micro-SD
    DSlite

    Aside from loading the OS and two games (Pokemon Pearl, Pokemon SacredGold) onto the card I haven't changed anything about it.
    Has anyone managed to run these hacks on a DSTWO? Is there a patch or a setting I need to fix?

    Thanks in advance for any help!

    EDIT:
    Problem solved.
    In regards to a different problem I stumbled on the information that Kingston SD cards often don't work very well with Flashcards. Went out, bought a SanDisk Class 10 SDHC and now everything is working just right, including the GBA emulator. :)
     
  2. migles

    migles Mei the sexiest bae

    Member
    GBAtemp Patron
    migles is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    6,623
    4,343
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
    did you tried the rom in an emulator to check that is propertely patched?

    some hacks require a save file, make sure you put it in the right place with the right name
     
  3. ryonbrink
    OP

    ryonbrink Newbie

    Newcomer
    3
    0
    Jul 2, 2014
    Gambia, The
    Thanks for your answer. :)
    If I load a savegame onto the card along with the rom I can get the game to work, but it doesn't seem to actually recognize the save. The game starts as if there was no saved game. The .sav file shows up in the game directory, though, when I inspect the card on my computer. It's got the exact same name as the rom.
    If I do start a new game and save it, the next time I start up the DS the same thing happens again. So apparently I can play, but not save. Trying to use the savestates results in a blackscreen when I try to load them.
    Any suggestions about that?

    ETA: The rom works fine in Desmume, as does the clean rom I patched it from. Gonna try the clean HG in the DSTWO now.

    Edit2: The clean HG has the same issue, as does my clean Platinum rom. With both of those putting a save file on the card doesn't change anything. I have noticed that the .sav that the DSTWO creates when trying to start up the game is 512KB while the .sav I get from converting my Desmume save is 1024KB. Could that be causing problems?
     
  4. ryonbrink
    OP

    ryonbrink Newbie

    Newcomer
    3
    0
    Jul 2, 2014
    Gambia, The
    Problem solved.
    In regards to a different problem I stumbled on the information that Kingston SD cards often don't work very well with Flashcards. Went out, bought a SanDisk Class 10 SDHC and now everything is working just right, including the GBA emulator. :)