DSi One - Latest DSi firmware breaks it

Discussion in 'Supercard' started by triforcemario, Nov 1, 2011.

  1. triforcemario
    OP

    triforcemario Newbie

    Newcomer
    4
    0
    Nov 30, 2008
    My brother who owns a Supercard DSi One recently went into the DSi store to download Zelda Four Swords, and he was prompted with an update, which he downloaded, and now his card doesn't work. I tried looking everywhere for updates, but even the latest one I could find still produces errors.

    Does anyone know where I can get the latest firmware? I've already tried this very forum, Filetrip, the official Supercard website and their forums, and so far I've had no luck.
     
  2. naved.islam14

    naved.islam14 Gbatemp's Official Dark Knight™

    Member
    968
    38
    Sep 12, 2009
    Gotham
    Do you have access to a DS?
     
  3. triforcemario
    OP

    triforcemario Newbie

    Newcomer
    4
    0
    Nov 30, 2008
    I'm afraid not, only a DSi and a 3DS.

    Edit: Doesn't work on the 3DS either. Just gives an error saying that an error has ocurred and that I have to turn off the console.
     
  4. Terminator02

    Terminator02 ヽ( 。 ヮ゚)ノ

    Member
    4,517
    309
    Apr 10, 2010
    United States
    Somewhere near monkat
    does the latest download from here work?
     
  5. Luigi2012SM64DS

    Luigi2012SM64DS G-old member

    Banned
    2,060
    309
    Aug 27, 2011
    Canada
    Minecrapt
    you should've joined the temp earilier. weve seen billons of posts about this.use the frimware writer that cam with the ds one and flash it to work with 1.4.3