DSi Hardware Problem

Discussion in 'NDS - Console and Game Discussions' started by Psychopathic, Mar 29, 2011.

Mar 29, 2011

DSi Hardware Problem by Psychopathic at 2:17 AM (664 Views / 0 Likes) 3 replies

  1. Psychopathic
    OP

    Newcomer Psychopathic Advanced Member

    Joined:
    May 29, 2008
    Messages:
    59
    Location:
    PA
    Country:
    United States
    I can't tell if its the battery or what but my DSi when turning it on will show the blue light for a second then the red and then shuts off. I replaced the battery and it did the same thing. Does anybody know what could be wrong?

    Thanks in advance.
     
  2. Slyakin

    Member Slyakin See ya suckers

    Joined:
    Oct 15, 2008
    Messages:
    4,450
    Location:
    Soviet Slyakin
    Country:
    United States
    Have you tried taking out the battery, plugging it into a wall charger and then trying?
     
  3. Psychopathic
    OP

    Newcomer Psychopathic Advanced Member

    Joined:
    May 29, 2008
    Messages:
    59
    Location:
    PA
    Country:
    United States
    With no battery and plugged in the unit does not turn on at all.
     
  4. craiga

    Newcomer craiga Member

    Joined:
    Mar 24, 2011
    Messages:
    22
    Country:
    United Kingdom
    When mine did that it had got wet, (don't ask how but it had something to do with a potty training 2 year old). Only 3 months old and now being used for spare parts.

    You can send them off to Nintendo or your local repair shop. As well as an estimate to repair you will also be told what is wrong with it.
     

Share This Page