1. Jiehfeng

    OP Jiehfeng Netti Netti
    Member

    Joined:
    Aug 15, 2012
    Messages:
    5,285
    Country:
    Sri Lanka
    I can't seem to get Wii Motion Plus games to work properly. I am using an original Wii Remote red with motion plus built in.

    When I play Skyward Sword for example, I can only go into the game by having the nunchuk disconnected, otherwise it would not detect the nunchuk and I have to reset. After connecting the nunchuk by starting the game disconnected, it works and then it tells me to place the remote upside down, and it seems to calibrate fine.

    I then have to point to the screen and press A, pointing here works well and no issues here. The issues start when I go into the game menu, then I cannot control the cursor well enough, it struggles in some directions.

    When playing the game, the sword only moves vertically for me for some reason. Vertically I can move the sword just fine and it is accurate, but when I move the remote left or right, the sword doesn't move.

    I am using a USB powered sensor bar and have it placed on the top of my monitor if that's important.

    Any clue as to how to fix this? I used to be able to play Wii Motion Plus games on this PC just fine, now I'm having issues out of nowhere. Thanks in advance.

    EDIT: Deleting the Dolphin Emulator folder in Documents and deleting the dolphin folder and getting the latest version online didn't work, same issue. In Red Steel 2 for example, I can only swing the remote horizontally, not vertically. :(

    Could my Wii Remote plus be broken?
     
    Last edited by Jiehfeng, Aug 31, 2020
    Scott_pilgrim likes this.
  2. Joom

    Joom  ❤❤❤
    Member

    Joined:
    Jan 8, 2016
    Messages:
    5,988
    Country:
    United States
    Are you using the emulated Bluetooth adapter or the pass through? This could be an issue with your Bluetooth adapter itself. I've read that disabling the remote's speaker helps in some cases because the adapter doesn't have enough bandwidth to handle audio. Sorry I'm not much help right now. I was actually going to set this up for myself later today, so it'll be a learning experience.
     
    Mama Looigi and Jiehfeng like this.
  3. Jiehfeng

    OP Jiehfeng Netti Netti
    Member

    Joined:
    Aug 15, 2012
    Messages:
    5,285
    Country:
    Sri Lanka
    I thought so too and ordered a branded bluetooth adapter which will probably come today or tomorrow, I'll update this thread when I get it, hopefully you're right. Thanks. :)

    EDIT: Oh and yes, emulated. I tried pass through as well but it has the same issue. I'll try turning off the audio on my new bluetooth adapter if it doesn't work on the get go.
     
    Last edited by Jiehfeng, Sep 2, 2020
    Scott_pilgrim likes this.
  4. Jiehfeng

    OP Jiehfeng Netti Netti
    Member

    Joined:
    Aug 15, 2012
    Messages:
    5,285
    Country:
    Sri Lanka
    After trying all kinds of Bluetooth Adapters, 4.0 and 5.0, and a branded Asus BT400, all of them have the same Remote Plus issues. I think it's safe to assume my controller's motion plus is broken.

    Are fake motion plus remotes any good? Does the motion plus in them work well?
     
  5. Joom

    Joom  ❤❤❤
    Member

    Joined:
    Jan 8, 2016
    Messages:
    5,988
    Country:
    United States
    It's hit or miss. It got better with the Wii U. I know a lot of people complained about it on the Wii, though. Also, sorry I haven't reported back. I just moved to Linux and self-compiled Dolphin last night, so I'm gonna see how well it works. I've just gotta dig out a remote and the charging dock.
     
    Jiehfeng likes this.
  6. Jiehfeng

    OP Jiehfeng Netti Netti
    Member

    Joined:
    Aug 15, 2012
    Messages:
    5,285
    Country:
    Sri Lanka
    I just found the issue! It's the frickin batteries, I used two slightly used batteries and all the wii motion plus issues occurred like in the OP, but just now I put in new ones and it's working like a charm lol. Thanks for your help. :)
     
    Joom and KiiWii like this.
  7. Joom

    Joom  ❤❤❤
    Member

    Joined:
    Jan 8, 2016
    Messages:
    5,988
    Country:
    United States
    Wow, whodathunkit? I guess since we're so accustomed to rechargeable lithium ion these days that I don't think we would have ever considered this.
     
    Jiehfeng likes this.
  8. Jiehfeng

    OP Jiehfeng Netti Netti
    Member

    Joined:
    Aug 15, 2012
    Messages:
    5,285
    Country:
    Sri Lanka
    Bad news, even though it seemed to work fine, when I test properly, there is a lot of lag in the Wii Motion Plus like in Red Steel 2. The sword doesn't move accurately and is a little bit glitchy (moves around a lot on its own).

    I have a fake motion plus controller ordered, I'll see if that works properly. If it does, then it's safe to assume my current controller is just bad on many levels.

    --------

    EDIT:
    Nvm, it works properly now. For some reason I have to have the nunchuk disconnected on game boot, and then connect it when I get prompted for it in game. That fixes the lag and everything works fine, weird but eh, it works. :P

    EDIT 2: Looks like the glitchiness is back somehow, guess the nunchuk thing wasn't a fix. Maybe my controller is dying.
     
    Last edited by Jiehfeng, Oct 9, 2020
  9. Joom

    Joom  ❤❤❤
    Member

    Joined:
    Jan 8, 2016
    Messages:
    5,988
    Country:
    United States
    It sounds like it has a poor connection to the receiver. Also, what does your controller configuration look like? Like, instead of choosing to use it as a real remote, have you tried connecting it as an emulated one? Have you tried with the DSU server?

    Edit: Yeah, try connecting it as an emulated remote.
    https://wiki.dolphin-emu.org/index.php?title=DSU_Client#DSU_Server
     
    Last edited by Joom, Oct 10, 2020
  10. Jiehfeng

    OP Jiehfeng Netti Netti
    Member

    Joined:
    Aug 15, 2012
    Messages:
    5,285
    Country:
    Sri Lanka
    Will connecting it as an emulated remote fix my problem? I tried going into Dolphin and checking "Connect Wii Remotes for Emulated Controllers", and selecting Emulated Wii Remote. How do I set up the motion plus?

    EDIT: I forgot to mention it started working again, weirdly enough. Sometimes it goes back to its glitchy movement, and sometimes it just works. I think I'm close to figuring out the issue though, I think in a few days I'll be able to pinpoint what's causing it.
     
    Last edited by Jiehfeng, Oct 10, 2020
  11. Jiehfeng

    OP Jiehfeng Netti Netti
    Member

    Joined:
    Aug 15, 2012
    Messages:
    5,285
    Country:
    Sri Lanka
    Here's a video showing what happens.



    I can't for the life of me figure out what's the issue. Sometimes it won't even calibrate, and then after a while that fixes itself but then the motion isn't right.
     
  12. Joom

    Joom  ❤❤❤
    Member

    Joined:
    Jan 8, 2016
    Messages:
    5,988
    Country:
    United States
    It sounds like something is obstructing the connection to the receiver. Bluetooth isn't the greatest of wireless protocols, and it's very susceptible to interference. I have a similar issue with my Xbone controllers. Nothing at all can be in front of them, or else they just drop out. Like, I can't hold them in my lap and play without dealing with this. I have to make sure they have a clear view of my computer. Are you using a USB receiver? It's possible you have too many USB peripherals connected, causing the bus to run out of bandwidth. I'm just spitballing here, though.
     
    Last edited by Joom, Oct 11, 2020
  13. Jiehfeng

    OP Jiehfeng Netti Netti
    Member

    Joined:
    Aug 15, 2012
    Messages:
    5,285
    Country:
    Sri Lanka
    I am right in front of the USB receiver, nothing is in between. I don't have many USB connections other than a charging usb cable plugged in and a microphone connected to the rear. Just tried using some energizer rechargables fully charged and still no dice, can't get past the calibration screen in Skyward Sword.

    I think it is the controller. I checked the model number and it's the RVL-CNT-01 and not the newer TR version, maybe that has something to do with it. Anyways I'll wait for the knockoff controller which will be arriving in a few weeks and I'll update the thread if if that works or not.
     
  14. Jiehfeng

    OP Jiehfeng Netti Netti
    Member

    Joined:
    Aug 15, 2012
    Messages:
    5,285
    Country:
    Sri Lanka
    New problem, now the remote won't connect to Dolphin. Maybe the controller was indeed dying and just worked time to time, coincidentally with "new batteries" and then in other times not work. I now can't connect how I used to connect (press 1+2 buttons making sure Continuous Scanning is checked).

    EDIT: I removed the USB Bt dongle and reinserted it, now it connects but the same problem is there like in the video I posted earlier.
     
    Last edited by Jiehfeng, Oct 13, 2020
  15. Joom

    Joom  ❤❤❤
    Member

    Joined:
    Jan 8, 2016
    Messages:
    5,988
    Country:
    United States
    Try disconnecting the microphone. I get the feeling that it's commanding all of your bus bandwidth.
     
  16. Jiehfeng

    OP Jiehfeng Netti Netti
    Member

    Joined:
    Aug 15, 2012
    Messages:
    5,285
    Country:
    Sri Lanka
    I did but now I get a different issue I got before I supposedly fixed the remote with new batteries, the motion plus isn't calibrating. Like in Skyward Sword for example, like in the video above, when you lay the remote down, after a second it shows the Wii Remote move icon rotate to the top and then it successfully calibrates. In this instance now, when I lay the remote flat the Wii Remote icon won't move to the top and it doesn't finish calibrating.

    This is an issue I've been encountering time and time again as well, which seems to fix itself but I don't know what fixes it. If this problem does fix itself I will try again making sure the webcam and microphone are disconnected.

    EDIT:

    With fully charged batteries, the motion plus calibration works. I disconnected both the webcam and microphone, and the same issue as the video I posted persists. Is it safe to assume it's the controller? :(

    EDIT 2:

    Fully charged batteries again, this time I can't calibrate yet again. Everything seems to be screaming it's the controller's fault, guess I will only know when my knockoff controller arrives.
     
    Last edited by Jiehfeng, Oct 14, 2020
  17. Jiehfeng

    OP Jiehfeng Netti Netti
    Member

    Joined:
    Aug 15, 2012
    Messages:
    5,285
    Country:
    Sri Lanka
    Ok so I bought a Wii Motion Plus addon and hooked it to an old Wii controller I had, and it works perfectly! So I think I was right in assuming the controller I was using was faulty, sadly.

    Do you have any idea how I could possibly repair the remote's motion plus?
     
  18. Joom

    Joom  ❤❤❤
    Member

    Joined:
    Jan 8, 2016
    Messages:
    5,988
    Country:
    United States
    Jiehfeng likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - properly, Dolphin, working