Do newer machines have worse usb support?

Discussion in 'Wii - Backup Loaders' started by mc2wheels, Aug 29, 2011.

Aug 29, 2011
  1. mc2wheels
    OP

    Newcomer mc2wheels Newbie

    Joined:
    Aug 29, 2011
    Messages:
    2
    Country:
    United States
    Background:
    I have a 3 year old Wii running 4.3U with all updates. I recently bought an older Wii from ebay with 4.2U to use as a netflix machine in my bedroom. I decided to put homebrew and a USB loader on the ebay machine to see how it worked. I started putting our games on the hard drive, and everything works fine. Of course, once my kids saw USB Loader GX, they wanted me to put that on our family room Wii as well. That's when I started noticing a problem.

    My system running 4.3 is a white Wii with a newer version of the optical drive (will not play DVDs). It will play any games from the USB drive (Seagate GoFlex 500GB), but freezes sometimes when I use this machine to continue backing up our games. It worked on many discs, but one of the last ones I did was COD Black OPs... I tried several times, and each time the install process would get about half way through backup to HDD, and then the USB loader would just freeze. Eventually, I brought the drive to the older Wii upstairs and tried it, and it installed to the drive correctly the first time without issue. I brought the drive back downstairs and got it to play easily on the newer Wii. This is bizarre. I saw this happen on a couple other games (usually the bigger ones), if I retried it would work. With Black Ops, I just couldn't get it to finish.

    Then, I started noticing that as my kids play, occasionally other games will just freeze... usually after my 7 year old son has invested some time trying to get past a Super Mario Galaxy level. It only happened a couple of times, and only when playing from USB drive. Eventually, I just swapped the consoles. Now my kids play on the older 4.2 console and have not seen a problem since.

    Both machines were using the exact same USB drive... I only have the one Seagate GoFlex that I was moving between them. Both machines were using the same version of USB Loader GX 2.2 using cIOS 249 (rev21).

    I installed the same cIOS on both machines (although I only really use 249 and 250 for Black Ops)... the following is the same on both in syscheck:
    IOS202[38] (rev 65535, Info: hermes-v5.0): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS222[38] (rev 4, Info: hermes-v4.0): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS223[37] (rev 65535, Info: hermes-v5.0): Trucha Bug, NAND Access, USB 2.0
    IOS224[57] (rev 65535, Info: hermes-v5.0): Trucha Bug, NAND Access, USB 2.0
    IOS236[36] (rev 65535, Info: rev 3351): Trucha Bug, ES Identify, NAND Access
    IOS246[37] (rev 21, Info: rev 21): Trucha Bug, NAND Access, USB 2.0
    IOS247[38] (rev 21, Info: rev 21): Trucha Bug, ES Identify, NAND Access
    IOS248[58] (rev 21, Info: rev 21): Trucha Bug, NAND Access, USB 2.0
    IOS249[56] (rev 21, Info: rev 21): Trucha Bug, NAND Access, USB 2.0
    IOS250[57] (rev 21, Info: rev 21): Trucha Bug, NAND Access, USB 2.0

    So my question is: Do newer Wii's have worse hardware support for USB?

    The only thing I can think of is that the USB port on the newer Wii is problematic. I have never seen any problems on the 4.3 machine. It has never frozen before, or hinted at over heating. I never leave Wii connect on in standby or anything. It has never had a problem reading discs either. It has been problem free except for this issue of installing our games to HDD in USB Loader GX, and the occasional freeze when playing from USB drive.

    Or is there an issue where the cIOS files I am using are less stable on 4.3?

    Anyway, I was more curious than anything else. I know I am a newbie, and no one has any reason to think that it's not just user error. I just find it odd that my 4.3 machine has this issue.
     
  2. shortz1994

    Member shortz1994 GBAtemp Maniac

    Joined:
    Jan 21, 2011
    Messages:
    1,341
    Country:
    United States
    try updating to the d2x 249/57. an d2x 250/57.. most of the usb loader if not all are supporting these cIOS. i see you have r21.
     
  3. mc2wheels
    OP

    Newcomer mc2wheels Newbie

    Joined:
    Aug 29, 2011
    Messages:
    2
    Country:
    United States
    Niice! That worked. I just re-ripped Black Ops on the 4.3 machine. It completed successfully, and I think it was about 100KB/s faster. Thank you so much.


    Now for the follow up dumb question:

    I have seen no problem with the 4.2U Wii. Any reason to upgrade to D2X on that one? What else is in that set cIOS that I might need if I am not seeing USB issues?

    Thanks again. Now I can go clean up my yard from Irene damage.
     
  4. shortz1994

    Member shortz1994 GBAtemp Maniac

    Joined:
    Jan 21, 2011
    Messages:
    1,341
    Country:
    United States
    the d2x cios. allow you not to have alt .dols.. this makes the games alot easier to load. so all the usb loaders moved on to this cios set. hermes are ok. but run mod mii, you'll find it under "hacking forum" it's in the stickies. you'll also want to read the main d2x page (yet another hot fix) this will answer all your questions about d2x.
     

Share This Page