DLDI Patching problem?

Discussion in 'NDS - Emulation and Homebrew' started by Lycanroc, May 19, 2014.

  1. Lycanroc
    OP

    Lycanroc Midnight Wolf

    Member
    2,014
    2,400
    May 11, 2014
    Germany
    Ibbenbüren
    So, I just downloaded the DLDI patching tool, and it doesn't seem to do what I've seen on the pictures of other people doing it. Instead of asking me to choose my flash cart, it just shows white dropping menu:

    http://i.imgur.com/LVHlAEe.png
     
    ComeTurismO likes this.
  2. Isaac

    Isaac American

    Member
    319
    104
    Dec 8, 2012
    United States
    Here? Right here? What about, say... over there?
    What card do you have? If I remember correctly, you need to have the dldi patch in the same directory as the exe.
     
  3. Lycanroc
    OP

    Lycanroc Midnight Wolf

    Member
    2,014
    2,400
    May 11, 2014
    Germany
    Ibbenbüren
    R4
     
    ComeTurismO likes this.
  4. Isaac

    Isaac American

    Member
    319
    104
    Dec 8, 2012
    United States
    Here? Right here? What about, say... over there?
  5. FAST6191

    FAST6191 Techromancer

    pip Reporter
    23,734
    9,604
    Nov 21, 2005
    United Kingdom
    Why are you DLDI patching things? Modern DS slot flash carts should do it automatically. There are still some good reasons for doing it for a select few pieces of homebrew but for the most part it is all automatic.
     
    Isaac likes this.
  6. Lycanroc
    OP

    Lycanroc Midnight Wolf

    Member
    2,014
    2,400
    May 11, 2014
    Germany
    Ibbenbüren
    Well, I need to DLDI patch the Bunjalloo browser in order for it to work, or at least it says so on their website
     
    ComeTurismO likes this.
  7. Lycanroc
    OP

    Lycanroc Midnight Wolf

    Member
    2,014
    2,400
    May 11, 2014
    Germany
    Ibbenbüren
    And thanks, I'll try that
     
    ComeTurismO likes this.
  8. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,580
    8,923
    Oct 27, 2002
    France
    Engine room, learning
    it probably say so because it was required when released.
    Each cart needed its own dldi patch.
    Then each flashcart manufacturer released their firmware update including auto-dldi patching in realtime. You don't need to patch it manually if you are using a recent/updated flashcart firmware.


    First, try without patching it manually and see if file access works fine.
    if it doesn't, you may have to patch it.
     
  9. Lycanroc
    OP

    Lycanroc Midnight Wolf

    Member
    2,014
    2,400
    May 11, 2014
    Germany
    Ibbenbüren
    Yeah, it worked without patching, I have the newest wood firmware for R4. Should've just tried moving it to the SD card from the beginning. Thanks guys!

    [​IMG]
     
    ComeTurismO likes this.