DLDI not working - Please help

Discussion in 'NDS - Nintendo Wi-Fi Connection' started by Frankula, Dec 27, 2008.

Dec 27, 2008
  1. Frankula
    OP

    Newcomer Frankula Newbie

    Joined:
    Dec 26, 2008
    Messages:
    9
    Country:
    United States
    I really need help with my ds r4 card, so if you can help i would really appreciate it. So here is my story.

    So i downloaded the DLDI patch for my R4 card and i patched my homebrew that needed patching via the right click application. Any time i try to connect to the internet (with dsMaps, aim, msn, dsOrganize), it didn't work. So i tried looking into it. I tried to open a homebrew app with dsOrganize but a message came up saying that it could not open the application because it needed "to be patched with DLDI". So i said, "well i know i patched it, maybe that right click application just doesn't work for me." So i downloaded the Win32 application. I patched the files again and it continues to not work or connect to the internet. Can somebody please help me?

    If it makes any difference i am using a DS Phat and i do not have any slot 2 hardware.

    Also i forgot to state that when i search for a connection with dsOrganize, my network does show up. And it doesnt really matter cause i have already connected to Mario Kart WIFI (just to make sure i've done it earlier today as well). Also Everything i've patched seems to work otherwise - and by that i mean i can save files, create, and load. I'm really not sure whats wrong....

    Please help, i would really appreciate it.
     
  2. Another World

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    a real r4 running the last official 1.18 firmware will auto dldi patch your dldi compatable homebrew when it launches. the dldi is part of the firmware and does not need to be in the directory. to have an app load inside of another app (like using moonshell to launch) you need those apps manually patched. this is because the loader is not launching so it can not auto patch. dldi rc will patch over the proper area with a no-patch routine, so your homebrew can not be repatched.

    all of this works -- unless you have a clone/fake r4.

    also i'm not sure what this post has to do with wifi, you should have posted it in the r4 sub section.

    -another world
     

Share This Page