DLCs won't show up(cia)

Discussion in '3DS - Homebrew Development and Emulators' started by pofer, Jan 19, 2016.

  1. pofer
    OP

    pofer GBAtemp Fan

    Member
    326
    104
    Jan 4, 2016
    Spain
    Somewhere around the corner
    So this is a problem a friend is describing to me, since I have no idea of what causes the problem I thought I'd ask her

    He says that , He's trying to install some DLCs (smash Bros in this case) , but he had bought some of those DLCS first (Ryu and mewtwo) , but now that he installs the cia pack with all the DLCs it simply doesn't show up in game

    Before hand ; he says:

    Ive already erased and reinstalled everything and it still won't show up

    ---

    Can anyone lend me a hand here ?

    Thanks a lot !
     


  2. urherenow

    urherenow GBAtemp Addict

    Member
    2,991
    889
    Mar 8, 2009
    United States
    Japan
    use big blue menu (BBM), not FBI.
     
  3. GalladeGuy

    GalladeGuy Freeze Kirby :3

    Member
    2,582
    2,641
    Oct 28, 2015
    United States
    Tell him to uninstall all the DLC he has. Then install the CIA.
     
  4. kevman323

    kevman323 Member

    Newcomer
    45
    20
    Oct 10, 2015
    United States
    I had the same issue. Using bigbluemenu instead of fbi fixed it for me.

    Also remember that accessing eshop or any other Nintendo is service will delete some of your installed dlc.
     
  5. GalladeGuy

    GalladeGuy Freeze Kirby :3

    Member
    2,582
    2,641
    Oct 28, 2015
    United States
    That wouldn't matter. FBI would work perfectly fine.

    EDIT: Okay maybe it would matter. :P
     
    Last edited by GalladeGuy, Jan 19, 2016
  6. kevman323

    kevman323 Member

    Newcomer
    45
    20
    Oct 10, 2015
    United States
    This definitely does make a difference, not sure why.
     
    GalladeGuy likes this.
  7. DaOG

    DaOG Advanced Member

    Newcomer
    53
    28
    Dec 4, 2015
    United States
    Did he try turning off the game and turning it back on.:rofl:
     
    GalladeGuy likes this.
  8. GalladeGuy

    GalladeGuy Freeze Kirby :3

    Member
    2,582
    2,641
    Oct 28, 2015
    United States
    Of course! The answer was staring me right in the face! :P
     
  9. urherenow

    urherenow GBAtemp Addict

    Member
    2,991
    889
    Mar 8, 2009
    United States
    Japan
    NO. It really does not work with FBI. Only BBM or Devmenu.

    FBI will happily install it without error, but it will never show in-game.
     
  10. pofer
    OP

    pofer GBAtemp Fan

    Member
    326
    104
    Jan 4, 2016
    Spain
    Somewhere around the corner
    Alright ! Let me suggest him to use BBM
     
  11. Phanton

    Phanton GBAtemp's Nui lover

    Member
    305
    152
    Sep 9, 2015
    Argentina
    I want this meme dead already, I have all the DLCs and only used FBI since I can't into BBM
     
  12. urherenow

    urherenow GBAtemp Addict

    Member
    2,991
    889
    Mar 8, 2009
    United States
    Japan
    Though shit. If you "can't into BBM" then you don't know what you're doing and it really depends on how the DLC.cia file was made. If you got all Smash DLC using FunkyCIA, it will work ONLY when installed with BBM. https://github.com/Steveice10/FBI/issues/30
     
    Last edited by urherenow, Jan 19, 2016
  13. Justin20020

    Justin20020 GBAtemp Advanced Fan

    Member
    577
    116
    Jun 22, 2015
    Gambia, The
    It worked for me when I delete the update from ssb and install (example 1.1.3 Update cia) and then the dlc. This works for me. If you update the game via eshop, it won't work for me
     
    GalladeGuy likes this.
  14. Phanton

    Phanton GBAtemp's Nui lover

    Member
    305
    152
    Sep 9, 2015
    Argentina
    >haven't had any problems with anything
    Yeah sure
     
  15. TimX24968B

    TimX24968B "That guy"

    Member
    1,373
    278
    Oct 28, 2015
    United States
    Nowhere
    I had this issue, there are 2 things you need. first, make sure you do not have an nnid on emunand (the game wont run from sysnand anyway if its 9.2 or below). Second, open up the dlc shop in game, and it should download. thats how I did it, and it worked for me. If you still have issues, try installing a cia version of smash 3ds and try to get the dlc working in that version first before you try it with a cartridge. This fixed it for me. I also used FBI and it worked fine for me, no need for BBM.

    — Posts automatically merged - Please don't double post! —

    I fixed this by going to the dlc shop in-game, and let it download the dlc. note that I did not have an NNID on emunand or use eshop so that may affect it.

    — Posts automatically merged - Please don't double post! —

    Also, If all of the above fail, try a different dlc pack downloaded from somewhere else, see if that helps
     
  16. Clydefrosch

    Clydefrosch GBAtemp Psycho!

    Member
    4,127
    1,181
    Jan 2, 2009
    Gambia, The
    for me, i had to remove all data that wasnt the game itself, so update data, dlc data, everything.
    then instead of downloading the update from eshop, download a cia with the latest update and after installing that, i installed dlc pack 2, 3 and 4 and it worked.

    though you need to reinstall pack 4 everytime you enter eshop
     
  17. RhythmCat

    RhythmCat GBAtemp Fan

    Member
    423
    94
    Jan 4, 2016
    United States
    I only used FBI and it worked fine.
    O.o
     
  18. urherenow

    urherenow GBAtemp Addict

    Member
    2,991
    889
    Mar 8, 2009
    United States
    Japan
    I'll say it again. It depends on where you got it from and how it was made. When people say they installed DLC, but it doesn't show up in the game, 99 times out of 100, they installed it with FBI. In these cases, the only time installing with BBM doesn't solve the issue, is when people mix and match regions (region spoofed DLC with a Smash.CIA for a specific region, or vice versa, or just plain wrong regions).

    If you dump your own ticket.db after visiting the in-game DLC shop while using your OWN CART, and all game updates from the eshop installed, then download all DLC using said ticket.db and funkyCIA2, you can install the DLC all day long with FBI and it will never give you an error. It still will not show up in-game. Go back and install the same .cia with BBM, and it will show in-game.

    None of this deleting updates or other nonsense. And guess what? Since my game is up to date, from the eshop, and I can actually purchase from the in-game shop, if I want to, I most certainly do have an NNID on my emunand.
     
  19. yusuo

    yusuo GBAtemp Addict

    Member
    2,553
    905
    Oct 19, 2006
    That's abit weird cause I installed it with FBI and it works fine for me
     
  20. urherenow

    urherenow GBAtemp Addict

    Member
    2,991
    889
    Mar 8, 2009
    United States
    Japan
    Read my post above yours. I'm talking about when it doesn't work. Did you make your OWN dlc pack and it works with FBI?