DLC issues

Discussion in 'PSP - Hacking & Homebrew' started by SalvadorOliveira, May 25, 2014.

  1. SalvadorOliveira
    OP

    SalvadorOliveira Member

    Newcomer
    37
    0
    Mar 31, 2012
    ok, so I'm playing Disgaea 2, and got the DLC characters. they're in the right folder (PSP/GAME), and I have NPLoader 0.9 installed and enabled. the game is seeing and recognizing the DLC (though my PSP is seeing it as a game) but it's giving the following error:

    My system software is 5.50 GEN-D3. I didn't mod it myself, but my safe-mode menu has the option to make a Pandora Battery, so I think it's an old mod.

    Why can't I use my DLC?
     
  2. greenlanternx

    greenlanternx Advanced Member

    Newcomer
    57
    12
    Sep 16, 2012
    Chile
    well, I only got this message if I delete the dlc files...
    maybe your dlc files were deleted, or corrupted somehow....
    copy again to the right folder (root_sd/psp/savedata/slus???????/)
     
  3. NicoBlogs

    NicoBlogs GBAtemp Regular

    Member
    289
    89
    Apr 19, 2013
    United States
    USA
    Update your PSP.
     
  4. SalvadorOliveira
    OP

    SalvadorOliveira Member

    Newcomer
    37
    0
    Mar 31, 2012
    corruption's a possibility, but it also happens with ma La Pucelle Ragnarok DLC.

    I tried moving it from the GAME folder to the SAVEDATA folder, like you suggested, but to no avail. my research tells me my game codes are right, though they're ULUS/ULJS instead of SLUS (Disgaea and Ragnarok, respectively). Should I be dumping them into their respective savefile folders, or something?

    also, I'm hesitant to update. I have no idea how to do it, the firmware is old, and I've already done it as best I can with ISO_Tool (which let me start playing Phantom Brave), but I don't know anything past that.
     
  5. NicoBlogs

    NicoBlogs GBAtemp Regular

    Member
    289
    89
    Apr 19, 2013
    United States
    USA
    DLC goes to the GAME folder not savedata
    Disgaea 2 code is ULUS10461
    so the patch should be
    X:\PSP\GAME\ ULUS10461\*dlc files here*

    On pro CFW you just need to have Nodrm enabled on the recovery menu to use the DLC. no need NPLoader.
    DLC usage guide
    PSP Update guide

    DLC Running on PRO CFW

    [​IMG]
     
  6. SalvadorOliveira
    OP

    SalvadorOliveira Member

    Newcomer
    37
    0
    Mar 31, 2012
    ok, looked at the 1st link: I don't have a PRO recovery menu, I have GEN recovery menu. it's green on black instead of red on black.

    also, my system software is 5.50 GEN-D3, as opposed to the example 6.20 PRO-B8. I'm pretty sure I have a completely different hack than what's in your description, and I'm leery about putting one hack over another hack.
     
  7. NicoBlogs

    NicoBlogs GBAtemp Regular

    Member
    289
    89
    Apr 19, 2013
    United States
    USA
    There's a link on my post above that teaches you to update i can do no more for you. :sleep:
     
  8. SalvadorOliveira
    OP

    SalvadorOliveira Member

    Newcomer
    37
    0
    Mar 31, 2012
    you're asking me to update GEN into CFW. if I had a CFW OS on there, or Promethius, as it mentions, I'd smile, thanks you a lot, and proceed.

    however, you're basically asking me to update my Mac into Windows XP, as far as I know.

    I just wanna be absolutely sure I don't brick the damned thing by changing the program used to hack it.
     
  9. ceifadorx

    ceifadorx Advanced Member

    Newcomer
    54
    4
    Aug 16, 2013
    Brazil
    He is telling to update your cfw because the new cfw pro is much better then gen, And the new game doesnt support gen cfw,
    Is the same if you want to play windows 7 only game with windows xp
     
  10. TecXero

    TecXero Technovert

    Member
    2,814
    909
    Apr 13, 2014
    United States
    Mainframe
    CFW doesn't work like that. The steps you'll take will be: 5.50 GEN -> 6.60 OFW -> 6.60 Pro.
    CFW is just a set of modifications to OFW. Those modifications are overwritten or become unused leftovers when you update to later firmware. When you install a new CFW over the firmware you've updated to, it will write everything it needs and remove/overwrite any conflicts with leftovers from GEN, so there's no worries. It will be much easier when you're on a newer firmware.
     
    SalvadorOliveira likes this.