Diablo 3 requiring internet connection

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by pcam90, Oct 31, 2018.

  1. tiliarou

    tiliarou GBAtemp Regular

    Member
    4
    Feb 4, 2018
    France
    Didn't try that, but multiplayer on the same console should work with 4 joy con/controllers I believe. Or did you mean local play with 2 switch ?
     
  2. mdmachine

    mdmachine GBAtemp Regular

    Member
    4
    Jun 15, 2009
    United States
    Local multiplayer works fine.
     
  3. ToastBrt

    ToastBrt Newbie

    Newcomer
    1
    Aug 27, 2018
    Germany
    Did anyone tried it on firmware 4.1?
     
  4. OperationNT

    OperationNT GBAtemp Fan

    Member
    6
    May 1, 2016
    France
    Yes, it doesn't work on FW 4.1 :-(.
     
  5. arcsy

    arcsy Advanced Member

    Newcomer
    5
    Sep 11, 2010
    I'm guessing it's the other way around, guys. If you have a NNID linked to the console, it will ask for an Internet connection at some point...
     
  6. m0rtex

    m0rtex Newbie

    Newcomer
    1
    Apr 1, 2019
    Germany
    Anyone solved this Problems?
     
  7. wurstpistole

    wurstpistole I got 8 warning points

    Member
    12
    Nov 19, 2015
    Gambia, The
    You can't "solve" it. You need to go into airplane mode or disable your connection.
     
  8. t1op

    t1op GBAtemp Regular

    Member
    3
    Nov 13, 2016
    United States
    I had this issue before with certain games that do work offline. I had to set up 90DS in order to connect to the internet but not to Nintendo. Solved the problem for me. Not sure if that will help everyone but it's worth a shot.
     
  9. ZShock

    ZShock Member

    Newcomer
    3
    Oct 15, 2014
    Argentina
    I haven't experienced this problem, and from the start I've been using 90DS. So maybe that's a fix.
     
  10. doofdilla

    doofdilla Member

    Newcomer
    4
    Jun 9, 2018
    United States
    Maybe SXOS "stealth mode" is the culprit? I've heard the same about tales of vesperia and it seemed that disable stealth mode fixed it
     
  11. grcd

    grcd Advanced Member

    Newcomer
    2
    Sep 14, 2009
    Did you try to install both the game and an (unspecified number of) update(s)? If so, try only to install the base game and run it without any updates. Updates can screw things up and need online connection.

    It definitely does not need to connect to start first time. I can confirm this using both the official cartridge and an XCI converted to NSP.
     
    Last edited by grcd, Apr 5, 2019
Quick Reply
Draft saved Draft deleted
Loading...