DevMenu/FBI/BBM not working for a .cia?

Discussion in '3DS - Flashcards & Custom Firmwares' started by jscjml, Jun 29, 2016.

  1. jscjml
    OP

    jscjml Monster Hunter

    Member
    244
    89
    Jan 4, 2015
    United States
    Las Vegas
    I'm trying to install something, and it keeps saying "The cia is invalid". The weird thing is i have installed this cia on my 3DS before without any problems, now it just doesnt work. Should i try other cia installers? Half of my other cias wont install with the same error also...

    11.0 SysNAND A9LH Luma3DS. Does anyone have this problem with random cia's also? If so how did you fix it?
    I already tried reformatting my 3DS SD Card and doing a System Restore, no dice.
    As a workaround i can use the .3ds version of the game with my Gateway but then i'd have to resort to playing everything on the GW Red Card.
     
  2. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    have you initialized the databases by:
    1st-creating a "dbs" folder in Nintendo 3ds-title1-title2
    2sd-putting there the import.db and the title.db
    3rd-going to system settings-data management-nintendo 3ds-software and selecting "restore"
    that should allow you to install the cias
     
  3. jscjml
    OP

    jscjml Monster Hunter

    Member
    244
    89
    Jan 4, 2015
    United States
    Las Vegas
    I already have a title/import.db in my 3DS->Title1->Title2. As for the Restore option i cannot find it in that menu.
    FBI returns the cia with "Invalid NCCH" but the same file works on another 3DS, and this same exact one before i formatted it. :/

    Also freeshop/CIAngel wont install a certain game for me either, if i download the same game (Xenoblade Chronicles or Animal Crossing) in .cia it shoots an error in FBI/DevMenu also.
    Maybe corrupted files during transfer? Fake SD? I dont know cause i have filled this one up to the brim before and had no problems, the only outlier was the SD Adapter i used.
     
    Last edited by jscjml, Jun 29, 2016
  4. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    try deleting THOSE and creating blank ones.
    Also, do you have multiple title1 folders on your nintendo 3ds folder?
     
  5. jscjml
    OP

    jscjml Monster Hunter

    Member
    244
    89
    Jan 4, 2015
    United States
    Las Vegas
    Alright, ill try that out. And no, title1 only has the title2 folder in it.
     
  6. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    I mean, in the "Nintendo 3DS" folder, are there multiple fodlers?
     
  7. jscjml
    OP

    jscjml Monster Hunter

    Member
    244
    89
    Jan 4, 2015
    United States
    Las Vegas
    Yeah, inside Nintendo 3DS is title1 and Private.
     
  8. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    okay, so it should be fine then.
    try creating new databases then
     
  9. jscjml
    OP

    jscjml Monster Hunter

    Member
    244
    89
    Jan 4, 2015
    United States
    Las Vegas
    Will it just recreate the databases if i delete them? I went into Software and couldnt find a Restore option.
     
  10. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    you have to create 2 0 kb files named title.db and import.db , both with the .db extension and put it into a dbs folder located in the title2 folder.
    The restore option comes up in software if you done that correctly
     
  11. jscjml
    OP

    jscjml Monster Hunter

    Member
    244
    89
    Jan 4, 2015
    United States
    Las Vegas
    Just tried that and no luck, "Cert signature or hash check failed"
     
  12. jscjml
    OP

    jscjml Monster Hunter

    Member
    244
    89
    Jan 4, 2015
    United States
    Las Vegas
    bump

    i bought a new SD card, a sandisk 64gb formatted to FAT32/32kb Allocation Size. Still having the same exact problems lol, either Cert signature or hash check failed/This .cia is invalid. Any other suggestions? Also tried a new SD reader, no luck there.

    does anyone think using a different CFW will work? I've been trying both Luma3DS and GW.
    edit: Im going to try and downgrade my SysNAND back to 9.2, that might be the problem. If not i can just restore my other nand backup to 11.0.
     
    Last edited by jscjml, Jul 2, 2016
  13. 2pairofaces

    2pairofaces Newbie

    Newcomer
    8
    1
    Nov 9, 2009
    United States
    Before you go to the trouble of a downgrade, I have a suggestion.
    1. Redownload your .cia from your source of choice. Please do try to find one in a rar format, as I've discovered many, many sources to lack error correction on downloads, whereas when you unrar the .cia winrar or 7zip will tell you if there is a crc error.
    2. Transfer this new cia over before deleting your old one, don't overwrite. Then delete old. Now try your install.
    3. My guess is you had a bad cia transfer, you've replaced your SD card , but that was likely with a bit by bit copy.
    4. Larger .cia files just fail sometimes. Think about 8000000000 bits for 1 gig game, and if anyone of them went wrong, or copied to a bad sector, your install will fail.
     
    jscjml likes this.
  14. jscjml
    OP

    jscjml Monster Hunter

    Member
    244
    89
    Jan 4, 2015
    United States
    Las Vegas
    I tried redownloading the .cia, both from .rar and .cia file and both failed for the same game.
    However, it worked when i changed back to my old microSD before changing to the new one. Weird. I also tried transfering them from different sources, like a sd adapter, a camera that takes a microSD card->computer.
    Whatever though, i give up on this lol. Whatever doesnt install as .cia on my 3DS just gets put on my GW Red Card. It's really annoying but i cant find anything that works. Cant always get what you want with unofficial programs.