DevKitPRO Help

Discussion in 'Wii - Emulation and Homebrew' started by Wozzie, Sep 18, 2009.

Sep 18, 2009

DevKitPRO Help by Wozzie at 3:02 AM (1,258 Views / 0 Likes) 6 replies

  1. Wozzie
    OP

    Newcomer Wozzie Newbie

    Joined:
    Sep 18, 2009
    Messages:
    3
    Country:
    United States
    Mmmk. I've been struggling with these same stupid errors, google is not helpful, so I'm here now.

    I've been trying to recompile SpaceJump's multi forwarding channels since they're a bit outdated for my liking. I've acquired the source, downloaded DevKitPRO 1.5 (latest as of this post), and dropped in the jpeg library aptly mentioned in the forwarder's thread. I've redownloaded, reinstalled, uninstalled, and just about everything under the sun, and no matter what..

    Code:
    > "make" 
    dol.c
    elf.c
    main.c
    c:/devkitpro/dev/wfmedia/source/main.c: In function 'main':
    c:/devkitpro/dev/wfmedia/source/main.c:190: warning: implicit declaration of function 'strspn'
    c:/devkitpro/dev/wfmedia/source/main.c:190: warning: incompatible implicit declaration of built-in function 'strspn'
    c:/devkitpro/dev/wfmedia/source/main.c:238: warning: implicit declaration of function 'valid_elf_image'
    c:/devkitpro/dev/wfmedia/source/main.c:241: warning: implicit declaration of function 'load_elf_image'
    c:/devkitpro/dev/wfmedia/source/main.c:243: warning: implicit declaration of function 'load_dol_image'
    c:/devkitpro/dev/wfmedia/source/main.c:257: warning: implicit declaration of function '__exception_closeall'
    c:/devkitpro/dev/wfmedia/source/main.c: In function 'draw_background':
    c:/devkitpro/dev/wfmedia/source/main.c:270: warning: implicit declaration of function 'memset'
    c:/devkitpro/dev/wfmedia/source/main.c:270: warning: incompatible implicit declaration of built-in function 'memset'
    c:/devkitpro/dev/wfmedia/source/main.c:277: warning: implicit declaration of function 'display_jpeg'
    c:/devkitpro/dev/wfmedia/source/main.c: At top level:
    c:/devkitpro/dev/wfmedia/source/main.c:281: warning: conflicting types for 'display_jpeg'
    c:/devkitpro/dev/wfmedia/source/main.c:277: warning: previous implicit declaration of 'display_jpeg' was here
    c:/devkitpro/dev/wfmedia/source/main.c: In function 'trim':
    c:/devkitpro/dev/wfmedia/source/main.c:308: warning: implicit declaration of function 'strlen'
    c:/devkitpro/dev/wfmedia/source/main.c:308: warning: incompatible implicit declaration of built-in function 'strlen'
    c:/devkitpro/dev/wfmedia/source/main.c:315: warning: implicit declaration of function 'isspace'
    linking ... wfmedia.elf
    output ... wfmedia.dol
    
    > Process Exit Code: 0
    > Time Taken: 00:02
    The output .dol files do not work (it'll bannerbrick actually.) I've got access to Windows XP & 7 and it's the same error regardless. This is all a bit foreign to me, so any advice would be great.
     
  2. kLiNiKaL

    Member kLiNiKaL Dr. Greenthumb

    Joined:
    May 24, 2009
    Messages:
    581
    Location:
    Los Ganjales
    Country:
    Jamaica
    dont quote me on this but it looks like you have the wrong libogc versions possibly

    not sure which versions SpaceJump used however
     
  3. SpaceJump

    Member SpaceJump Where's my new 2D-Metroid?

    Joined:
    Aug 18, 2005
    Messages:
    3,648
    Location:
    Zebes
    Country:
    Germany
    Did you try it with the libogc I linked in my thread?
     
  4. Wozzie
    OP

    Newcomer Wozzie Newbie

    Joined:
    Sep 18, 2009
    Messages:
    3
    Country:
    United States
    Thanks for replying. Yes, I did. I actually get the same errors with or without the libogc library you linked.

    Mainly, here's exactly what I'm doing.. am I missing something?

    Uninstalled DevKitPRO. (Cleaned the folder out, too.)
    Redownloaded & installed DKP1.5, reboot.
    Dragged the libogc folder into the /devkitpro folder. (renamed previous library.)
    Placed the jpeg library into /devkitppc/powerpc-geckko
    Clean, Make.. errors :
     
  5. Wozzie
    OP

    Newcomer Wozzie Newbie

    Joined:
    Sep 18, 2009
    Messages:
    3
    Country:
    United States
    I guess this might be a noobish question, but does DevKitPRO need to be "recompiled" or have the libraries rebuilt into the program? I ran the self-installer to get everything going. I would lead myself to believe that, at least, the errors would be slightly different between the two libogc versions (but perhaps not.)

    Perhaps I should use an older version of DevKitPRO? I've tried 1.50, 1.49, and 1.48 with both prepacked libogc's and SpaceJump's libogc. No matter what is tried, it just seems to go nowhere. I've even tried running it through a VM on my Mac with different Window's versions, and, regardless, the errors remain the same. Please help :
     
  6. SpaceJump

    Member SpaceJump Where's my new 2D-Metroid?

    Joined:
    Aug 18, 2005
    Messages:
    3,648
    Location:
    Zebes
    Country:
    Germany
    I used version 1.4.8. I uploaded my whole devkitpro folder for you. Good luck!
     
  7. kLiNiKaL

    Member kLiNiKaL Dr. Greenthumb

    Joined:
    May 24, 2009
    Messages:
    581
    Location:
    Los Ganjales
    Country:
    Jamaica
    hey Spacejump, ever got to the 9th level on Metroid [​IMG] lol
     

Share This Page