DarkWii Extended 1.0 (fixed) for 4.1E

Discussion in 'Wii - Hacking' started by Aurora Wright, Jul 21, 2009.

Jul 21, 2009
  1. Aurora Wright
    OP

    Member Aurora Wright GBAtemp Maniac

    Joined:
    Aug 13, 2006
    Messages:
    1,392
    Country:
    Italy
    I quickly adapted DarkWii Extended for 4.1, Wii settings work fine.
    The "white Launch button" issue after inserting a disk or switching between a blank disk channel and another one is also fixed (the problem was caused by a RLMC tag in a chanTtl.ash brlan).
    4.1E version here - 4.1U version here.
    - Open NUS Downloader
    - Click on "Generate Certs"
    - Check the "Decrypt contents" box
    - Insert 0000000100000002 in the first textbox and 449 (for NTSC/U) or 450 (for PAL) in the second one
    - Click on "Start NUS Download"
    - When it´s done, close it and launch patch.bat
    - Copy the newly-created FSToolBox folder on the SD
    - With FSToolBox navigate to title/00000001/00000002/content and press + on 0000007b.app (NTSC/U) or 0000007e.app (PAL) to overwrite the original file.
    - Enjoy.
    Credits go to the original author(s).
     


  2. tj_cool

    Supervisor tj_cool Stuff

    Joined:
    Jan 7, 2009
    Messages:
    9,942
    Location:
    This planet
    Country:
    Belgium
    great thanks [​IMG]
     
  3. Blue-K

    Member Blue-K No right of appeal.

    Joined:
    Jun 21, 2008
    Messages:
    2,572
    Location:
    Helvetica
    Country:
    Switzerland
    Seems to works...this theme is the best one, I don't like all the "Matrix/XP/Jurassic/whatever"-Themes, but that one is simply nice [​IMG]. Although the White Button if no Disc is inserted is ugly...

    But good work, thanks [​IMG]


    Btw: You know that this file is illegal, right?
     
  4. 9th_Sage

    Member 9th_Sage GBAtemp Maniac

    Joined:
    Apr 30, 2008
    Messages:
    1,481
    Country:
    United States
    Hmm...what did you do to convert it exactly? I'm not quite up on the theme stuff for the Wii, and I'd love to have the NTSC version of this theme on System Menu 4.1.
     
  5. Aurora Wright
    OP

    Member Aurora Wright GBAtemp Maniac

    Joined:
    Aug 13, 2006
    Messages:
    1,392
    Country:
    Italy
    4.1U version available, it´s untested because I own a PAL Wii but it should work.
    Both archives are now legal.
     
  6. purechaos996

    Member purechaos996 GBAtemp Advanced Fan

    Joined:
    Nov 5, 2008
    Messages:
    765
    Location:
    Connecticut
    Country:
    United States
    anyone have a pics of this theme? Ive never heard of it so I wanna see what it looks like
     
  7. Linuks

    Member Linuks GBAtemp Regular

    Joined:
    Aug 30, 2008
    Messages:
    299
    Location:
    France
    Country:
    France
    Cool, thanks, did you fix the transparency problem with arrows ?

    [​IMG]
     
  8. muzz

    Member muzz GBAtemp Regular

    Joined:
    Jul 22, 2008
    Messages:
    163
    Country:
    United States
    Thanks for NTSC version Davi92...unfortunately I can't test until I am home from work. Maybe someone can confirm before then?
     
  9. WB3000

    Member WB3000 GBAtemp Advanced Fan

    Joined:
    Apr 5, 2007
    Messages:
    668
    Country:
    United States
    This is really awesome, the only potential issue you might want to fix is some directory issues in the batch file. Some things might need quotes to be read properly. I had to move the download to C:\ to get it to work, so presumably there's some quotes missing somewhere.
     
  10. Tagg7

    Member Tagg7 GBAtemp Fan

    Joined:
    Jun 24, 2007
    Messages:
    394
    Country:
    United States
    Both links are broken. [​IMG]
     
  11. smurf

    Newcomer smurf Member

    Joined:
    May 24, 2006
    Messages:
    18
    Country:
    Italy
    Link for pal is good
     
  12. asdf

    Member asdf GBAtemp Advanced Fan

    Joined:
    May 20, 2009
    Messages:
    827
    Location:
    Torrance, CA
    Country:
    United States
    So is the one for NTSC-U.
    EDIT: It worked perfectly, thanks.
     
  13. WB3000

    Member WB3000 GBAtemp Advanced Fan

    Joined:
    Apr 5, 2007
    Messages:
    668
    Country:
    United States
    I can confirm that the 4.1U app is good, it was also useful to debug NUSD's content editor. [​IMG]

    I don't really see any of the changes you mention (white button fix). Perhaps they were left out of your NTSC build? There's also a settings button with abnormally dark text (the Back button in the Wii Settings page).
     
  14. Linuks

    Member Linuks GBAtemp Regular

    Joined:
    Aug 30, 2008
    Messages:
    299
    Location:
    France
    Country:
    France
    The bug was :

    If you press A on the Disc Channel when there is not a disk and then use + or - to switch to an other channel, the "launch" button (I don't know th english name, could be start or something else) of this channel wil be grey.
     
  15. 9th_Sage

    Member 9th_Sage GBAtemp Maniac

    Joined:
    Apr 30, 2008
    Messages:
    1,481
    Country:
    United States
    So what did you use to 'port' the theme to 4.1? [​IMG] Did you extract the individual files and things from the app?
     
  16. loopguy

    Member loopguy GBAtemp Regular

    Joined:
    Mar 19, 2007
    Messages:
    229
    Location:
    Germany
    Country:
    Germany
    good work, thx [​IMG]
     
  17. nico445

    Member nico445 GBAtemp Advanced Fan

    Joined:
    Apr 27, 2008
    Messages:
    579
    Location:
    my house.
    Country:
    Netherlands
    thx [​IMG] now i finally have a wii with another theme [​IMG]
     
  18. morgan200

    Newcomer morgan200 Member

    Joined:
    Jul 13, 2009
    Messages:
    45
    Country:
    Canada
    when i load up fstoolbox everything works fine but i can't open the contents folder to open the .app file. running from cios 36

    EDIT: used mymenu to install. love it. wish i could get my hands on a black case and controller...
     
  19. Aurora Wright
    OP

    Member Aurora Wright GBAtemp Maniac

    Joined:
    Aug 13, 2006
    Messages:
    1,392
    Country:
    Italy
    I copied the modified ash archives in layout/common from the 4.0 theme to the clean 4.1 app, then I unpacked the 4.1 iplsetting.ash, copied the 4.0 theme images and stylesheets and repacked. Finally, I used yaz0dec on chanTtl.ash, unpacked it, fixed the bug in the brlan using benzin, repacked the ash and used yaz0enc.
    Thanks for testing the U version, I can remove the "warning" then [​IMG]
     
  20. Linuks

    Member Linuks GBAtemp Regular

    Joined:
    Aug 30, 2008
    Messages:
    299
    Location:
    France
    Country:
    France
    Thanks, that's great.
    Could you also fix the transparency bug ?
    Arrows' borders are white [​IMG]

    And is there a way to change the healthscreen ?
     

Share This Page