d2x Suddenly causes Black Screen

Discussion in 'Wii - Hacking' started by Hibiro, Jul 16, 2013.

  1. Hibiro
    OP

    Hibiro Member

    Newcomer
    10
    0
    Sep 30, 2009
    Canada
    So I got USB Loader GX Working for most things, and I wanted to see if Metroid Prime Trilogy would work. It didn't. So I looked up how to get it working without the disc, though the compatibility page is still fairly vague on it all.

    Anyway, I tried to install the latest version of d2x, the installer didn't work, kept giving me a DSI exception after the first page. So I did the manual install with WADs. That worked out, but now most of the games that DID work with USB Loader, no longer do. Kirby Collection, Return to Dreamland, and I'm sure a few others, but for the most part, they worked before I installed d2x, but not now.

    Kind of wondering if anyone can help me with this, tell me if maybe I need to install an older or different version of d2x.
     
  2. Hibiro
    OP

    Hibiro Member

    Newcomer
    10
    0
    Sep 30, 2009
    Canada
    I'm also having issues with Super Mario Galaxy 2. The game sorta freezes up after feeding the FIRST Hungry Luma, the music keeps playing, the Luma keeps dancing, but it won't respond to any Wii Remote input, the remote shows it's still connected, but then if I pull out the battery, it doesn't reconnect.
     
  3. calmwaters

    calmwaters Cat's best friend

    Member
    1,718
    375
    May 27, 2013
    United States
    happy land
    USB Loader GX sucks; it always gave me some sort of error when I'd try to play my games. Follow the guide on WiiBrew to make sure you've done everything right.
     
  4. Hibiro
    OP

    Hibiro Member

    Newcomer
    10
    0
    Sep 30, 2009
    Canada
    Confused. What Guide? I've already gone through the process of hacking the Wii. And as I said, the games did work BEFORE changing the cIOS to d2x. So, not quite sure what happened. Some games still work fine, but others don't.
     
  5. natkoden

    natkoden Not a New Member

    Member
    783
    185
    Jul 25, 2006
    Argentina
    For you, maybe. Works flawlessly for me.

    Hibiro, check the bases and the slots, and the config in USB Loader GX.

    d2x v10 beta 52 base 56 slot 249
    d2x v10 beta 53 alt base 57 slot 250

    usb loader gx configured to use 249

    everything works
     
  6. Hibiro
    OP

    Hibiro Member

    Newcomer
    10
    0
    Sep 30, 2009
    Canada
    As I've said, I had to use the WAD installation, since the d2x installer keeps giving me the stupid Code Dump.
    Anyway, I've double-checked and made sure I had the cIOSes installed. I even reinstalled:
    cIOS249[56]-d2x-v10-beta52 and cIOS250[57]-d2x-v10-beta53-alt

    USB Loader is set to use 249. I still get the same problems. Black Screen upon booting up the Kirby games, and the first Hungry Luma crashes Super Mario Galaxy 2 in a weird way. (Still music and movement, but no response from remote.)
     
  7. calmwaters

    calmwaters Cat's best friend

    Member
    1,718
    375
    May 27, 2013
    United States
    happy land
    My d2x has v6 installed. I have base 56 installed on 248 and 57 installed on 247. And you should check the meta.xml file associated with USB Loader Gx. Make sure its default IOS is 248. And make sure you have this file on your SD card: d2x cIOS Installer v3.1.
    You can get it here if you don't: https://code.google.com/p/d2x-cios-installer/downloads/list
     
  8. Hibiro
    OP

    Hibiro Member

    Newcomer
    10
    0
    Sep 30, 2009
    Canada
    I don't see how using 248 would make a difference. I can try with older versions, though I'm using the newere versions of d2x under 249 and 250 as the other guy said. But it seems you didn't pay attention to my statement I've made twice now. I can't use the Installer, it gives me a code dump. And I have gotten it from the proper location.
     
  9. calmwaters

    calmwaters Cat's best friend

    Member
    1,718
    375
    May 27, 2013
    United States
    happy land
    It's giving you a code dump because something isn't installed properly. Like I said, I don't like USB Loader GX. Follow GAF's tutorial on how to install the files you need for making your games run. Here's the website: http://gwht.wikidot.com/ Then, download DMLizard to download your USB loaders.I used to get code dumps; I don't anymore. This tutorial is guaranteed to work; I deleted everything off my SD card and loaded the files in the tutorial on it. I haven't had any problems with my games loading. And if you get a white screen when loading a Wii game, set the video patch to NTSC or whatever type Wii you have. The video patch option is easy to find in WiiFlow, which is why I use it. Hope this helps.
     
  10. Hibiro
    OP

    Hibiro Member

    Newcomer
    10
    0
    Sep 30, 2009
    Canada
    I guess it's a bad-dump issue or something. I did EVERYTHING, BOTH THINGS as suggested, and a good chunk of the games do start up, but the Kirby games and Mario still give me the same issues on both GX and Config.
    I can play Sonic Colors, Pandora's Tower, Sonic Riders, Mario Strikers, and a SLEW of other games.
    Again, Galaxy 2, Return to Dreamland, Kirby Collection, and now The Last Story, and Xenoblade Chronicles don't boot up properly. And as I've said, they worked perfectly fine BEFORE I followed the guide to get Metroid Prime Trilogy to play it's Corruption half. Which was still unsuccessful.
     
  11. calmwaters

    calmwaters Cat's best friend

    Member
    1,718
    375
    May 27, 2013
    United States
    happy land
    Maybe you've got some bad files/rips. Xenoblade and Metroid Prime both work for me. Did you try WiiFlow too? That's all I can say. I was just reading some comments about how WiiFlow is the best loader for these games. Or close to the best one.
     
  12. Hibiro
    OP

    Hibiro Member

    Newcomer
    10
    0
    Sep 30, 2009
    Canada
    Nope. Still no luck. Xenoblade locks up with flashing Reading Disc. I find it hard to believe they'd be bad rips, seeing as they were working before, and I hadn't changed the game files at all.
     
  13. calmwaters

    calmwaters Cat's best friend

    Member
    1,718
    375
    May 27, 2013
    United States
    happy land
    ........I've got no idea..... maybe you should just reinstall them into your usb device..... I promise you, though, if it was working before, then it'll work again.
    It just takes a lot of patience.