D2Pro firmware/SSBB problems

Discussion in 'Wii - Hacking' started by Rice923, Aug 27, 2008.

Aug 27, 2008

D2Pro firmware/SSBB problems by Rice923 at 7:19 AM (1,802 Views / 0 Likes) 7 replies

  1. Rice923
    OP

    Member Rice923 GBAtemp Regular

    Joined:
    Mar 7, 2008
    Messages:
    156
    Country:
    United States
    I installed a D2Pro with wiiclip today along with the ribbon cable. Got a few questions about this.

    1) My ribbon cable is plugged into the d2pro and routed to the outside of the case, but it's just dangling there. Is this setup alright or will something go wrong if I keep it like this?

    2) All games work so far, except for SSBB. I put in the SSBB disk (works fine on my WiiKey Wii), and it prompted for the expected update which I accepted. The game loads fine at the beginning, and then goes to the screen where it tells me to strap on the wiimote. It then goes to a black screen that says "loading" with a small Smash Bros icon rotating. It then proceeds to a white screen and never changes. Occasionally when I insert the SSBB disk, it will spin for about 3 seconds and then stop. The wii then tells me the disk cannot be read and/or tells me to turn off the wii after ejecting. What's the problem with the game? I tried SMG, and it works fine.

    3) I booted up the d2pro utility disk v1.6 (provided by d2pro site) and did the update. There is no noticable dofference in performace. What else do I need to do to get the most up to date d2pro? I do not have a d2prog; do I absolutely need one now?
     
  2. gratefulbuddy

    Member gratefulbuddy amateur lunatic

    Joined:
    Apr 4, 2007
    Messages:
    802
    Location:
    on the wheel
    Country:
    United States
    1) Doubtful there will be problems
    2) Add manual layer break (2084960)
    3) I don't know what you are looking for here. Seems to me, if everything is working (besides SSBB;see above), then you should get to playing games and stop fiddling with the chip.
     
  3. Rice923
    OP

    Member Rice923 GBAtemp Regular

    Joined:
    Mar 7, 2008
    Messages:
    156
    Country:
    United States
    About the manual layer break, I did that on another copy of SSBB for my wiikey. That specific copy ended up not working for the wiikey. Guess I'll have to dig it up from under my desk somewhere and see if it works.
     
  4. SenorClean

    Member SenorClean GBAtemp Advanced Fan

    Joined:
    Mar 21, 2008
    Messages:
    522
    Country:
    Australia
    Could be a video mode thing... have you tried loading it with Gecko OS?
     
  5. Rice923
    OP

    Member Rice923 GBAtemp Regular

    Joined:
    Mar 7, 2008
    Messages:
    156
    Country:
    United States
    I haven't tried the Gecko OS before. Do I simply run it like any other homebrew program, and it will automatically start the game? Also, the game does work but for a short period of time. It gets to the "loading" screen and then a white screen comes up and it freezes. I beleive that is the screen immediately before they show all the characters standing on a cliff.
     
  6. enigmaxp83

    Newcomer enigmaxp83 Newbie

    Joined:
    Aug 20, 2008
    Messages:
    8
    Country:
    United States
    I had the exact same problem with SSBB. It would get to the white screen and then nothing would happen.

    I was able to get it to work by using ImgBurn@4x with Layerbreak 2084960. However, I had to try this on 3 different dvd burners to get it to work. The wii drive is sensitive and the burning speed definitely affected the quality of my burns. My Wii wouldn't even recognize the discs until I slowed the burns down to 6x and even then it didn't get past the White Screen.

    First I used it on a Lite-on DVD Burner, but ImgBurn would fail halfway. Then I tried with a Phillips Laptop DVD DL Drive and it would burn correctly, but I still got the same problem. Finally after using a TSST DVD DL Drive @ 4x it burnt correctly and the white screen disappears to show the intro movie and the copy fully works.

    The media I used throughout all my testing is Memorex 2.4x-8x Speed DVD+R DL Media.

    -As for whether you need d2prog, that depends whether you're experiencing any problems with the firmware version of your d2pro. I had the dvd inching problem so I had to get d2prog to update the firmware. The DVD only updates SPI. Unless you run into a problem that requires firmware flashing (such as my drive inching issue), I'd wait to buy the d2prog.

    Hope this helps.
     
  7. Rice923
    OP

    Member Rice923 GBAtemp Regular

    Joined:
    Mar 7, 2008
    Messages:
    156
    Country:
    United States
    Thank you for that enigmax. I'll probably buy a pack fo DL DVD RW since they're expensive to test with.

    About the inching problem, I modded my friend's wii with d2pro d2e chipset. It immediately had inching problems, but the Utility Disk 1.6 fixed that without a problem. I guess I'll try Utility Disks before purchasing d2prog for problems.

    edit: Do they even sell DVD DL RW?
     
  8. Rice923
    OP

    Member Rice923 GBAtemp Regular

    Joined:
    Mar 7, 2008
    Messages:
    156
    Country:
    United States
    I burned SSBB using the manual layer break 2084960 at 2.4x using Imgburn. The game went to the white screen after the black loading screen, and then the "could not read disk" blah blah green sign came up. What's wrong with what I'm doing? The d2pro was updated using Utility disk 1.6 and the system's firmware is 3.1u. I don't see what I'm doing wrong.

    Side note: I have a perfectly operable copy of SSBB working on a Wiikey 3.1u firmware Wii.
     

Share This Page