CycloDS + GBA Expansion Card?

Discussion in 'CycloDS' started by demib, Oct 1, 2008.

  1. demib
    OP

    demib Newbie

    Newcomer
    2
    0
    Oct 1, 2008
    United States
    Hello,

    I am wondering which Slot 2 GBA expansion cards are compatible with the CycloDS Revolution.

    I was looking at the M3 GBA expansion card, but I am not sure if it works with the CyloDS Revolution.

    Are there any other methods to play GBA games with the Cyclo DS? Can anyone point me in the right direction?

    Thanks!! [​IMG]
     


  2. Ducky

    Ducky QUACKJECTION!

    Member
    1,086
    0
    Oct 13, 2007
    Iceland
    Duckling Land!
    Okay.. Amm I have a cycloDS and I bought an EZFlash3in1 .. Its really usefull together , For that the cyclo just opens any GBA games you have by just opening it up. No homebrew needed.. Only thing needed is the EZFlash 3in1.
    The 3in1 is also comptaible with rumble and internet browser (Opera browser).
    Its also really cheap.
    I suggest you go for a 3in1 if you want GBA games , Cheap and usefull.
     
  3. deciiii

    deciiii Member

    Newcomer
    14
    0
    Aug 20, 2008
    Gambia, The
    i use the m3 gba expansion pack with my cyclo ds cart and it works, but not perfect.
    you have to use a homebrew program (gbaexploader) to load gba files onto the expansion, and then play them. you can manage save files on your slot-1 but thats about it.
    also if you want to use it as a ram expansion note that it is not supported BUT there is a little workaround i found. you just have to start the gbaxploader 2 times in a row with softresetting out of it. cumbersome. but works.

    i guess the EZflash3in1 is the better choice, its gets recommended alot (as seen above [​IMG] )and a lot of people state how good it works with most gba games, slot-1 cards and whatnot!
     
  4. Derak

    Derak Member

    Newcomer
    19
    0
    Jun 22, 2008
    Prague, Czech Republic
    I am using Ewin expansion card and EZ3in1 and both of them working fine, but I recommend EZ3in1 - with Cyclo you don't need any homebrew loader, because Cyclo can use EZ3in1 directly.
     
  5. unz

    unz Chaotic Neutral

    Member
    283
    21
    Jul 14, 2008
    Curmudgeon's quarters
    What Derak said. The 3in1 is supported by the Cyclo's software - so it works straight out of the box with no extra software required.
    M3's GBA Exp. pack works, but you'll have to run GBA Exploader every time you want to use it for anything - which makes it clunky in comparison to the 3in1.
     
  6. demib
    OP

    demib Newbie

    Newcomer
    2
    0
    Oct 1, 2008
    United States
    Thanks, everyone!

    I found the EZ Flash V 3 in 1 online for 23 bucks. Looks like this is the real deal.

    Peace!
     
  7. Jordan10la

    Jordan10la GBAtemp Regular

    Member
    192
    0
    Jul 24, 2008
    Canada
    Also I have to say it's "Evolution" not "Revolution"
     
  8. NatsuMatto

    NatsuMatto GBAtemp Regular

    Member
    144
    0
    Mar 15, 2008
    United States
    I just got a new Cyclo and EZF3n1 last week.

    Every time I try to run the Opera browser, it gives me an error to put the mempack in. Also, whenever I try and enable the rumble features, the game tells me that there is no rumble pack inserted.

    I've used Rudolp's NDS back up tool to extract saves, and have played GBA games successfully... so I'm guessing the memory is THERE. Why is the Cyclo not seeing it? Why isn't the rumble working?

    Any help?
     
  9. Seven

    Seven oh hell no

    Member
    777
    7
    Jun 22, 2007
    United States
    Use the latest GBAExpLoader and put softreset.cevo in the root directory (google for the download!) When you load up GBAExpLoader, press R a couple times till it pulls up a third option page and there you'll see Rumble Levels and an expansion pack option. Select that and shazam, it works as Opera's expansion RAM.
     
  10. NatsuMatto

    NatsuMatto GBAtemp Regular

    Member
    144
    0
    Mar 15, 2008
    United States
    The CycloDS firmware claims to run all this stuff without patching...
     
  11. Seven

    Seven oh hell no

    Member
    777
    7
    Jun 22, 2007
    United States
    Well, using my directions you're not patching anything, silly.

    Never assume everything comes automatically. There was a time when people had to manually patch DLDI, &c.
     
  12. Derak

    Derak Member

    Newcomer
    19
    0
    Jun 22, 2008
    Prague, Czech Republic
    With Cyclo firmware 1.41 you can run Opera browser directly. There is also patch for Opera for EZ3in1, but for me unpatched version is working ok.
     
  13. NatsuMatto

    NatsuMatto GBAtemp Regular

    Member
    144
    0
    Mar 15, 2008
    United States
    I'm not assuming, since the CycloDS manual says it will run Opera automatically.

    Mine, however, DOESN'T. Gives me an error, as I said.

    I contacted Dealwoot... looks like I'll have to send it back.
     
  14. unz

    unz Chaotic Neutral

    Member
    283
    21
    Jul 14, 2008
    Curmudgeon's quarters
    I'm probably barking up the wrong tree here, but it doesn't hurt to ask...

    Are you using European version of the browser, or US version?
    The Euro version will work with the 3in1 , but the US version won't, apparently.

    ...and you are correct. My Cyclo doesn't need any extras to load the browser - apart from the 3in1 itself of course.
     
  15. NatsuMatto

    NatsuMatto GBAtemp Regular

    Member
    144
    0
    Mar 15, 2008
    United States
    Yes, I'm using the (E) version, since the ROM site I frequent doesn't actually HAVE the (U) version.

    This is really frustrating. The 3in1 rumble worked for one day... I can still use the RAM to play GBA games, but it refuses now to work with Opera and doesn't register as a rumble pack for any games.
     
  16. Vague Rant

    Vague Rant Deceptively cute

    Member
    2,052
    414
    Aug 7, 2008
    Melbourne
    There is no (U) version; rather, the (E) and (U) versions are identical. Feel free to rename the (E) ROM to (U), it's the same thing.
     
  17. NatsuMatto

    NatsuMatto GBAtemp Regular

    Member
    144
    0
    Mar 15, 2008
    United States
    that explains a lot.

    personally, I don't care about regions-- I'm easy that way [​IMG] -- I only mentioned it because the previous poster did.
     
  18. unz

    unz Chaotic Neutral

    Member
    283
    21
    Jul 14, 2008
    Curmudgeon's quarters
    Oh okay... I was led to believe there was a (U) version, back when I was researching the 3in1. Must've gotten my wires crossed, I guess. :shrug:

    @ NatsuMatto : As you have the (E) version, I can only suggest you try downloading the browser again, maybe from another site.
    If it still doesn't see the 3in1's RAM, try starting the browser with Rudolph's GBA Exploader, like Seven said.

    Edit: Oh and have you tried taking the 3in1 out of the DS, then reinserting it? Sometimes that helps too.

    If it still fails after all that, then it's pretty safe to say your 3in1 is definitely at fault.
     
  19. NatsuMatto

    NatsuMatto GBAtemp Regular

    Member
    144
    0
    Mar 15, 2008
    United States
    Unz-- yeah, I tried taking it out and putting it back in several times... didn't make a difference.

    What I ended up having to do is run GBA Exploader to get it to work. I know, that's what you are supposed to do on every other card... but the CycloDS SAYS IN THE MANUAL that it will run the rumble feature and the Opera memory pack automatically. It doesn't.

    Some people say that this started with "new" EZFs that came out recently... not sure. At least I got it to work, even if I have to go through that extra step.
     
  20. Rascal

    Rascal GBAtemp Fan

    Member
    429
    0
    Apr 23, 2008
    United States
    Cyclo Firmware 1.5b4 seems to have fixed the problem with newer 3-in-1's. I've had no problems with the NDS Browser, which I did have on 1.5b3, which forced me to use GBA Exploader often.