"CXI Build Failed" trying to dump installed title for Citra

Discussion in '3DS - Homebrew Development and Emulators' started by Insidious611, May 28, 2017.

  1. Insidious611
    OP

    Insidious611 GBAtemp Regular

    Member
    140
    105
    Oct 23, 2010
    United States
    Hi. I'm trying to follow this walkthrough https://citra-emu.org/wiki/dumping-installed-titles/ in order to dump my copy of Ocarina of Time 3D to try out in Citra. Unfortunately, I get to the part where I've found the proper TMD, confirmed it's for Ocarina of Time 3D, hit to "Dump CXI/NDS File"... and it immediately gives me "CXI build failed".

    I thought it might be a space thing, but I have 5GB free on my SD card. I've googled around trying to find if anyone else has gotten this error, no luck.

    I'm using GodMode9 v1.1.8 on a boot9strap'd 2DS.

    I've attempted to dump other titles as well, to the same result.

    EDIT: Tried deleting some things I wasn't using to get it to >8GB free since that's what the walkthrough recommends. Got to 9GB free, still same result.

    EDIT EDIT: Figured it out! If there's no gm9out folder, GodMode9 won't create one for "Dump CXI/NDS File". I had to make it create one. I did so by copying the tmd to gm9out through a different option, which I just did to see what would happen. After doing that and trying to dump the CXI/NDS file again, it worked.
     
    Last edited by Insidious611, May 28, 2017