Hacking Custom SXOS CFW

Which licence you use ?

  • Free Licence by Reacher17

  • Original Licence by TX

  • I would prefer Atmophere


Results are only viewable after voting.

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
2,608
Trophies
2
XP
1,824
Country
United States
But Triangle Triforce Trifecta Triple Triad (that tactics game) doesn't work on SX so the internet agreed it's now shit, right?

I personally don’t think SXOS is shit. I still run 3.1.0b, in dual boot mode, and I’ve converted a significant part of my stash to XCI* but I’m nowhere near finished.

SXOS Haters, don’t look here

*- only those requiring 11.0.0 or below of course.
 

raging_chaos

Well-Known Member
Member
Joined
Oct 27, 2020
Messages
247
Trophies
0
XP
667
Country
United States
SX OS boots because the BCPKG2 partition is FW11.0.0.
No one said otherwise, you're giving information people already know. The fact remains people have spoofed running SXOS on 11.0.1. Spoofed. As said before nothing else ever came from it.

Bringing this back full circle. Will updating sysNAND to 11.0.1 break SX? No. Will updating sysNAND to 12.0.2 or above break SX? If you are on Mariko yes. The only update that completely killed SX compatibility for Mariko was 12.0.2.
 

raging_chaos

Well-Known Member
Member
Joined
Oct 27, 2020
Messages
247
Trophies
0
XP
667
Country
United States
On the conventional way...it will
You're purposely going in circles. What part of only 12.0.2 breaks SX compatibility on v2 units are you having difficulty understanding? Having a sysNAND on 11.0.1 on any Switch has never stopped an SX emuNAND on 11.0.0 from working, and as far as Eristas go it will always continue to work. Only v2 units completely break when updating to 12.0.2.

Firmware 12.0.2 is live
Do not update until further notice. This update does break Atmosphere.
Package1 has been updated, and they burnt a fuse.
SX users: Anything requiring 11.0.1+ can still be ignored/bypassed for the time being.
Do not update sysNAND to 12.0.2. This will break emuNAND!
Edit: Let me clarify something.
Updating sysNAND on Erista(v1) consoles is completely fine. The emuNAND will still work.
Updating sysNAND on Mariko/Lite(v2) consoles will break the emuNAND.
Anyone that was on their Discord would remember that post. V2 users had to decide whether to update to keep playing online while permanently migrating SX to Atmosphere or not update and stay offline forever. There are plenty of posts of users picking to not update their Mariko sysNAND past 11.0.1 and instead choosing to buy another Switch for online play (I bet most of those ended up with an OLED).
 
Last edited by raging_chaos,

isoboy

Well-Known Member
Member
Joined
Dec 23, 2016
Messages
1,122
Trophies
0
XP
2,022
Country
United States
I personally don’t think SXOS is shit. I still run 3.1.0b, in dual boot mode, and I’ve converted a significant part of my stash to XCI* but I’m nowhere near finished.

SXOS Haters, don’t look here

*- only those requiring 11.0.0 or below of course.
I'm on SX with 11 myself. I'm too lazy to jump over yet.
 

angrynewraze

Well-Known Member
Newcomer
Joined
May 27, 2020
Messages
91
Trophies
0
Age
32
XP
130
Country
United States
Lol? Bullshit. Sx os doesn't work on higher firmwares. Doesn't matter if you use emuMMC or sysMMC. And by the way, sx os also doesn't work on 11.0.1 ;)
Actually what your saying is complete bullshit bc on a previous switch I had emunand on 11.0(sxos) and sysnand on 12.1 and sxos still booted just fine. But in order to do the initial full boot of sxos I had to downgrade the sysnand to 11.0 but after the initial full boot of sxos and sxos had been running for a while I upgraded sysnand back to newest 12 update at the time and sxos still booted just fine
 
Last edited by angrynewraze,

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
2,608
Trophies
2
XP
1,824
Country
United States
Actually what your saying is complete bullshit bc on a previous switch I had emunand on 11.0(sxos) and sysnand on 12.1 and sxos still booted just fine. But in order to do the initial full boot of sxos I had to downgrade the sysnand to 11.0 but after the initial full boot of sxos and sxos had been running for a while I upgraded sysnand back to newest 12 update at the time and sxos still booted just fine

Note that this is from my experience with my V1 switch. Maybe V2 is different?

e: Mariko is absolutely different. Do not upgrade Sysnand to 12.0.2+ on Mariko.

if you are on Erista…
You can absolutely upgrade your Sysnand to 14.1.1 and subsequently install SXOS (at any time you please) on an Emunand downgraded to 11.0.0. The two *nands and completely decoupled. If you had any issues with installing on your 11.0.0 Emunand it will have been unrelated to what was on your Sysnand.
 
Last edited by binkinator,

tlfrance

Member
Newcomer
Joined
May 7, 2022
Messages
8
Trophies
0
Age
50
Location
paris
XP
15
Country
France
Hello. I'm using Atmosphere-Vs-Sxos bootloader with emunand for sxos & Atmosphere under 11.0.0. I would like to upgrade Atmosphere to 1.2.5 version. But fusee-primary no longer exists in atmo version > 1.0 , but "Atmosphere-Vs-Sxos" seems to boot only on fusee-primary.bin only.

@Jonoxley : Is there already planned "Atmosphere-Vs-Sxos" upgrade for latest Atmosphere version support?
Thank you for your great job
 

tlfrance

Member
Newcomer
Joined
May 7, 2022
Messages
8
Trophies
0
Age
50
Location
paris
XP
15
Country
France
Hello. I'm using Atmosphere-Vs-Sxos bootloader with emunand for sxos & Atmosphere under 11.0.0. I would like to upgrade Atmosphere to 1.2.5 version. But fusee-primary no longer exists in atmo version > 1.0 , but "Atmosphere-Vs-Sxos" seems to boot only on fusee-primary.bin only.

@Jonoxley : Is there already planned "Atmosphere-Vs-Sxos" upgrade for latest Atmosphere version support?
Thank you for your great job
 

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
2,608
Trophies
2
XP
1,824
Country
United States
Hello. I'm using Atmosphere-Vs-Sxos bootloader with emunand for sxos & Atmosphere under 11.0.0. I would like to upgrade Atmosphere to 1.2.5 version. But fusee-primary no longer exists in atmo version > 1.0 , but "Atmosphere-Vs-Sxos" seems to boot only on fusee-primary.bin only.

@Jonoxley : Is there already planned "Atmosphere-Vs-Sxos" upgrade for latest Atmosphere version support?
Thank you for your great job
I’m confused a bit here. Atmos-vs-SXOS uses the SXOS boot binary rather than anything to do with Atmosphere. Since SXOS will never upgrade past 11.0.0 there will never need to be an upgrade of Amos-vs-SXOS.

My screenshots above using AvS are from my very recently upgraded dual boot (Atmos 1.3.0 and SXOS 3.1.0b) V1 Switch. https://gbatemp.net/threads/custom-sxos-cfw.588020/post-9806543

That said, you are seeing something different so I would like to ask, how are you determining the need for fusee-primary.bin?
 

tlfrance

Member
Newcomer
Joined
May 7, 2022
Messages
8
Trophies
0
Age
50
Location
paris
XP
15
Country
France
I’m confused a bit here. Atmos-vs-SXOS uses the SXOS boot binary rather than anything to do with Atmosphere. Since SXOS will never upgrade past 11.0.0 there will never need to be an upgrade of Amos-vs-SXOS.

My screenshots above using AvS are from my very recently upgraded dual boot (Atmos 1.3.0 and SXOS 3.1.0b) V1 Switch.

That said, you are seeing something different so I would like to ask, how are you determining the need for fusee-primary.bin?

Hi @binkinator
,
For now i use AvS dual boot with Atmos 0.19.5 ans SXOS 3.1.0b V1 Switch . Atmos & sxos have theire proper emunand.
You said you have upgraded to Atmos 1.3.0 & sxos 3.1.0b, and that's exactly i want to do.
First, i've prepared my SD card like that :
  • Download AsV from github (Atmosphere-Vs-Sxos) (emunand No Auto boot.dat + the sd card setup files from oxley192)
  • Install all on my sdcard
  • Migrate emunand for atmos (have sxos emunand)
  • recopy sxos emunand (to have 2 separate emunand )
All working well, and know i would like to upgrade atmos 1.3.0 . So I have done:
  • Download Atmos 1.3.0 zip + fusee.bin (install all into Atmosphere folder)
  • Download sigpatch 1.1.1 FW13.0.0 zip (install under root sdcard)

When boot, i select Atmosphere, but i have error (boot)

1st question : Is my install i done is OK ? Maybe i've forget something .

I'll capture my error screenshot if neded.
Anyway, thanks blinkinator for your help.
1st question : Is my install i done is OK ? Maybe i've forget something .

I'll capture my error screenshot if neded.
Anyway, thanks blinkinator for your help.
 
Last edited by tlfrance,

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
2,608
Trophies
2
XP
1,824
Country
United States
Hi @binkinator
,
For now i use AvS dual boot with Atmos 0.19.5 ans SXOS 3.1.0b V1 Switch . Atmos & sxos have theire proper emunand.
You said you have upgraded to Atmos 1.3.0 & sxos 3.1.0b, and that's exactly i want to do.
First, i've prepared my SD card like that :
  • Download AsV from github (Atmosphere-Vs-Sxos) (emunand No Auto boot.dat + the sd card setup files from oxley192)
  • Install all on my sdcard
  • Migrate emunand for atmos (have sxos emunand)
  • recopy sxos emunand (to have 2 separate emunand )
All working well, and know i would like to upgrade atmos 1.3.0 . So I have done:
  • Download Atmos 1.3.0 zip + fusee.bin (install all into Atmosphere folder)
  • Download sigpatch 1.1.1 FW13.0.0 zip (install under root sdcard)

When boot, i select Atmosphere, but i have error (boot)

1st question : Is my install i done is OK ? Maybe i've forget something .

I'll capture my error screenshot if neded.
Anyway, thanks blinkinator for your help.
1st question : Is my install i done is OK ? Maybe i've forget something .

I'll capture my error screenshot if neded.
Anyway, thanks blinkinator for your help.

Let’s take this CFW troubleshooting over here: https://gbatemp.net/threads/switch-noob-paradise-ask-questions-here.488277/page-1616#post-9819937
 
General chit-chat
Help Users
  • mthrnite @ mthrnite:
    well that's why i got a gas one too, most times i can use the electric everyday, overnight charge
    Gift
  • mthrnite @ mthrnite:
    gotta go far sometimes tho
    Gift
  • mthrnite @ mthrnite:
    and the lectric only goes 90 miles
    Gift
  • KenniesNewName @ KenniesNewName:
    Imagine being 1 mile away from a charge station and you gotta call a tow truck just to go their
    Gift
  • Dark_Phoras @ Dark_Phoras:
    That can happen with a gas-powered car
    Gift
  • mthrnite @ mthrnite:
    i've had it a few years now and never been stuck due to battery
    Gift
  • KenniesNewName @ KenniesNewName:
    You can at least walk their to get gas
    Gift
  • mthrnite @ mthrnite:
    had a flat once tho, that was a small nightmare
    Gift
  • KenniesNewName @ KenniesNewName:
    I'd like to fill my gas container with electricity pls
    Gift
  • Dark_Phoras @ Dark_Phoras:
    I've changed a flat once, it was so much easier than I thought.
    Gift
  • mthrnite @ mthrnite:
    only noobs run outta batt
    Gift
  • mthrnite @ mthrnite:
    i can change a flat but the fiat don't got a spare
    Gift
  • KenniesNewName @ KenniesNewName:
    I don't know why tesla doesn't have emergency battery replacements you can charge separate just in case of those emergency situations
    Gift
  • mthrnite @ mthrnite:
    they give you what amounts to fix-a-flat foam
    Gift
  • Dark_Phoras @ Dark_Phoras:
    Fiat is like the bottom line
    Gift
  • mthrnite @ mthrnite:
    yeah they cheap
    Gift
  • mthrnite @ mthrnite:
    fun as fuck tho
    Gift
  • KenniesNewName @ KenniesNewName:
    That's what I love about my 04 corolla cheap everything and availability on parts
    +1
    Gift
  • KenniesNewName @ KenniesNewName:
    They made it super easy to change things out also
    Gift
  • mthrnite @ mthrnite:
    always wanted a toyota 323, it'd be dumb to get one now tho
    Gift
  • Dark_Phoras @ Dark_Phoras:
    Toyota, they are pretty cars and they seem very reliable. I see early 90s or late 80s Toyotas around still
    Gift
  • Dark_Phoras @ Dark_Phoras:
    Not like 1 or 2 cars that someone took very good care of, but several of them that seem used day-to-day
    Gift
  • KenniesNewName @ KenniesNewName:
    Wanna replace headlights? Just unbolt the front bumper
    Gift
  • Dark_Phoras @ Dark_Phoras:
    A friend of mine drove a 1987 Corolla, gave me a ride and it was steadier than I expected - and he was high
    Gift
  • KenniesNewName @ KenniesNewName:
    My engine is shaking a bit more lately though
    Gift
    KenniesNewName @ KenniesNewName: My engine is shaking a bit more lately though