CrazyIntro V0.31

Discussion in 'Wii - Hacking' started by WiiCrazy, Feb 20, 2009.

Feb 20, 2009

CrazyIntro V0.31 by WiiCrazy at 11:32 PM (14,805 Views / 0 Likes) 111 replies

  1. WiiCrazy
    OP

    Member WiiCrazy Be water my friend!

    Joined:
    May 8, 2008
    Messages:
    2,391
    Location:
    Istanbul
    Country:
    Turkey

    http://wiicrazy.tepetaklak.com/index.php/2...31/crazy-intro/

    Here is the readme :

    -=-=-=-=-=-=-=-=-=-=-= CrazyIntro POC with Video v0.32 -=-=-=-=-=-=-=-=-=-=-=-=

    22/02/2009 WiiCrazy (I.R.on)
    ---------------------------------------------------------------
    Changes :
    * Garbled display at the start and in the end issue is solved
    * No multiple wiimote clicking, pressing a single button will work
    * You can have more than one video configured, just delimit the filenames with
    semicolon.
    Like this,
    Program will randomly select the video file and play...

    -=-=-=-=-=-=-=-=-=-=-= CrazyIntro POC with Video v0.31 -=-=-=-=-=-=-=-=-=-=-=-=

    21/02/2009 WiiCrazy (I.R.on)
    ---------------------------------------------------------------
    This is basically proof of concept CrazyIntro with video support. In this
    version mp3/jpeg stuff is deliberately taken off. Currently it's just a rip off
    from mplayerwii...

    CrazyIntro.xml config file can be used for direct channel launching as usual.
    A new config element named VideoFile added, you can define the boot video as the
    filename element of VideoFile tag. An example config file and boot video
    provided in the archive.

    Sources are left out as usual because they are messy... I'll release
    them as soon as I get them at the quality I expect from any published source.

    Current bugs & glitches:

    1. Mplayerwii build is rather bulky (which preloader doesn't like)
    so I compressed the dol which makes the initial display garbled.

    2. You need to press twice on wiimote to launch channels/hbc/system
    menu. Though if it's a quick video you don't need to press anything,
    the thing will automatically load system menu when video finished.

    Thanks :
    MickeyBlue (for the example video included in the archive)
    My wife

    -=-=-=-=-=-=-=-=-=-=-= CrazyIntro POC with Video v0.31 -=-=-=-=-=-=-=-=-=-=-=-=

    LEGAL DISCLAIMER
    AUTHOR OF THIS PROGRAM CAN NOT BE HELD RESPONSIBLE FOR ANY
    DAMAGES THIS PROGRAM MAY CAUSE.
     


  2. _Contra_

    Member _Contra_ GBAtemp Fan

    Joined:
    Feb 11, 2009
    Messages:
    315
    Country:
    Italy
    thanks [​IMG]

    Good [​IMG]
     
  3. ether2802

    Former Staff ether2802 we have the techno...!!

    Joined:
    Oct 14, 2007
    Messages:
    4,350
    Location:
    Pto. Vallarta
    Country:
    Mexico
    Bravo...!! [​IMG]
     
  4. Scolor

    Member Scolor GBAtemp Regular

    Joined:
    Nov 7, 2008
    Messages:
    172
    Country:
    Italy
    Very nice. Also, I love Death Note, so it's nicer ! XD
     
  5. BL4Z3D247

    Member BL4Z3D247 GBAtemp Stoner

    Joined:
    Oct 22, 2008
    Messages:
    614
    Location:
    I'm so high I don't even know!
    Country:
    United States
    aww you big softy you [​IMG]

    good work as always [​IMG]
     
  6. MickeyBlue

    Member MickeyBlue GBAtemp Regular

    Joined:
    Oct 21, 2008
    Messages:
    103
    Country:
    Belgium
    No problem, it is a pleasure [​IMG]
     
  7. WiiCrazy
    OP

    Member WiiCrazy Be water my friend!

    Joined:
    May 8, 2008
    Messages:
    2,391
    Location:
    Istanbul
    Country:
    Turkey
    You'll understand what I mean in that thanks line when you get married [​IMG]
    It's unusual stuff for one to take his time and work on something like this... at least for me [​IMG]
     
  8. m-tek

    Member m-tek GBAtemp Regular

    Joined:
    Dec 29, 2008
    Messages:
    176
    Location:
    Manchester
    Country:
    United Kingdom
    right ..what am i missing??

    im just getting a black screen then system menu??
     
  9. WiiCrazy
    OP

    Member WiiCrazy Be water my friend!

    Joined:
    May 8, 2008
    Messages:
    2,391
    Location:
    Istanbul
    Country:
    Turkey
    You need to copy crazyintro.xml and boot.wmv to the root of your sd card. If it can't find the configuration file it will return to the system menu directly...

    ps: Ok, now tested and it works... you possibly missed the configuration file
     
  10. m-tek

    Member m-tek GBAtemp Regular

    Joined:
    Dec 29, 2008
    Messages:
    176
    Location:
    Manchester
    Country:
    United Kingdom
    I have all 3 files in the root....!!
     
  11. WiiCrazy
    OP

    Member WiiCrazy Be water my friend!

    Joined:
    May 8, 2008
    Messages:
    2,391
    Location:
    Istanbul
    Country:
    Turkey
    And installed CrazyIntroVideo.dol using preloader install/file option?

    Tested this on my two wiis, one ntsc and one pal... it works on both... Don't know why it fails on you...

    Anyone else can confirm that this works?
     
  12. m-tek

    Member m-tek GBAtemp Regular

    Joined:
    Dec 29, 2008
    Messages:
    176
    Location:
    Manchester
    Country:
    United Kingdom
    Installed just as previous versions....

    strange!!

    just went back to crazyintro.dol and that works...
     
  13. WiiCrazy
    OP

    Member WiiCrazy Be water my friend!

    Joined:
    May 8, 2008
    Messages:
    2,391
    Location:
    Istanbul
    Country:
    Turkey
    This one uses old fat interface, do you have anything inserted in usb slots? maybe it searches for the files in another fat device...

    ps: well tested plugging in a flash disc and still boots... by the way are you using the video in the archive or a custom one?
     
  14. m-tek

    Member m-tek GBAtemp Regular

    Joined:
    Dec 29, 2008
    Messages:
    176
    Location:
    Manchester
    Country:
    United Kingdom
    just unplugged everything (usb and gc) ... just the same ...

    its as if it cant find the config file....

    V0.3 works for me...
     
  15. Tichinde925

    Member Tichinde925 Marth Ditto Money Match?

    Joined:
    Jul 14, 2008
    Messages:
    1,096
    Location:
    Warwick, Rhode Island
    Country:
    United States
    I now have an Xbox360 / just the startup lol...
     
  16. m-tek

    Member m-tek GBAtemp Regular

    Joined:
    Dec 29, 2008
    Messages:
    176
    Location:
    Manchester
    Country:
    United Kingdom
    using all 3 original files....

    edit,..

    working now.... I reformatted my sd card....

    excellent stuff!!
     
  17. WiiCrazy
    OP

    Member WiiCrazy Be water my friend!

    Joined:
    May 8, 2008
    Messages:
    2,391
    Location:
    Istanbul
    Country:
    Turkey

    by the way Tichinde, do you confirm that it works?
     
  18. m-tek

    Member m-tek GBAtemp Regular

    Joined:
    Dec 29, 2008
    Messages:
    176
    Location:
    Manchester
    Country:
    United Kingdom
    you missed my edit!!

    its working after a format of the sd card!!

    cheers and good work!!
     
  19. WiiCrazy
    OP

    Member WiiCrazy Be water my friend!

    Joined:
    May 8, 2008
    Messages:
    2,391
    Location:
    Istanbul
    Country:
    Turkey
    Well seen your edit, glad to see now you got it running...
    Thanks for the responses btw
     
  20. Tichinde925

    Member Tichinde925 Marth Ditto Money Match?

    Joined:
    Jul 14, 2008
    Messages:
    1,096
    Location:
    Warwick, Rhode Island
    Country:
    United States
    Yes its working. My video is 5 MB.

    Had to convert it to a .wmv and make it 640 X 480.

    I dont like the garbling before and after the vid though.
     

Share This Page