connecting to internet on RXtools

Discussion in '3DS - Homebrew Development and Emulators' started by Mrzeldaootfan, May 18, 2016.

  1. Mrzeldaootfan
    OP

    Mrzeldaootfan GBAtemp Regular

    Member
    137
    6
    May 10, 2016
    United States
    HI i am running RXtools and booting with sysnand, i believe i do not have emunand setup, I am on 9.2.0.20 FW, i was wondering if there was a Homebrew OR cia that can connect me to the internet on Games like pokemon alpha saphire
    CTR-HTTPWN will not work
     


  2. Trolling

    Trolling This Username is taken. Problem?

    Member
    281
    361
    Jul 29, 2012
    Netherlands
    Behind you
    What's wrong with the 3DS default internet connection?

    Ps: Use Luma instead of OutdatedTools.
     
    Last edited by Trolling, May 18, 2016
    hobbledehoy899, Xiphiidae and MelonGx like this.
  3. Mrzeldaootfan
    OP

    Mrzeldaootfan GBAtemp Regular

    Member
    137
    6
    May 10, 2016
    United States
    It wont let me connect to the internet unless i update
     
  4. Trolling

    Trolling This Username is taken. Problem?

    Member
    281
    361
    Jul 29, 2012
    Netherlands
    Behind you
    You have to be on the latest firmware to play online.
    Update your emunand to the latest firmware to solve your problem.

    And use LumaCFW. It's decades better than RXTools
     
    Xiphiidae and MelonGx like this.
  5. Mrzeldaootfan
    OP

    Mrzeldaootfan GBAtemp Regular

    Member
    137
    6
    May 10, 2016
    United States
    then i wont be able to use my homebrew . . .
     
  6. Davidosky99

    Davidosky99 Eevee :3

    Banned
    2,582
    1,570
    Jun 7, 2015
    Porto
    Use luma3ds
     
    MelonGx likes this.
  7. Xiphiidae

    Xiphiidae ξίφος εἶδος

    Member
    2,080
    1,016
    Sep 13, 2009
    Australia
    I don't think you understand how emunand works.

    Edit — Your options are:
    1. Install A9LH to use updated sysnand.
    2. Set up emunand (use Luma or something, not Rxtools)
     
    Last edited by Xiphiidae, May 18, 2016
    MelonGx likes this.
  8. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,634
    439
    Jan 8, 2009
    China
    1) Duplicate your SysNAND to EmuNAND
    2) Withdraw your SD card and format SysNAND
    (You MUST format SysNAND without inserting SD, otherwise your game data will be lost!)
    3) Install Menuhax / A9LH on your formatted SysNAND
    4) Upgrade EmuNAND to 11.0
    That makes your everything work.
     
    Last edited by MelonGx, May 18, 2016
    Ev1l0rd likes this.
  9. Ev1l0rd

    Ev1l0rd (⌐◥▶◀◤) Knight of Void

    Member
    1,031
    754
    Oct 26, 2015
    Netherlands
    Land of Darkness and Bounty
    If you're running from SysNAND (which is a bad idea), just go for a9lh. A9lh makes SysNAND safer and is easy to set up (all bricks have been due to human error).

    Also, if you aren't sure if you have an EmuNAND set up, check your SD card in a partition manager (personal recommendation: gparted). There should be an empty space area or a second partition. That area is an EmuNAND.
     
    MelonGx likes this.
  10. Mrzeldaootfan
    OP

    Mrzeldaootfan GBAtemp Regular

    Member
    137
    6
    May 10, 2016
    United States
    yeah its 13.9 instead of 14.9 GB
     
  11. Ev1l0rd

    Ev1l0rd (⌐◥▶◀◤) Knight of Void

    Member
    1,031
    754
    Oct 26, 2015
    Netherlands
    Land of Darkness and Bounty
    Then you have an EmuNAND. Could you try booting into it? (Hold L at boot, select the first option and then boot into EmuNAND).
     
  12. Mrzeldaootfan
    OP

    Mrzeldaootfan GBAtemp Regular

    Member
    137
    6
    May 10, 2016
    United States
    ok, should i try when booting into rxtools? i will try it when im done installing a animal crossing new leaf Cia, its almost finished
     
  13. Ev1l0rd

    Ev1l0rd (⌐◥▶◀◤) Knight of Void

    Member
    1,031
    754
    Oct 26, 2015
    Netherlands
    Land of Darkness and Bounty
    Yep. Also, do you have an o3ds or an n3ds? If you have an N3ds, you have to switch to luma3ds because RXTools has some issues with later system versions last time I heard.

    (I recommend putting this in your sig for in the future, here is an example:
    CFW TYPE | FW | O3DS/N3DS | CFW )
     
  14. Mrzeldaootfan
    OP

    Mrzeldaootfan GBAtemp Regular

    Member
    137
    6
    May 10, 2016
    United States
    i have an o3ds

    — Posts automatically merged - Please don't double post! —

    It tells me no emunand detected on the next slot it tells me

    "Press X to apply patches and reboot the console and rxmonde on sysnand"
     
  15. SANNIC789

    SANNIC789 GBAtemp Advanced Fan

    Member
    704
    91
    Oct 3, 2015
    United States
    luma 3ds is not working rn with internet
     
  16. Ev1l0rd

    Ev1l0rd (⌐◥▶◀◤) Knight of Void

    Member
    1,031
    754
    Oct 26, 2015
    Netherlands
    Land of Darkness and Bounty
    Then you don't have an EmuNAND or it didn't get set up properly. Follow a guide to set one up. There are more than enough here on GBATemp. Make sure to backup the contents of your SD card before beginning (and dump SysNAND just in case). After you've set it up and serparated NANDs, you can safely update EmuNAND. If you want to have an updated SysNAND instead, follow Plailect's Guide for a9lhax.

    — Posts automatically merged - Please don't double post! —

    It does if you use the latest nightly.
     
    Xiphiidae likes this.
  17. Xiphiidae

    Xiphiidae ξίφος εἶδος

    Member
    2,080
    1,016
    Sep 13, 2009
    Australia
    Works fine for me with the latest nightly; read the numerous threads on that issue.

    Edit: ninja'd
     
    Last edited by Xiphiidae, May 18, 2016
  18. Mrzeldaootfan
    OP

    Mrzeldaootfan GBAtemp Regular

    Member
    137
    6
    May 10, 2016
    United States
    I know a guide that i can use to install emunand, its the one i used to install sysnand i guess im gonna have to format Sysnand then

    — Posts automatically merged - Please don't double post! —

    so if i have emunand installed then i can safely update to 11.0 and still be able to use homebrew?
     
  19. Xiphiidae

    Xiphiidae ξίφος εἶδος

    Member
    2,080
    1,016
    Sep 13, 2009
    Australia
    As long as it's Emunand that you're updating to 11.0; leave Sysnand on 9.2.
     
  20. Ev1l0rd

    Ev1l0rd (⌐◥▶◀◤) Knight of Void

    Member
    1,031
    754
    Oct 26, 2015
    Netherlands
    Land of Darkness and Bounty
    Just make sure you update EmuNAND and not SysNAND, but yes you are correct.