Complete Upgrading Guide from 4.1 to 4.2

Discussion in 'Wii - Hacking' started by darklocust, Oct 3, 2009.

Thread Status:
Not open for further replies.
Oct 3, 2009
  1. darklocust
    OP

    darklocust Newbie

    Note: This guide is Outdated. Please use this one instead[/p]

    All credits go to Zektor's original post:
    http://gbatemp.net/index.php?showtopic=182...p;#entry2297787

    I'm in no way trying to be a hero, stealing the thunder, etc. here so please save any snarky remarks you have. I'm just trying to help out those who are already soft-modded with a clean, concise set of instructions. If you have any suggestions, please PM me!

    This tutorial assumes you are already soft modded. If you are on 4.2 and not soft modded, head over here:
    http://gbatemp.net/index.php?showtopic=171901

    PREP WORK

    1. Download the following:

    HackMii Installer v0.5
    http://bootmii.org/download/

    Dop-IOS v8
    http://wiibrew.org/wiki/Dop-IOS

    NUSD Downloader 1.2
    http://wiibrew.org/wiki/NUS_Downloader

    WAD Manager 1.4
    http://www.google.com/#hl=en&source=hp...d15299a959dbb33

    2. Update the NUSD database by copying the 9/29 code on the page below and pasting it on "database.xml" where NUSD exe is located
    http://wiibrew.org/wiki/NUS_Downloader/database

    4. Run NUSD Downloader, check the "Pack -> WAD" box then click "Database". Select the appropriate IOS and System versions then click "Start NUS Download!". Download one-by-one until completed.

    IOS9 (v778)
    IOS12 (v269)
    IOS13 (v273)
    IOS14 (v520)
    IOS15 (v523)
    IOS17 (v775)
    IOS21 (v782)
    IOS22 (v1037)
    IOS28 (v1550)
    IOS31 (v3349)
    IOS33 (v3091)
    IOS34 (v3348)
    IOS35 (v3349)
    IOS36 (v3351)
    IOS37 (v3869)
    IOS38 (v3867)
    IOS53 (v5406)
    IOS55 (v5406)
    IOS56 (v5405)
    IOS57 (v5661)
    IOS60 (v6400) *optional: will install as a stub IOS*
    IOS61 (v5405)
    Shopping Channel (v17) *optional: do you use the channel or not?*
    SystemMenu 4.2 (v481 for USA) *make sure you choose the region of your Wii*

    TRANSFERRING FILES TO SD CARD

    5. Unzip HackMii 0.5 and place the "boot.elf" in the "apps\hackmii" folder or whatever folder name you had before.

    6. Unzip Dop-IOS v8 and place the "boot.dol" in the "apps\dopios" folder or whatever folder name you had before.

    7. Unzip Wad Manager 1.4 and place the "boot.dol" in the "apps\wad_manager" folder or whatever folder name you had before.

    8. Copy the WADs you downloaded from NUSD and place in the "wads" folder.

    ON THE WII


    9. Insert the SD card, start HBC.

    10. Run the HackMii v0.5 installer. Update HBC and BootMii as IOS or boot2

    11. Run DOP-IOSv8. Download and sig hash patch (trucha) IOS70.

    12. Run WAD Manager 1.4 and install all packed WADs you downloaded except IOS60 (see below). Skip the Shopping Channel if you don't need or use it. Do not exit WAD Manager until they all others are installed!

    13. Once completed, verify the Wii is running 4.2 system menu. If you'd like to install IOS60 as a stub, run Wad Manager from HBC again then install the IOS60 wad.

    UPGRADING TO 4.2 WITHOUT HACKMII v0.5


    ***RISKY! Not recommended by Zektor or Wii soft-mod purists. If it fails, use bannerbomb v2 to get HBC back***

    1. Skip #10 (do not install HackMii v0.5) and #13 (do not install IOS60 as Preloader needs it)

    2. Update "hacks.ini" for 4.2U from http://wiibrew.org/wiki/Preloader/hacks on your SD card

    3. Use WAD Manager to install all WADs. After completion, press the "HOME" button on the Wiimote to go back to HBC (HAXX title)

    4. Run Preloader v0.29 installer

    5. Get within arms reach to your Wii. Restart it and immediately hold the RESET button to get into Preloader.

    6. Enable the "Disable HAXX,DVDX,RZDx checks"

    7. Restart the Wii again and HBC (HAXX title) should still be installed. Congratulations! You have now bypassed the need for HackMii v0.5 and not yet released Preloader v0.30

    Why it works? You are effectively disabling the function (using Preloader) in SM 4.2 that deletes HBC and DVDX before it even has the chance to boot up for the FIRST time. I know its mean! LOL!

    NOTES


    1. This tutorial should work with SM 4.1 (i.e. 3.1, 3.2, 3.4) and below but Zektor (and the scene) strongly advises you do a dump of the NAND first. If you already had BootMii in the past, you probably already have a NAND backup. Just keep it safe.

    2. You can effectively use WAD Batch Installer v0.1 instead of WAD Manager. Move all the WADs from the "wad" folder to a new "installer" folder on the root of the SD card. Be careful and do not move the wads you don't want to install in the "installer" folder (i.e. IOS60, Shopping Channel). UPDATE: this errors out after so many WADs according to SpaceJump.

    3. If you are attempting the "UPGRADING TO 4.2 WITHOUT HACKMII v0.5" set, make sure you use WAD Manager so you can return to HBC when completed.
     


  2. zektor

    Member zektor GBAtemp Maniac

    Joined:
    Nov 29, 2005
    Messages:
    1,325
    Country:
    United States
    Thanks for giving me credit, as well as starting a nice clean easy to read thread [​IMG]
     
  3. xzxero

    Member xzxero ♥bong milk does good for the brain♥

    Joined:
    Jul 18, 2008
    Messages:
    3,831
    Location:
    SB
    Country:
    United States
    nice work, but theres no reason to upgrade to 4.2!!

    anways. have you looked into the command line NUSD?

    you just set up a file and it will download all the titles you want from NUSD in one batch.
     
  4. sasho123

    Newcomer sasho123 Advanced Member

    Joined:
    Sep 13, 2009
    Messages:
    64
    Country:
    Bulgaria
    After doing this, do I have to make a new NAND or I can stay with the old one
     
  5. Pakatus

    Member Pakatus GBAtemp Advanced Fan

    Joined:
    Apr 13, 2009
    Messages:
    777
    Location:
    Portugal
    Country:
    Portugal
    whats the difference between making this package instalation and wanin method?
    Isnt the same? Just one is auto...and the other is manual.
    Right?
     
  6. xzxero

    Member xzxero ♥bong milk does good for the brain♥

    Joined:
    Jul 18, 2008
    Messages:
    3,831
    Location:
    SB
    Country:
    United States
    you should stay with the old one is has 4.1 installed in it.

    Posts merged

    waninkoko's method trucha's and probably es_identify every IOS while this installs the official pure IOS's from the 4.2 update.
     
  7. HiBit

    Member HiBit GBAtemp Fan

    Joined:
    Jun 19, 2009
    Messages:
    477
    Country:
    Germany
    Never install IOS60 in version 6400.

    With the old version you can also use sysmenu 4.1, with the stub you can use nothing.

    Otherwise you can delete it but a stub IOS is useless.
     
  8. jazvdb

    Member jazvdb GBAtemp Advanced Fan

    Joined:
    Jul 22, 2009
    Messages:
    835
    Location:
    In front of computer...
    Country:
    United States
    When i download IOS70 and hash patch it, i get "hash BAD
     
  9. darklocust
    OP

    darklocust Newbie

    I guess installing it is for purity's sake. So if you skip this one, would Preloader 0.29 still work assuming you update your "hacks.ini"?

    4.2U hacks.ini here:
    http://gbatemp.net/index.php?showtopic=182882

    4.2E hacks.ini here:
    http://gbatemp.net/index.php?showtopic=183390

     
  10. john1010_ma

    Member john1010_ma GBAtemp Regular

    Joined:
    Dec 31, 2006
    Messages:
    110
    Country:
    Brazil
    Using DOP-IOS MOD to download the latest IOS can be a safer experience as it doesn't allow you to download and install the latest (stub) of IOS 60. Perhaps the authors of DOP-IOS MOD knew the risk of a bad brick if this was installed before the new SM 4.2 was in place. I only installed the stub ios 60 (packed it into wad via NUS) after I was sure SM 4.2 was installed to ios 70. So there, a little bit different from the guide as an added precaution.
     
  11. darklocust
    OP

    darklocust Newbie

    Thanks. I updated the guide steps #12 and #13 (new).

     
  12. zektor

    Member zektor GBAtemp Maniac

    Joined:
    Nov 29, 2005
    Messages:
    1,325
    Country:
    United States
    The reason the stubbed IOS60 wad was added was for purity of the upgrade. My goal with this guide was to get you exactly were an official v4.2 upgrade would, but simply minus the cIOS slot stubs, the newer MIOS, and the boot2 overwrite. IOS60 is now as useless as IOS30 when on v4.2. It is a mothballed IOS.

    In other words, you do not have to install it....unless you are a purist like me that is [​IMG]

    EDIT: Ohh, and I would like to mention that the only time stubbing the system menu IOS is dangerous is if you loaded wad manager, stubbed IOS60, and didn't go ahead and install IOS70 and the new system menu. This is why I say not to leave wad manager until ALL IOSes are installed, and always have a NAND backup as a precaution.

    The reason that DOP-IOS blocks the stub install is because if it did not you would have a bunch of morons stubbing IOS60 (while they were on v4.1 which REQUIRES it), exiting DOP-IOS and finding their system bricked. Then you know what they would say? "DOP-IOS brickz0rd ma Wii!" [​IMG]
     
  13. transam81

    Member transam81 GBAtemp Regular

    Joined:
    Oct 4, 2009
    Messages:
    284
    Location:
    Central California
    Country:
    United States
    I just softmodded my Wii today, using Modify any Wii 4.2 & below, aka the simplistic mod by xzxero. Now when I try to play my Original or Backup Wii Sports Resort i'm almost forced to update my firmware from 4.1U to the 4.2 firmware. can i use this method to update my firmware?, so that i can play Wii Sports Resort once again.
     
  14. zektor

    Member zektor GBAtemp Maniac

    Joined:
    Nov 29, 2005
    Messages:
    1,325
    Country:
    United States
    Can't you just use NeoGamma v0.8b3 and enable to block updates to play your game?
     
  15. transam81

    Member transam81 GBAtemp Regular

    Joined:
    Oct 4, 2009
    Messages:
    284
    Location:
    Central California
    Country:
    United States
    yeah you are right, also i did that on the preloader settings. 1 other question would it be better to use this method to update my firmware or should i just hold my horses and wait for Waninkoko's 4.2 Firmware updater?
     
  16. zektor

    Member zektor GBAtemp Maniac

    Joined:
    Nov 29, 2005
    Messages:
    1,325
    Country:
    United States

    Guess you haven't been reading the various threads around here [​IMG] Waninkoko's firmware updater was released, I found it to be flawed in some seriously bad ways, so I created this guide. Of course I am going to recommend to use this guide. It is the only correct way to go from a softmodded previous system menu.
     
  17. longtom1

    Member longtom1 Keep an eye on my posts cause I quick edit frequen

    Joined:
    Jan 12, 2009
    Messages:
    2,641
    Location:
    Honey Oils inc.
    Country:
    Antarctica
    could you not just use one of the cIOSCORP installers for the wads??

    delete the wads from the cIOSCORP folder and drop all the wads you've downloaded in the cIOSCORP folder on the root of your sd card

    I think the installer just installs every wad in the cIOSCORP folder correct me if i'm wrong
     
  18. darklocust
    OP

    darklocust Newbie

    I'm not sure. I've never used cIOSCORP. That would be awesome if it can process a batch of wads from a specific folder. Care to test for us?

     
  19. zektor

    Member zektor GBAtemp Maniac

    Joined:
    Nov 29, 2005
    Messages:
    1,325
    Country:
    United States
  20. darklocust
    OP

    darklocust Newbie

    If you use WAD Batch Installer, you will have to move all the WADs from the "wad" folder to a new "installer" folder. Be careful and do not move the wads you don't want to install in the "installer" folder (i.e. IOS60, Shopping Channel).
     
Thread Status:
Not open for further replies.

Share This Page