1. Manicat

    OP Manicat Newbie
    Newcomer

    Joined:
    May 9, 2020
    Messages:
    9
    Country:
    Germany
    Hello,

    I got my Hands on an "dead" Nintendo Switch. When turned on, it crashes after the Nintendo Logo. I dont have an NAND Backup or somewthing other for this Console.

    I read about the ChoiDujour Downgrade to possible Fix a Switch without a Backup. So i followed the Instructions with a 6.0.1 Firmware. The Fuse Counter is on 12 so i should need atleast 9.0.1. My plan was to flash the Switch with the older Firmware and then update it to 9.x via Atmosphere and ChoiDujourNX.

    But how often i try i stuck with the same result: Launching the FS_XXX-exfat_nocmac_nogc’ shows the Kosmos Screen and then Crashes. Loading the fuse.primary via payload display a short flash Atmosphere Screen and then turn Black with the Background Light on. Pressing the Power Button repeats that.

    I still got a NAND Backup from the state when i got the Switch (Crashing after Nintendo Logo).

    Can someone help me with this Console?
    It would be a waste to throw it away because it has no marks or scratches.

    Thank you

    Manicat
     
    Last edited by Manicat, May 9, 2020
  2. Manicat

    OP Manicat Newbie
    Newcomer

    Joined:
    May 9, 2020
    Messages:
    9
    Country:
    Germany
    Little Update: When i try to load an older Atmosphere Version it also crashes after the Bootscreen but showing me the Error:
    Key Derivation Failed
    Could it be that the Keys i read with Lockpick RCM or other are false?
     
  3. Manicat

    OP Manicat Newbie
    Newcomer

    Joined:
    May 9, 2020
    Messages:
    9
    Country:
    Germany
    Another Update:
    When i picked the Launch configuration for the exfat_nomac... the Kosmos Screen shows up. After pressing the Louder Button a different Error is displayed. Is there a Problem with my SD Card Files? Do i need an older Atmosphere Version for the 6.x Firmware? The SD Card is formatted with FAT32. Please guys, help me :/
     

    Attached Files:

    Last edited by Manicat, May 10, 2020
  4. LIY2012

    LIY2012 Advanced Member
    Newcomer

    Joined:
    Apr 29, 2020
    Messages:
    50
    Country:
    Japan
    I would check that your boot0 file is correct. Is lockpick able to read the keys correctly?
     
  5. Manicat

    OP Manicat Newbie
    Newcomer

    Joined:
    May 9, 2020
    Messages:
    9
    Country:
    Germany
    Thanks for the Reply.
    Lockpick RCM worked. I used the keys to "convert" the Firmware with ChoiDujour. How i can check if the Boot0 file is correct?
     
  6. LIY2012

    LIY2012 Advanced Member
    Newcomer

    Joined:
    Apr 29, 2020
    Messages:
    50
    Country:
    Japan

    I just meant that it's the correct version for your firmware and has the correct keyblobs for your firmware. I've run into some people have had trouble with the files becoming corrupted when transferring the boot0 and boot1 files from choidujour to their switch. As long as Lockpick_RCM says your keys are fine it's probably OK.

    Did you copy the .kip file from choidujour over the correct place on your SD card? Is you SD card formatted at FAT32 or exFat?
     
  7. Manicat

    OP Manicat Newbie
    Newcomer

    Joined:
    May 9, 2020
    Messages:
    9
    Country:
    Germany
    Thanks for the Reply.
    Lockpick RCM worked. I used the keys to "convert" the Firmware with ChoiDujour. How i can check if the Boot0 file is correct?
    So i tryd lockpick rcm again and now it says that all keyblob are corrupt. Should i then rewrite the backup and get the Keys again? When i get the keys off the Backup and lockpick lists them as green, are there 100% okay? The Problem is that i dont know anything what happend with the console.
    The kip is in the right place. I use the fat32 format.
     
    Last edited by Manicat, May 13, 2020
  8. LIY2012

    LIY2012 Advanced Member
    Newcomer

    Joined:
    Apr 29, 2020
    Messages:
    50
    Country:
    Japan

    How did you transfer the boot0 and boot1 from choidujour to the switch? I've seen other people having problems with that step. I had success by just taking the original boot0 and boot1 (with the valid keys) backup from Hekate tools and using HxD to edit the code portion (offset 0x0 to 0x017FFFF) from choidujour boot0 and (offset 0x0 to 0x7FFFF) boot1 then restoring them back using Hekate tools.
     
  9. Manicat

    OP Manicat Newbie
    Newcomer

    Joined:
    May 9, 2020
    Messages:
    9
    Country:
    Germany
    I take every step menitoned in this Tutorial:
    https://switch.homebrew.guide/usingcfw/manualchoiupgrade
    Ah okay, thats sounds interresting. I used memloader to connect the boot0 and 1 as an usb drive and flashed the boot files from choidujour via etcher. Tomorrow, i restore the backup and then try your method. :)
     
  10. LIY2012

    LIY2012 Advanced Member
    Newcomer

    Joined:
    Apr 29, 2020
    Messages:
    50
    Country:
    Japan

    I think it might be a problem with etcher zeros out the keys at the end of the file. I don't think you need to start over, as long as you did everything else right, you should be able to just fix the BOOT0 file (boot1 should be OK) and restore it with hekate tools, check that lockpick_rcm sees the right keys and then boot using the .kip file.
     
  11. Manicat

    OP Manicat Newbie
    Newcomer

    Joined:
    May 9, 2020
    Messages:
    9
    Country:
    Germany
    The Sound of Progress :)
    With the Boot Files from the Backup i get past the Sept screen but now stuck at a new errror.
    No Mandatory secom or warmboot provided
    Failed to Launch HOS
     
    Last edited by Manicat, May 14, 2020
  12. LIY2012

    LIY2012 Advanced Member
    Newcomer

    Joined:
    Apr 29, 2020
    Messages:
    50
    Country:
    Japan
    Hmm, sounds like it might be a configuration problem. Are you using the latest versions.

    Did you check this?
    https://github.com/CTCaer/hekate/issues/386
     
  13. Hambrew

    Hambrew the none and only
    Member

    Joined:
    Oct 9, 2018
    Messages:
    477
    Country:
    United States
    U do realize that you can edit posts?
     
  14. Manicat

    OP Manicat Newbie
    Newcomer

    Joined:
    May 9, 2020
    Messages:
    9
    Country:
    Germany
    The SD Files are from the SD Setup Webpage.
    In the ipl. Ini from the choidujour Firmware isnt an option for the Secom or warmboot key. Do i have to link them Manually? And where are those files?

    My Plan now is to restore the Full Backup and do the whole Tutorial again (Inserting the Boot Files your way via hekate. Because now i get a Bluescreen when the OFW launched. Dont know what i changed (before Blackscreen = Fuse check fail)
     
  15. Manicat

    OP Manicat Newbie
    Newcomer

    Joined:
    May 9, 2020
    Messages:
    9
    Country:
    Germany
    So, with help of LIY 2012, im now at the point where the Bootfiles should be correct. Also the Secom/Warmboot Error is away.
    But the Switch still crashes after the Nintendo logo when i load the provided. .kip file.
    I have done so far:
    - Downloaded the newest SD Card Files
    - Tryd 3 different SD Cards
    - Formateted them with FAT32
    - Used the Firmware 5.1 wich should work with my Keys

    Is there anything to test if there is still a problem with the Keys? Lockpick_RCM outputs no Erros. Or do you have other Options to try? I really really want to get this alive because i got it for a very good price
    I hope somebody can help me.
    https://ibb.co/6WRHyBG
     
    Last edited by Manicat, May 24, 2020
  16. Erneston

    Erneston Newbie
    Newcomer

    Joined:
    May 28, 2020
    Messages:
    6
    Country:
    Germany
    Did you found a fix?
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - ChoiDujour, Revive, Launch