CFG USB Loader wont load uLoader ehcmodule.elf

Discussion in 'Wii - Backup Loaders' started by Krata, Aug 5, 2009.

Aug 5, 2009
  1. Krata
    OP

    Newcomer Krata Newbie

    Joined:
    Sep 12, 2007
    Messages:
    7
    Country:
    United States
    First the facts:

    * My hard drive is only supported by uLoader 2.8D at the moment, with Hermes cIOS222 v3 installed.
    * cIOS222 install is all default settings (IOS222, IOS36, install...)
    * uLoader 2.8D can use my drive no problem
    * Configurable USB Loader (v38) should be able to load ehcmodule.elf (and thus support my drive if I'm not mistaken)
    * ehcmodule.elf from uLoader 2.8 (resources folder) is placed in sd:/usb-support/ but is not loaded (there is no message)
    * When cIOS rev14 is installed CFGloader uses it and cannot find my drive
    * When cIOS rev14 is deleted CFGloader prints "Custom IOS 249 could not be loaded" and forces a restart, despite cIOS222 being installed

    How can I get Configurable USB Loader to use Hermes cIOS222 v3 and load the ehcmodule.elf from uLoader 2.8D?
     
  2. Dr. Clipper

    Member Dr. Clipper GBAtemp Addict

    Joined:
    Aug 28, 2007
    Messages:
    2,487
    Country:
    Australia
    Configurable doesn't support v3 yet. However, oggzee has indicated he wants to add support for the new version soon, but he's a little busy at the moment.

    Edit: Actually, it seems I might not be fully correct there. It seems it does support v3 now, but still doesn't support the newer ehcmodule.elf. I was right that oggzee is working on this, though.
     
  3. zektor

    Member zektor GBAtemp Maniac

    Joined:
    Nov 29, 2005
    Messages:
    1,325
    Country:
    United States
    No, v3 works perfectly fine with v38 release. I have been playing games using cios222 v3 all day long [​IMG]

    After installing cIOS222 (I installed as default), add this to your config.txt in the usb-loader directory on your sd card:

    ios = 222-mload

    The reason USBLoaderCFG backs out after uninstalling cIOS249 (rev14) is because the program default is to look for 249. You need to add this to your config.txt to allow it to look for 222 right off the bat.
     
  4. Krata
    OP

    Newcomer Krata Newbie

    Joined:
    Sep 12, 2007
    Messages:
    7
    Country:
    United States
    Yeah, I figured out that v3 works as long as you specify "ios = 222-mload" in the config.txt. However, it wont load the ehcmodule.elf from 2.8D (there is no dialog saying it is loaded, and the drive times out).
     
  5. zektor

    Member zektor GBAtemp Maniac

    Joined:
    Nov 29, 2005
    Messages:
    1,325
    Country:
    United States
    This may sound obvious, but did you try the other USB port? I am not too familiar with the ehcmodule. I am assuming it adds new support to USB devices? All I do know is that my own drive was not supported in cIOSrev10, but now works in rev14...as well as 222v3.
     
  6. Krata
    OP

    Newcomer Krata Newbie

    Joined:
    Sep 12, 2007
    Messages:
    7
    Country:
    United States
    Tried it and no luck.

    The only port supported by the cIOS' is port 0 (the bottom port), at least to my knowledge.

    I believe the breakdown is cIOS allows USB support and the ehcmodule.elf is the actual USB driver.
     
  7. zektor

    Member zektor GBAtemp Maniac

    Joined:
    Nov 29, 2005
    Messages:
    1,325
    Country:
    United States
    I see what you mean now. I tried running a game using the merged 36/37 IOS223 and it gave me an error about not having the ehcmodule. I added the new one (and later tried the old one from a previous version) and both didn't work...same timeout on the HD deal. Guess we'll just have to wait till it's fixed is all. This should have been posted in the main thread tho...
     

Share This Page