Castlevania problem

Discussion in 'R4 DS' started by Ryu X, Nov 3, 2008.

  1. Ryu X
    OP

    Ryu X GBAtemp Regular

    Member
    100
    10
    Feb 9, 2007
    United States
    Here is a weird problem I am having on my R4. If i play Castlevania OoE it corroupts my Castlevania PoR rom. So if I want to play PoR I then have to copy a new one over from my PC. As soon as I play OoE it corrupts it again. Someone tell me whats going on here? I am using 1.18 firmware.
     
  2. InuYasha

    InuYasha Professional Coke Fiend

    Member
    1,778
    55
    Dec 8, 2007
    United States
    Sounds like your memory card is corrupted?
     
  3. Another World

    Another World Emulate the Planet!

    Former Staff
    10,487
    1,598
    Jan 3, 2008
    Colombia
    From Where???
    everything i'm about to say is speculation because i gave my r4 away so i can't test this. the r4 loader is so out of date that it is probably a simple issue with the loader and not your msd or rom. things you should search for (here or google) are possible arm7 patches for your problem rom and/or a header swap fix. i have no idea if ysmenu would give you better results but everyone i know who still uses the r4 for gaming swears by it.

    if team r4 would just leak the loader files as opensource....

    goodluck to you.
    -another world
     
  4. jagerstaffel

    jagerstaffel GBAtemp Advanced Fan

    Member
    533
    129
    Aug 20, 2008
    United States
    I use YSMenu and have both the PoR and OoE games in the card at the same time and it doesn't get corrupted. I say the Micro SD has bad sectors, most likely something happened if you keep overwriting files (I've heard that it's not a good idea to overwrite USRCHEAT.DATs, the preferred method is to delete the old file and paste a new one in. I took that approach for all files so you might want to take that into consideration.)