Cannot load PSP ISOs...Black Screen Upon Startup

Discussion in 'PSP - Hacking & Homebrew' started by FryFro, Dec 28, 2015.

  1. FryFro
    OP

    FryFro Member

    Newcomer
    10
    0
    Dec 28, 2015
    United States
    I just got an ISO for the game Star Wars : The Force Unleashed from nicoblog.org

    The ISO is located in a folder titled ISO.

    The ISO folder is on the root of the memory stick.

    The game shows up when I ope my memory stick on my PSP in the game section, right? Hover over the icon, the background changes to a force unleashed pic and a Star Wars theme plays!

    Start it, and whomp - a black screen. You know the one, where the home button is no use and all you can do is completely shut down your PSP.

    What have I done wrong? I have nothing else in the ISO folder.

    Here is the PRO VSH MENU in text

    CPU CLOCK XMB : Default
    CPU CLOCK GAME : Default
    USB DEVICE : Memory Stick
    UMB ISO DEVICE : M33 Driver
    ISO Video Mount : None
    RECOVERY MENU ->
    SHUTDOWN DEVICE
    SUSPEND DEVICE
    RESET DEVICE
    RESET VSH
    EXIT

    If I have to, I will set up that program that captures the screen of your PSP and post my Recovery Menu settings.

    If all else fails, I will post a the Menu in text format.


    Please help, I want to play this and Battlefront very badly.
     
    Last edited by FryFro, Dec 28, 2015
  2. Coraje187

    Coraje187 Newbie

    Newcomer
    9
    3
    Jul 29, 2013
    United States
    Try and change the UMB ISO DEVICE to the sony one. Also might need to update the firmware you are on. What CFW?