Cannot boot into SX OS CFW...

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by xempirex, Jan 12, 2019.

  1. xempirex
    OP

    xempirex Newbie

    Newcomer
    1
    Jan 12, 2019
    Canada
    Hi everyone, so I've been lurking these forums for quite sometime. Bought my nintendo switch the day it first came out, it's currently running 2.0.0. So thought well it's time to hack my console (as I've been awaiting a long time for proper releases to come out)

    I have purchased an 256 GB SDXC card and the SX PRO kit.

    What I've done so far is BACKUP my original untouched NAND running 2.0.0, I then have updated the SYSTEMNAND to 2.1.0 through ChoidoujourNX (to enable EXFAT as 2.0.0 didn't support it) with AUTO RCM installed to prevent fuse burning. I then proceeded to create a EMUNAND with SX OS which worked fine.

    Here's where I'm currently stuck.... I cannot boot into CFW with EMUNAND enabled. However if I load the HEKATE payload, I can boot into atmosphere and do everything there but strictly through SX OS just gives me that error... I'm really stuck, tried to read online with a bunch of stuff but can't find any help.

    I'm trying to update the EMUNAND with 6.1.0 so that I can run all my backups and keep my SYSNAND untouched on 2.1.0.

    Any help would be appreciated! And I used to hack the Xbox 360 back in the days as well as my PSP (so been in the hacking scene for awhile). Thanks guys!!
     
  2. theMille

    theMille Member

    Newcomer
    3
    Apr 3, 2016
    United States
    IIRC doesnt the latest SX OS require 6.2?
     
  3. xempirex
    OP

    xempirex Newbie

    Newcomer
    1
    Jan 12, 2019
    Canada
    Hmm you may be right, I just put SX OS version 2.0.1 on and it now lets me boot into CFW however I can't boot into Emunand from the hidden partition I made from the newest version this way... What is the exact process for me to get this running? Is the only way to get this working by updating my SYSNAND to 6.2? Then create the emunand from there? Hopefully someone can point me in the right direction. Thanks.
     
  4. json

    json MUSCLEMAN

    Member
    9
    Aug 9, 2013
    Burkina Faso
    Whats the error you get when loading emunand?

    (And 6.2 is not required at all)
     
  5. SonyUSA

    SonyUSA We're all mad here

    pip Contributor
    12
    GBAtemp Patron
    SonyUSA is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    May 12, 2006
    United States
    I don't think you can use hidden system emunand with the older sxos, that's a pretty recent feature.
     
  6. xempirex
    OP

    xempirex Newbie

    Newcomer
    1
    Jan 12, 2019
    Canada
    When I try to boot into CFW, show the nintendo bootscreen, then i can press buttons for 2 secs and then says:

    ERROR CODE 2254-0006

    "Please press the POWER button to restart the console" etc etc.

    Hmm, not really sure why this is happening. My Switch is NEVER going online until I feel like putting it back to stock so maybe the best bet is to ERASE emunand, upgrade my SYSNAND to 6.2, then recreate EMUNAND? Really stumped here.
     
  7. Gamerjin

    Gamerjin GBAtemp Regular

    Member
    3
    May 25, 2016
    United States
    hmm....before doing that, have you updated to the latest SX OS? its 2.5.1 i think?
     
  8. xempirex
    OP

    xempirex Newbie

    Newcomer
    1
    Jan 12, 2019
    Canada
    I was using the latest version which was 2.5.2. Tried your suggestion of 2.5.1 and same error occurs.... Anyone else have any ideas before I try the SYSNAND upgrade via Choi? Was hoping to keep my SYSNAND on lowest firmware possible and just using the updated EMUNAND to 6.1...
     
  9. Gamerjin

    Gamerjin GBAtemp Regular

    Member
    3
    May 25, 2016
    United States
    Last edited by Gamerjin, Jan 13, 2019
    xempirex likes this.
  10. xempirex
    OP

    xempirex Newbie

    Newcomer
    1
    Jan 12, 2019
    Canada
    Thanks for doing some diggin' on this! Exactly same issue as me that they're having. So TLDR, which version should I update to? Should I just go to SYSNAND 6.1? Or should I go to 3.0.1? 2.2.0 seems like it won't work with 2.5.2 still (Which I need for EMUNAND hidden partition to work)

    Edit* I think firmware 4.1.0 is the one to go for, should work with everything. Gonna try that now.
     
    Last edited by xempirex, Jan 13, 2019
  11. Gamerjin

    Gamerjin GBAtemp Regular

    Member
    3
    May 25, 2016
    United States
    ah, I meant 2.2.0 as a suggestion. In your case, you may have try higher firmware, just until it starts working. ( as for me, i haven't tried the hidden partition emunand, however, i was the file-based version on 6.0.1, not that it helps.... )
     
    Last edited by Gamerjin, Jan 13, 2019
    xempirex likes this.
  12. SonyUSA

    SonyUSA We're all mad here

    pip Contributor
    12
    GBAtemp Patron
    SonyUSA is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    May 12, 2006
    United States
    Why not just update to sysnand 6.2? Coldboot is a pipe-dream that will never come. And as long as you stay in CFW (Auto-RMC) you can always go back if your fuses aren't burned.
     
  13. xempirex
    OP

    xempirex Newbie

    Newcomer
    1
    Jan 12, 2019
    Canada
    Yeah that's true, I thought about it but meh, already updated to 4.1 now and my emunand is almost done being created. Will let you all know what the outcome is! :) Thanks for all the help.
     
    SonyUSA likes this.
  14. SonyUSA

    SonyUSA We're all mad here

    pip Contributor
    12
    GBAtemp Patron
    SonyUSA is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    May 12, 2006
    United States
    I find emunand is kind of a waste of 32GB of space... lol. I just updated to latest firmware and kept the extra room for other goodies :D

    Since you are on 4.1 now there is no reason to stop there, may as well go to 6.2.
     
    xempirex likes this.
  15. xempirex
    OP

    xempirex Newbie

    Newcomer
    1
    Jan 12, 2019
    Canada
    Only going to update my SYSNAND to higher versions if it requires it! Haha.

    UPDATE - updated my SYSNAND to 4.1.0 through Choi, then ran SX OS to create EMUNAND on SDCard, launched CFW from SX OS and it now works!! So I just updated my EMUNAND to 6.1! Now just loading my backups on! Thanks a lot everyone! SUPER STOKED on this! :D
     
    SonyUSA likes this.