1. CompC

    OP CompC GBAtemp Fan
    Member

    Joined:
    May 28, 2009
    Messages:
    372
    Country:
    United States
    Well yesterday I accidentally took my microSD out of my computer without ejecting it first and it deleted everything on the card. YAY!

    So I go to put it back in my Acekard after putting all my ROMs and stuff back on and… the microSD doesn't go into the Acekard! It goes in, but it doesn't 'click' in and doesn't stay. Is there a way to fix this? I don't want to buy another one… I can use emulators on my iPlayer but I still need my Acekard for DS ROMs!
     
  2. wrettcaughn

    wrettcaughn GBAtemp Psycho!
    Member

    Joined:
    Mar 14, 2009
    Messages:
    3,819
    Country:
    United States
    try pushing it in very hard and see if the spring pops back into place
     
  3. CompC

    OP CompC GBAtemp Fan
    Member

    Joined:
    May 28, 2009
    Messages:
    372
    Country:
    United States
    No, it doesn't seem to be doing anything.
     
  4. wrettcaughn

    wrettcaughn GBAtemp Psycho!
    Member

    Joined:
    Mar 14, 2009
    Messages:
    3,819
    Country:
    United States
    i can't really recommend this...but my ak2i came with a borked spring and i just opened it up, popped it back in place, and glued it back together.
     
  5. rommy667

    rommy667 GBAtemp Advanced Fan
    Member

    Joined:
    Mar 21, 2008
    Messages:
    569
    Country:
    The last batch of ak2i i saw had no spring the card just slides in and out like a r4i [​IMG]
     
  6. CompC

    OP CompC GBAtemp Fan
    Member

    Joined:
    May 28, 2009
    Messages:
    372
    Country:
    United States
    But I've had my Acekard for a year and it does have a spring and now it doesn't work.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Broken, spring,