Bricked PSP

Discussion in 'PSP - Games & Content' started by sekhu, Jan 25, 2008.

Jan 25, 2008

Bricked PSP by sekhu at 1:14 PM (808 Views / 0 Likes) 2 replies

  1. sekhu

    Member sekhu moo?

    Feb 14, 2007
    United Kingdom
    I think i may have bricked a PSP having upgraded to 3.71. I used a Pandora battery and a magic stick, to update to 3.71. It worked but now the PSP wont' power on any more, or the light is orange,/sometimes green, but nothing displays.IS it bricked? I have two pandora batterys and 2 magic sticks, one lot is tested, i have yet to test the other lot. Also I'm not sure which is he normal batteyer anymore and which is the pandora battery, I've got them mixed up. Except the third battery and magic stick which arrived very late in the post.

    Suggestions ideas, or guidance in how to resolve this?

    Cheers in advance
  2. rdurbin

    Member rdurbin GBAtemp Fan

    Sep 13, 2006
    United States
    Try plugging the psp in. Also check to see if the brightness got reset

    also try to reboot the psp all the way, hold the power switch for about 10 seconds

    you can also try to enter the recovery menu if you have a Custom firmware installed, (hold R while booting psp)
  3. [M]artin

    Member [M]artin .

    Nov 7, 2006
    United States
    This happened to me once when I was modding two different PSP Phats in a hurry and mixed up the batteries.

    Plug in the PSP to its power source and try turning on the PSP (it should start up, the PSP doesn't need a battery to start as long as it's plugged into a power source, you should check to see if your upgrade was successful at this point, too). If it's still not powering up, make sure that there's no memstick inserted and try again.

    If you're trying to revert you battery back to normal, you're gonna have to find the same battery/memstick combo you used. This should be done with some simple trail-and-error tests (have the psp unplugged and try the various possibilities, once the menu with the white text (pandora menu) shows up, you'll know you found the right combo). [​IMG]

Share This Page