Bricked Powersaves for Amiibo?

Discussion in 'Wii U - Hacking & Backup Loaders' started by mooglazer, Dec 30, 2016.

  1. mooglazer
    OP

    mooglazer GBAtemp Regular

    Member
    103
    26
    Jun 24, 2007
    United States
    Just picked up a Powersaves for Amiibo and plugged it up to Windows 10. The device manager picked it up, and I then ran the NaMiio software. It immediately jumped to "upgrading device", the blue LED started blinking and sat for a minute before the software crashed.

    I tried starting the software up, but now it doesn't detect the device and the blue LED just blinks. Is it bricked, and is there a way to restore it?

    Edit: Exchanged it for another one. It detected, but even with the official software, it's been stuck at an orange 50% for an hour.

    http://i.imgur.com/VOpq37k.jpg

    Edit 2: Unplugged it, restarted software, it finished the update and now seems to be working. Gotta love cheap chinese hardware.
     
    Last edited by mooglazer, Dec 30, 2016
  2. pic2022

    pic2022 Newbie

    Newcomer
    2
    0
    Mar 14, 2017
    United States
    Hey I am stuck at the exact a=same spot you are with updating this stupid things software. When you unplugged it, did it work for you after that? This is my 2nd one and my 1st one bricked itself just around this time.
     
  3. Bheckrim

    Bheckrim Newbie

    Newcomer
    1
    0
    Nov 22, 2012
    United States
    I am having the 50% issue as well. Pic2022 how did things turn out?
     
  4. DMG

    DMG Member

    Newcomer
    12
    4
    Aug 1, 2016
    Gambia, The
    Had the same issue. I plugged it into a powered USB hub and it just didn't work. Tried another USB port on the back of my PC and it continued the update process. Seems to work now.