Bravely Default: For the Sequel (CTR-BTRJ) Crashes

Discussion in '3DS - Homebrew Development and Emulators' started by Noriken, Mar 1, 2016.

  1. Noriken
    OP

    Noriken Newbie

    Newcomer
    7
    1
    Mar 1, 2016
    United States
    As the title says, when Bravely Default: For the Sequel is on ver 0.0.0 it works perfectly fine.

    However, once I apply the ver 1.1.0 patch it crashes before the title screen.

    I've tried several different .cia's for both the game itself and the update patch as well.

    Does anyone know what's going on?

    *For the record my emunand is 10.6 and my 3DS' region is US (not sure if that matters).

    Any assistance/information would be greatly appreciated as this is driving me nuts.

    @mods
    I'm not really certain if this is the proper sub-forum to post this question; if it isn't please feel free to move the thread to the proper sub-forum. Thanks!
     
  2. ih8ih8sn0w

    ih8ih8sn0w Koreaboo

    Member
    1,669
    732
    Aug 22, 2015
    United States
    Hell
    I had this issue as well when trying to add the uncensored models to my own dump. I thought it was just due to a lack of enough RAM for makerom.exe, but I'm going to try building again tonight without model hacks and post the results here.
     
  3. Noriken
    OP

    Noriken Newbie

    Newcomer
    7
    1
    Mar 1, 2016
    United States
    I'm using a [supposedly] unmodified version as the JP release of Bravely Default: For the Sequel had [to my knowledge] uncensored models + english subs.

    That being said, still unable to install the JP ver 1.1.0 patch (and have a working game).
     
  4. Abcdfv

    Abcdfv What comes around goes around.

    Member
    1,454
    591
    Dec 24, 2013
    United States
    Maybe it needs "region fixed" similar to how they got the Hyrule warriors legends extra data to work properly? Just a thought.
     
    Noriken likes this.
  5. Noriken
    OP

    Noriken Newbie

    Newcomer
    7
    1
    Mar 1, 2016
    United States
    Could you elaborate on that?

    I'm extremely new to this scene and have absolutely no idea what any of that means.

    I just got my 3DS to boot off emunand less than 2 days ago.
     
  6. Abcdfv

    Abcdfv What comes around goes around.

    Member
    1,454
    591
    Dec 24, 2013
    United States
    I don't know exactly what all it involves, I'd try asking on that one iso site in one of the region fixed hyrule warriors threads to see exactly how they did it. I was more interested in getting My Fairy working than reading up on it.

    This is pure speculation on my part though. It may not be what's wrong at all. I've never tried installing updates for an out of region game
     
    Noriken likes this.
  7. Noriken
    OP

    Noriken Newbie

    Newcomer
    7
    1
    Mar 1, 2016
    United States
    Quick update w/ more details:

    I'm running cakes and when I try to boot the game with the ver 1.1.0 update it will crash even when I run NTR prior to trying.

    ver 0.0.0 works just fine, it's ver 1.1.0 that crashes both with & w/o NTR.
     
  8. key1340

    key1340 GBAtemp Regular

    Member
    160
    85
    Jul 6, 2015
    United States
    Bravely Default: For theSequel update checks if your emunand is Japanese and if it is then the game boots fine.

    If it is USA or euro you get any error and the console reboots.

    To fix it you need to use ntr cfw with the Japanese language plugin.
     
    Noriken likes this.
  9. Noriken
    OP

    Noriken Newbie

    Newcomer
    7
    1
    Mar 1, 2016
    United States
    That was it.

    Got it working on ver 1.1 now, thanks guys.
     
    Abcdfv likes this.
  10. TheGlow

    TheGlow GBAtemp Regular

    Member
    149
    32
    Nov 23, 2013
    United States
    Da Bronx
    Do you know what patch notes are for 1.1.0?
    Im trying to play it on a US 3DS and it says theres an update but fails to download it.
    I'm wondering if I should just leave as is then since I dont seem to need to worry about using NTR yet either.