Boktai hardware problem

Discussion in 'GBA - Console and Game Discussions, Help and Tips' started by sethirion, Aug 4, 2009.

Aug 4, 2009

Boktai hardware problem by sethirion at 11:57 PM (1,217 Views / 0 Likes) 2 replies

  1. sethirion
    OP

    Newcomer sethirion Advanced Member

    Joined:
    Nov 16, 2008
    Messages:
    97
    Location:
    CA
    Country:
    United States
    A few years ago I bought Boktai: The Sun is in Your Hand, but I had some problems playing it becasue of my skin sensitivity.
    I played it a few then I had to move to a backup option. When I heard that it can be used to add features with the Lunar Knight NDS game I tried to use the GBA cart; by curiosity I inserted it into my GBA port (slot-2), but to my surprise the save was gone.

    I feared the worst, but I tried (do not know why) putting on the GBA system... the save was intact!
    How could this happen?

    Today I tried to read the GBA game in my NDS lite system (Zelda golden) unfortunately there was no save game there. One weird thing is that the game never asked me for a calibration of the solar sensor as opposed to a blank game (none save on them). I wonder why...

    I took it appart to check the inside (thought the cart is crystal clear) and I found oxide (rust) on the plastic and the battery; I cleaned it and the GBA contacts.

    After the clean processes I tried again at the NDS lite, but without any difference... I put the GBA game on the NDS (original system) and it actually works with the save game (the first time I put in slot-2 was on this system).

    My advice to you is that if something happens related to your save on a NDS lite, try to open the catridge and check the contacts; I did it with a digital multimeter to ensure the read of the voltage.

    I am going to keep looking an answer to the NDS lite bad reading. Do you have anything similar or advices?
     
  2. Overlord Nadrian

    Banned Overlord Nadrian Banned

    Joined:
    Jul 28, 2008
    Messages:
    6,671
    Location:
    Riviera
    Country:
    Belgium
    This is like with the Pokémon games, the save's gone cause the battery's run dry. Although this is a bit of a different case...
     
  3. santorix10

    Member santorix10 GBAtemp Regular

    Joined:
    Jan 31, 2008
    Messages:
    240
    Location:
    Rochester, NY - USA
    Country:
    United States
    Seems you were pretty thorough about this... I would recommend tracing the cartridge pins back to components or ICs (basically any point on the board with exposed solder connected to a trace leading to a cartridge pin) and do a continuity test (there should be one in your multimeter) to see if the pins are not clean, or if a trace is broken.
     

Share This Page