BLACK SQUARE Help Thread

Discussion in '3DS - Flashcards & Custom Firmwares' started by KazuRo, Feb 27, 2016.

  1. KazuRo
    OP

    KazuRo GBAtemp Regular

    Member
    102
    24
    Apr 11, 2014
    Gambia, The
    [​IMG]

    Because I solved my Black Square problem yesterday I want to bring a thread that helps other people to solve their problems with this stupid blank apps.
    I didn't know much about the whole 3DS stuff but I think there are enough people here on GBATemp to do this and why don't help everyone with this problem in one thread.

    Let's start by collecting problems by people who solved the black app problem already and put them on a list that the person who got a black app problem can come here and can go through all problems.

    • User: KazuRo
      Problem: Black Square on EmuNAND but not on SysNAND.
      Solved?: YES
      Solution: Injected FBI into Health and Safety on EmuNAND with RxTools, after removing CTR-P-CFBI with the ID: 0x01930 on EmuNAND which was never intended to be there installed on NAND. Used BigBlueMenu instead of FBI cause FBI could not found that File.

    • User: MelonGx and his pals
      Problem: Black Square on 4.X rxMode SysNAND
      Solved?: YES
      Solution:
      Upgrade SysNAND to 9.X then it disappears.

    • User: MelonGx and his pals
      Problem: Black Square on TWN consoles' rxMode emuNAND
      Solved?: NO
      Solution:
      Don't know.

    • User: wormdood
      Problem: 3 black squares on sysnand
      Solved?: YES
      Solution: used bbm to look at installed titles found 3 instances of fbi and 2 sysupdater & deleted them (bbm only deleted the improperly installed copies btw ;))
     
    Last edited by KazuRo, Feb 27, 2016
    wormdood, MelonGx and Quantumcat like this.
  2. MelonGx

    MelonGx GBAtemp Advanced Maniac

    Member
    1,634
    439
    Jan 8, 2009
    China
    User: MelonGx and his pals
    Problem: Black Square on 4.X rxMode SysNAND
    Solved?: Yes
    Solution:
    Upgrade SysNAND to 9.X then it disappears.

    User: MelonGx and his pals
    Problem: Black Square on TWN consoles' rxMode emuNAND
    Solved?: No
    Solution:
    Don't know.
     
  3. wormdood

    wormdood pirate booty inspector

    Member
    3,350
    1,406
    Jan 3, 2014
    United States
    behind a parental advisory sticker
    had you asked i would have told you to use bbm to look for duplicate installs and delete them . . . but you found out (the solution) on your own . . . anyway

    User: wormdood
    Problem: 3 black squares on sysnand
    Solved?: yes
    Solution: used bbm to look at installed titles found 3 instances of fbi and 2 sysupdater & deleted them (bbm only deleted the improperly installed copies btw ;))

    but i have discovered in all the time i spent on gbatemp helping people with there 3ds issues that the issue can also be caused by a bug in some nightly builds of rxtools (as such i now advise people to install rxtools 3.0 beta 2)

    also despite the cause updating (or downgrading then updating . . . if need be) will solve the issue as well

    note. if any of the black boxes load sd card management when you try to launch them then its a bug that is causing the issue (as such bbm will not turn up any duplicate files but instead may show titles not installed by the user in addition to user installed titles (the same amount of titles as black boxes) that will not match when compared to the fw title list on 3dsbrew nor in 3dsdb list of game title id's)
    but if all black boxes cause a freeze/error screen then user error caused the boxes . . . (. . . like my issue for example)

    2nd note @KazuRo good job making a thread for this ( . . . i should have long ago but everyone wanted to dismiss me because they don't want to be accused of error-ing the saying is "to error is human . . ." and not "to error is impossible" . . . anyway i never did a thread like this . . . so congrats)
     
    Last edited by wormdood, Feb 27, 2016