Black screen with boot9strap and Luma3DS 8.1

Discussion in '3DS - Flashcards & Custom Firmwares' started by someguy42, Aug 7, 2017.

  1. someguy42
    OP

    someguy42 Member

    Newcomer
    10
    0
    May 14, 2017
    United States
    So, I might have a brick, but I still have some hope.

    I've updated AL9H to boot9strap and Luma3DS 8.1, but after completing the guide, nothing boots. I can't enter chain-loader menu, Luma settings, recovery mode, etc. I checked boot9strap and Luma versions, they're okay. 3ds turns on, but the screen doesn't. What's especially strange is that if I put Godmode9 in the root of SD card as boot.firm, the screen turns on as well, but I only see black screen. It booted GodMode9 once or twice (I hoped to restore NAND), but now it doesn't boot at all.

    Anything I can do?
     
  2. Lacius

    Lacius GBAtemp Guru

    Member
    5,630
    2,117
    May 11, 2008
    United States
    If you haven't already done so, try these troubleshooting steps: https://3ds.guide/troubleshooting

    Specifically, the ones that say:
    • Black screen on SysNAND boot
    • Black screen on SysNAND boot after Installing boot9strap
     
  3. someguy42
    OP

    someguy42 Member

    Newcomer
    10
    0
    May 14, 2017
    United States
    Yeah, I've tried everything from this guide.

    1. 3ds doesn't boot without SD card (it turns off after a second)
    2. Tried booting without a cartridge
    3. Tried using another SD card
    4. Can't enter recovery mode

    Oh, and one more thing: I was getting some ARM9 and ARM11 "data abort" exceptions from Luma. Here's a dump of ARM9 exception, if it's of any help.
     

    Attached Files:

  4. Lacius

    Lacius GBAtemp Guru

    Member
    5,630
    2,117
    May 11, 2008
    United States
    The fact that it's turning off after a second without an SD card is a good sign. This means you don't have the Luma3DS boot.firm on your CTRNAND, but it means B9S is installed and intact. Here's what I would do:
    1. Take a different SD card and format it with SD Formatter.
    2. Put the Luma3DS 8.1 boot.firm onto the new SD card.
    3. Create a /luma/ folder on the root of the SD card.
    4. In the /luma/ folder, create a /payloads/ folder.
    5. Download the latest GodMode9 and put the .firm into the /luma/payloads/ folder.
    6. Attempt to boot the 3DS, which should automatically load the Luma3DS configuration settings.
    If it does, what happens next after you hit Start?
     
    Last edited by Lacius, Aug 7, 2017
  5. Majickhat55

    Majickhat55 The Red Woman

    Member
    2,937
    1,373
    Mar 28, 2016
    United States
    Asshai
    OMG for a second I thought OP was talking to himself.... Lol :wacko:
     
  6. Lacius

    Lacius GBAtemp Guru

    Member
    5,630
    2,117
    May 11, 2008
    United States
    @someguy42 and I will try not to implode the universe.
     
    DarthDub, someguy42 and Majickhat55 like this.
  7. someguy42
    OP

    someguy42 Member

    Newcomer
    10
    0
    May 14, 2017
    United States
    Unfortunately, it still doesn't boot settings or GodMode9 (the screen doesn't light up). Btw, putting latest Godmode9 as boot.firm doesn't light screen up as well, only previous version does it (or maybe older, will have to check).

    UPD: Yep, 1.2.8 lights the screen (but still black screen), 1.3.0. does nothing, though 3ds doesn't turn off.
     
    Last edited by someguy42, Aug 7, 2017
  8. Lacius

    Lacius GBAtemp Guru

    Member
    5,630
    2,117
    May 11, 2008
    United States
    What happens if you use the Luma3DS 7.1 boot.firm on the root of your SD card?
     
  9. someguy42
    OP

    someguy42 Member

    Newcomer
    10
    0
    May 14, 2017
    United States
    Nothing, holding Start or Select does nothing as well. I've tried lots of Luma3DS versions, none of them did anything. As for GodMode9: 1.2.8. lights up the screen, 1.2.7 booted once after several tries.

    JFYI: there was no physical damage to 3DS, previously GodMode9 booted consistently, I've tried to restore NAND, but it freezed, after the second or third try I gave up and tried different versions of GodMode9/Luma3DS and now I'm kinda stuck with this situation.
     
  10. Lacius

    Lacius GBAtemp Guru

    Member
    5,630
    2,117
    May 11, 2008
    United States
    When did the problem start? What were you doing before the problem started?
     
  11. someguy42
    OP

    someguy42 Member

    Newcomer
    10
    0
    May 14, 2017
    United States
    I previously had AL9H and Luma 7.0, everything worked well. Then I updated to boot9strap using Plailect's guide, everything went as expected, but then I got a variety of errors (crypto fail, tried aeskeydb.bin, then arm9/11 errors, wrong firmware, etc.), then I tried recovering NAND via GodMode9, but it failed (never reached 100%, freezed at 20-30%), then I started trying different Luma/GodMode/boot9strap configurations, but nothing helped and here I am.
     
  12. Lacius

    Lacius GBAtemp Guru

    Member
    5,630
    2,117
    May 11, 2008
    United States
    First, when did you go through the guide? Second, when exactly did the errors start?
     
  13. someguy42
    OP

    someguy42 Member

    Newcomer
    10
    0
    May 14, 2017
    United States
    I followed it three days ago. I launched SafeB9S installer, it finished successfully and then I started getting errors.
     
  14. HugaTheFox

    HugaTheFox GBAtemp Advanced Fan

    Member
    522
    131
    Feb 11, 2017
    United States
    Las Vegas
    Whats your firmware. And try the legacy of luma.
     
  15. HugaTheFox
    This message by HugaTheFox has been removed from public view by porkiewpyne, Aug 8, 2017.
    Aug 8, 2017
  16. someguy42
    OP

    someguy42 Member

    Newcomer
    10
    0
    May 14, 2017
    United States
    11.3. I tried, got nothing. But I've tried Luma 8.1.1. and at least settings booted. I set "Show NAND or user string in System Settings" and got crypto fail on reboot. Put aeskeydb.bin in boot9strap folder, but then got "CTR firm is invalid or corrupt" and then it stopped booting again.
     
  17. HugaTheFox

    HugaTheFox GBAtemp Advanced Fan

    Member
    522
    131
    Feb 11, 2017
    United States
    Las Vegas
    restor a nand backup
     
  18. someguy42
    OP

    someguy42 Member

    Newcomer
    10
    0
    May 14, 2017
    United States
    I would, but sadly I can't enter GodMode9.
    For some reason 3DS stopped booting again with the latest Luma. Seems like something is really broken.
     
  19. leerpsp

    leerpsp GBAtemp Advanced Fan

    Member
    844
    182
    Feb 22, 2014
    United States
    sounds like you need a hardmod.
     
  20. someguy42
    OP

    someguy42 Member

    Newcomer
    10
    0
    May 14, 2017
    United States
    Yeah, probably, was hoping that this could be avoided, but with random stuff like this, not likely.
     
  21. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,445
    4,762
    Mar 17, 2010
    Norway
    Alola
    Just to rule it out as an issue, you haven't changed SD card recently have you? And you're using a name brand SD card from a reputable seller? (no eBay or 3rd party Amazon sellers)
    The issues restoring NAND and booting payloads could be caused by a bad SD card.
    And your 3DS' NAND was probably bricked by the failed restore.
    If you can get GodMode9 working again and complete the NAND restore, and put boot.firm in CTRNAND, your 3DS should work again.
    Maybe try with another known good SD card, and put only the Luma3DS boot.firm as well as Luma\payloads\GodMode9.firm (redownload both) on the SD and see if you're able to boot into Luma or GodMode9. If Luma doesn't work but GM9 does, put the NAND backup on and try restoring it again.
     
    Last edited by The Real Jdbye, Aug 8, 2017