Black screen when running Homebrew Launcher Channel

Discussion in 'Wii U - Homebrew' started by Sega dude, Dec 18, 2018.

  1. Sega dude
    OP

    Sega dude Member

    Newcomer
    3
    Nov 23, 2014
    United States
    When I try to launch the Homebrew Launcher Channel from the Wii U Menu, I get a black screen after the Homebrew Launcher splash screen. I then have to hold the power button until the Wii U turns off. My Wii U is on 5.5.1U and I followed Plailect's guide. This happened the first time I tried launch the Homebrew Launcher Channel, but I believe it worked the second time I tried. It has not worked since, even after multiple attempts and deleting and reinstalling the Homebrew Launcher Channel. It seems like the splash screen disappears abruptly like it's crashing. I am using the browser exploit and I am launching Mocha before I go to the Wii U Menu. I can't find anything about this problem. Any ideas? To be clear, I am having trouble launching the Homebrew Launcher from the Wii U Menu, not from the browser.
     
  2. x65943

    x65943 Dr. Rabbi Prince X, Sr., Ed. D.

    Moderator
    16
    GBAtemp Patron
    x65943 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jun 23, 2014
    United States
    Midwest
    Did you buy the DS game you injected the channel into? It doesn't work if you use a pirated game
     
  3. Sega dude
    OP

    Sega dude Member

    Newcomer
    3
    Nov 23, 2014
    United States
    I'm not using a DS game. I am using the browser exploit and Mocha CFW. I installed the Homebrew Launcher Channel with WUP installer as described in Plailect's guide.
     
  4. x65943

    x65943 Dr. Rabbi Prince X, Sr., Ed. D.

    Moderator
    16
    GBAtemp Patron
    x65943 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jun 23, 2014
    United States
    Midwest
    Ah, so you are using browser exploit every time you launch?

    Strange that it is not working. Are other installed titles working?
     
  5. Sega dude
    OP

    Sega dude Member

    Newcomer
    3
    Nov 23, 2014
    United States
    Yes, I am launching the browser exploit every time. I start the Wii U and go to the Internet Browser. I run the exploit which launches Homebrew Launcher 1.3. From there I launch Mocha CFW. I then press the home button, which brings me to the Mii Maker. I close the Mii Maker, then I launch Homebrew Launcher Channel on the Wii U Menu. The splash screen comes up and it makes a sound, then a few seconds after the splash screen abruptly disappears. Other installed titles are working fine. I tried redownloading the Homebrew Launcher Channel again, putting it on the SD card and trying to install it again. Same problem. I also tried reformatting the SD card and starting from scratch. Still the same problem.
     
  6. Steckbecken

    Steckbecken Advanced Member

    Newcomer
    4
    Jan 12, 2018
    Austria
    I have the same problem with Haxchi CFW on 5.5.3e
    Launchin HBL via Haxchi is working, but the installed HBL Channel results in a Blackscreen after the spladh screen. Any ideas?
    Thx!
     
  7. d3x

    d3x Member

    Newcomer
    2
    Sep 14, 2007
    Norway
    I have this very same issue :(
     
  8. eranar

    eranar Newbie

    Newcomer
    1
    Mar 8, 2019
    Bulgaria
    Exactly the same problem here, 5.5.3e with Mocha exploit. Can anyone help?
     
  9. THEELEMENTKH

    THEELEMENTKH GBAtemp Advanced Maniac

    Member
    9
    May 31, 2016
    Spain
    iirc it's because even though you exit mii maker, the homebrew launcher is still there on the Wii U's RAM.
    If you try to re-launch the homebrew launcher payload while the homebrew launcher is still loaded on the Wii U it crashes (kinda) and hangs on a black screen

    Since you, OP, use the web exploit to launch the homebrew channel, load mocha and then exit normally, you just tap the miimaker app to launch the homebrew channel again until you either reboot your Wii U or cause a soft reboot (like starting system settings and exiting)

    (Note: It's been years I don't use the browser exploit nor mocha cfw, but I recall it worked like this)
     
    KyoLikesTrees likes this.
  10. Sega dude
    OP

    Sega dude Member

    Newcomer
    3
    Nov 23, 2014
    United States
    Launching the Mii Maker app again after running the exploit through the browser does indeed re-launch the Homebrew Launcher.

    I looked at Plailect's guide again, and it has changed a bit since I followed it in December. It now says to use Homebrew Launcher 1.4 instead of 1.3. This means I can now run RPX homebrew, which I could not with 1.3. That is why I wanted to use the Homebrew Launcher Channel, since the more recent Wii U homebrew is RPX. It also has you put a payload.elf file from the Homebrew Launcher Installer payload.zip file in the wiiu folder of the SD card. There is also a new exploit site to go to, wiiuexploit.xyz. I still can't use the Homebrew Launcher Channel, but now that I'm using Homebrew Launcher 1.4, I can use the newer Wii U homebrew.
     
  11. eranar

    eranar Newbie

    Newcomer
    1
    Mar 8, 2019
    Bulgaria
    I tried using loadiine.ovh instead of the provided exploit site and, surprise surprise, it worked like a charm. Sega dude, give it a try, it will probably work for you too, as I've been following the same guide as you.
     
  12. Pathulhu

    Pathulhu Newbie

    Newcomer
    1
    Aug 14, 2019
    United States
    hate to bump the thread but i've got the same problem, i have no idea what's causing my homebrew launcher making the screen go black and freeze my wii u, i use haxchi and activate the mocha cfw before opening the channel and then nothing

    i just got into wii u hacking a couple days ago and im concerned i did something wrong
     
Quick Reply
Draft saved Draft deleted
Loading...