Black screen when boot, safebs9installer not loading

Discussion in '3DS - Flashcards & Custom Firmwares' started by Omarr98, Sep 6, 2018.

  1. Omarr98
    OP

    Omarr98 Member

    Newcomer
    2
    May 26, 2017
    United States
    I have been having issues with my 3ds. I updated my hacked 3ds to 11.8 not so long ago, and no immediate issues arose.
    It wasn't until recently when there only appears a black screen when I turn on my 3ds. When I try without an sd card, it gives me the error message, "failed to apply 1 firm patch".

    So then I tried looking online for similar problems from others, and I assumed it was probably because I needed to update my Luma and to update to safebs9installer.
    and so I followed the guide from this link: https://3ds.hacks.guide/a9lh-to-b9s.html

    However; I think there is a problem when it comes to "section II: installing boot9strap". It goes straight to Godmode9 when I boot with the start button.
    I have no idea whats going wrong. When I try skipping this step, the problem persists, and I still get a black screen, (now even when I remove my sd card; no more error message, just a black screen as well).

    Whats am I doing wrong or missing from this guide? Is this guide even the solution, or is it something else?
    I see lots of similar questions like this asked here, but none that I have seen have worked for me yet.

    Any help would be appreciated. Thanks!
     
  2. lone_wolf323

    lone_wolf323 GBAtemp Addict

    Member
    8
    May 27, 2011
    Canada
    The issue is that 11.8 requires v9.1 luma file. If yours is 7.0.5 then your gonna have to use ntrboot to get it back. If its over 7.1 but under 9.1 you will need to grab that file and set it on sd root.
     
    Omarr98 likes this.
  3. Omarr98
    OP

    Omarr98 Member

    Newcomer
    2
    May 26, 2017
    United States
    I downloaded and used the latest Luma, and I put it on my sd card root. I downloaded it from here https://github.com/AuroraWright/Luma3DS/releases/tag/v9.1
    It must be something else...
     
    Last edited by Omarr98, Sep 6, 2018
  4. zacchi4k

    zacchi4k GBAtemp Maniac

    Member
    7
    Feb 6, 2015
    Italy
    Somewhere eating pizza
    Are you sure you're running A9LH? Is the arm9loaderhax.bin file in your SD card root?
     
    Omarr98 likes this.
  5. Omarr98
    OP

    Omarr98 Member

    Newcomer
    2
    May 26, 2017
    United States
    Yeah, its in my sd card root.
     
  6. zacchi4k

    zacchi4k GBAtemp Maniac

    Member
    7
    Feb 6, 2015
    Italy
    Somewhere eating pizza
    Delete it, copy SafeB9SInstaller.bin to the SD card, rename it as arm9loaderhax_si.bin and power on the console, see if the installer launches
     
    Omarr98 likes this.
  7. Omarr98
    OP

    Omarr98 Member

    Newcomer
    2
    May 26, 2017
    United States
    I did that. I copied the safebs9installer.bin, renamed it arm9loaderhax_si.bin, and placed it in my sd root; but when I boot with start, it goes to Godmode9 instead of the installer.
     
  8. zacchi4k

    zacchi4k GBAtemp Maniac

    Member
    7
    Feb 6, 2015
    Italy
    Somewhere eating pizza
    Try renaming it to arm9loaderhax.bin instead
     
    Omarr98 likes this.
  9. Omarr98
    OP

    Omarr98 Member

    Newcomer
    2
    May 26, 2017
    United States
    Just tried it. The same thing happens.
     
  10. zacchi4k

    zacchi4k GBAtemp Maniac

    Member
    7
    Feb 6, 2015
    Italy
    Somewhere eating pizza
    Mhh... I don't know if it's possible, since I don't remember much about GM9 back in the A9LH days, but..
    Since you can only boot in GM9, while you're there, go into the SD card, go to where SafeB9SInstaller is, highlight it, and press A. Does it give an option to boot it?
     
    Omarr98 likes this.
  11. Omarr98
    OP

    Omarr98 Member

    Newcomer
    2
    May 26, 2017
    United States
    No, I can't boot it. It lets me boots .firm files, so I got the safebs9installer.firm from the .zip file provided, and I booted that.
    It actually worked, and it did everything, but when I had to press A on the final step to reboot, it instead went to the black screen like before, instead of going to the Luma screen.

    Is it something else causing my issue, or am I missing something?
     
  12. zacchi4k

    zacchi4k GBAtemp Maniac

    Member
    7
    Feb 6, 2015
    Italy
    Somewhere eating pizza
    Ok, you've finally installed B9S. Follow the A9LH to B9S guide again, but skip the "Installing boot9strap" section
     
    Last edited by zacchi4k, Sep 7, 2018
    Omarr98 likes this.
  13. Omarr98
    OP

    Omarr98 Member

    Newcomer
    2
    May 26, 2017
    United States
    I tried it again already, but the problem still persists.
    If I skip the boot9strap section, then I still can't progress, because I can't boot my 3ds home menu. The black screen still shows.
     
  14. zacchi4k

    zacchi4k GBAtemp Maniac

    Member
    7
    Feb 6, 2015
    Italy
    Somewhere eating pizza
  15. Omarr98
    OP

    Omarr98 Member

    Newcomer
    2
    May 26, 2017
    United States
    Wow! Finally!

    It turns out the update probably prevented the console from booting if it detected a flashcart. I had my R4i 3ds one on the console the whole time (I always did).
    Once I removed it, it worked like normal.

    Not sure how exactly it did so, but at least I can finally use it again.

    Thanks a lot!
     
    zacchi4k likes this.
  16. zacchi4k

    zacchi4k GBAtemp Maniac

    Member
    7
    Feb 6, 2015
    Italy
    Somewhere eating pizza
    Sometimes defective or corrupt flashcarts can cause a black screen on boot or, if inserted while on the home screen, cause the console to freeze. Honestly, I should've thought of it before :/
     
    Omarr98 likes this.
Loading...