Best Custom Firmware?

Discussion in 'PSP - Games & Content' started by Aeladya, Jun 2, 2010.

Thread Status:
Not open for further replies.
  1. Aeladya
    OP

    Aeladya *mistressOFtheCLOW

    Member
    759
    1
    Nov 13, 2004
    United States
    Idaho Falls, ID
    I have a PSP that uses 3.30 OE-A and I was curious as to which custom firmware would be the best to update to. I want to play Dissidia, but I'm unsure on if my PSP's current firmware could actually play it (I just bought a new memory card to put it on, but I might be going to another store and I wanted to see if they were cheaper there before I opened it up). Is there any current firmware that can play most of the popular games?
     
  2. ShinRyouma

    ShinRyouma GBAtemp Advanced Fan

    Member
    956
    2
    Dec 6, 2008
    Indonesia
    Surabaya
    The latest CFW is 5.50 Gen-D3, but some people like 5.00 M33-6.
     
  3. Skyline969

    Skyline969 MENUdo Afficionado

    Member
    2,207
    8
    Nov 18, 2008
    Canada
    Saskatchewan
    Thanks to me, she's already using 5.50 GEN-D3. Actually, today I also gave my friend's brother in law 5.50 GEN-D3 over 5.00 M33-6 because he was sick of not being able to play the new games. He didn't want to go through a clusterfuck of decrypting them, etc, so I hooked him up too. [​IMG]
     
  4. Aeladya
    OP

    Aeladya *mistressOFtheCLOW

    Member
    759
    1
    Nov 13, 2004
    United States
    Idaho Falls, ID
    Yup sorry for not editing, I'm tired from doing daycare. Now that I'm set up I just need to take the case off and use some dust-off since I forgot to do it when I put my PSP cover back on and the dust is driving me up the wall XD!
     
  5. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    5,861
    863
    Jul 14, 2008
    Wow...didn't know GEN had Prometheus included now.....oh it doesn't? Still need to patch/decrypt new games. Riiiiiiiiiiiiiiiiiiight......
     
  6. zeromac

    zeromac Finally reached 1000 posts EXACTLY

    Member
    2,194
    7
    Mar 7, 2009
    Earth
    Chill M33 fanboy no need to go hyper

    Seeing as how the OP has already gotten a new firmware this thread can be locked before it turns into a M33 vs GEN when this guy responds
     
  7. Raika

    Raika uguu

    Member
    4,866
    10
    Sep 15, 2008
    uguu
    3.14159265358979323846 GEN π-A=pi*r^2 ...
    Or just go for GEN D-3
     
  8. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    5,861
    863
    Jul 14, 2008
    I'm no fanboy and take that as an insult if you're saying i am. Describing

    1. Extract eboot.bin with UMDGen
    2. Patch with EDecrypt
    3. Replace eboot.bin

    ...as a clusterfuck is just a massive joke though. Both firmwares have advantages, and one is not clearly superior to the other.
     
  9. zeromac

    zeromac Finally reached 1000 posts EXACTLY

    Member
    2,194
    7
    Mar 7, 2009
    Earth
    Why did you recite Pi (not very well either) and give the formula for the area of a circle?
     
  10. Raika

    Raika uguu

    Member
    4,866
    10
    Sep 15, 2008
    uguu
    Cos I fail at math. [​IMG] (I blame copy and pasting [​IMG])
    Enough with the off-topicness. [​IMG]
     
  11. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    5,861
    863
    Jul 14, 2008
    Your sig appears to be in PAL format Raika...
     
  12. Princess Rozalin

    Princess Rozalin †GBAtemp Official Princess Of Roses†

    Member
    544
    5
    Jul 12, 2009
    United States
    Netherworld
    GEN-D3 Is what I recommend some People might dissagree but its what i use.
     
  13. Skyline969

    Skyline969 MENUdo Afficionado

    Member
    2,207
    8
    Nov 18, 2008
    Canada
    Saskatchewan
    Lock, please! The OP has been helped with her problem, and now it's just turned into a mass argument among the lurking children.
     
  14. insidexdeath

    insidexdeath .

    Member
    1,135
    463
    Apr 13, 2010
    m33 is outdated so the m33 fanboys needs to move on already.
     
  15. HokageNaruto

    HokageNaruto GBAtemp Regular

    Member
    155
    0
    Nov 21, 2008
    United States
    none of this please
     
  16. sprogurt

    sprogurt GBAtemp Fan

    Member
    375
    5
    Dec 13, 2006
    +1

    I used to use m33 until it became locked out of the psn store (plugins can fix this) so i updated to gen. Everyone says gen is really buggy but exactly like m33, I've never found a bug. I personally use gen as it's the latest, also just in case i get a new game that would require countless patches oherwise.
     
  17. steve-p

    steve-p GBAtemp Advanced Fan

    Member
    503
    0
    Apr 13, 2009
    all new games need patching,
    learn to patch - it's easy and you can strip out the junk & save space on your stick in the process.
     
  18. TrolleyDave

    TrolleyDave Philosolosophising

    Former Staff
    7,762
    231
    Jan 1, 2007
    Wales, UK
    The problem has been solved so the thread is being closed. [​IMG]
     
Thread Status:
Not open for further replies.