ati card crashing games

Discussion in 'Computer Games and General Discussion' started by Licardo7, Oct 31, 2010.

Oct 31, 2010

ati card crashing games by Licardo7 at 5:57 AM (2,160 Views / 0 Likes) 25 replies

  1. Licardo7
    OP

    Member Licardo7 GBAtemp Fan

    Joined:
    Jul 29, 2008
    Messages:
    498
    Country:
    United States
    Well i just bought the 5770 today and i was all excited. I got mixed up on drivers and junk but my friend, who owns ati cards, helped me and got me the latest one by what he says. The thing is that all of my games are crashing.

    Worked:
    Counter strike source (but with worse fps than with my 9800gt)
    fallout 3 (better performance)
    resident evil 5 (OMG looks so good)
    minecraft ([​IMG])

    Didn't work:
    Call of duty 4 and 5
    battle field bad company 2
    left 4 dead 2
    and grand theft auto 4

    can someone please shed some light on this becuase so far i hate amd/ati [​IMG]
     


  2. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Describe "crash" in EXTREME detail.
     
  3. Licardo7
    OP

    Member Licardo7 GBAtemp Fan

    Joined:
    Jul 29, 2008
    Messages:
    498
    Country:
    United States
    Crashing would be in every case, as loading up the game, it turning black (the loading/title screen does NOT appear) then the game dies giving me a 'not responding" error
     
  4. murkurie

    Member murkurie GBAtemp Fan

    Joined:
    Feb 16, 2010
    Messages:
    316
    Location:
    California, Redlands
    Country:
    United States
    what dies? the game or the computer?
     
  5. Licardo7
    OP

    Member Licardo7 GBAtemp Fan

    Joined:
    Jul 29, 2008
    Messages:
    498
    Country:
    United States
    the game
     
  6. JeAves

    Newcomer JeAves Member

    Joined:
    Jan 30, 2009
    Messages:
    21
    Country:
    Finland
    I bought R5850 while ago and had similar problems, sometimes just the game crashed, other times BSOD! [​IMG] I thought that my new shiny ATI card was broken but then i shifted back to catalyst 10.5 and... CRASHES STOPPED! [​IMG] Now I'm enjoying my games at 100%! Newest drivers that time were 10.8 or 10.9. BTW bluescreen error said atikmdag.sys caused my crash.
     
  7. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    How exactly did you check for the latest drivers?
     
  8. Licardo7
    OP

    Member Licardo7 GBAtemp Fan

    Joined:
    Jul 29, 2008
    Messages:
    498
    Country:
    United States
    tried, doesn't work.

    And theres a thing on the steam store to check for the latest version and that was it. But now i have 10.5 running but everything still crashes.
     
  9. Originality

    Member Originality Chibi-neko

    Joined:
    Apr 21, 2008
    Messages:
    5,154
    Location:
    London, UK
    Country:
    United Kingdom
    Have you tried uninstalling your graphics drivers, rebooting, and installing them again?

    Also I don't trust Steam's driver check for now. When I used it, it made my system very unstable for a week until I installed a Windows Update that, for some reason, fixed it again.
     
  10. Ichiban

    Member Ichiban GBAtemp Regular

    Joined:
    Oct 20, 2005
    Messages:
    152
    Location:
    England
    Country:
    United Kingdom
    I have the http://www.ebuyer.com/product/189741 and all those games you mention all work fine for me, in your CCC 3d settings, make sure AAmode is on performance, having it on quality causes some problems for me.

    Goodluck hope it helps :S
     
  11. dysan

    Member dysan GBAtemp Advanced Fan

    Joined:
    Jan 31, 2010
    Messages:
    577
    Country:
    Greece
    ahhh guys guys....noone noticed that he owned an nvidia card and then bought an ati card?

    the remaining nvidia drivers are propably conflicting with the ati drivers he installed later.

    download this
    http://www.guru3d.com/category/driversweeper/

    restart your pc in safe mode
    run that program(driver sweeper)
    and choose to uninstall anything that mentions "nvidia" or "geforce"
    restart your pc in normal mode
    ????
    PROFIT!

    that should take care of your problems.
    if it doesn't then maybe you need to format [​IMG]
     
  12. Ichiban

    Member Ichiban GBAtemp Regular

    Joined:
    Oct 20, 2005
    Messages:
    152
    Location:
    England
    Country:
    United Kingdom
    yea true, I also had an nvidia card, but I made sure to use driver sweeper before installing my ati card, so yea this could be your problem :/
     
  13. Joe88

    Member Joe88 [λ]

    Joined:
    Jan 6, 2008
    Messages:
    11,191
    Location:
    NYC
    Country:
    United States
    install the 10.10 drivers
    I know there were lots of problems with the 10.8 drivers (crashing games, freezing, ect...)
     
  14. Licardo7
    OP

    Member Licardo7 GBAtemp Fan

    Joined:
    Jul 29, 2008
    Messages:
    498
    Country:
    United States
    Urg, i did everything you guys said and took off the nvidia drivers and installed the 10.10 drivers but i am still getting the same results. =/

    edit: well BattleField Bad Company 2 seems to be working, but everything else doesn't.
     
  15. Ichiban

    Member Ichiban GBAtemp Regular

    Joined:
    Oct 20, 2005
    Messages:
    152
    Location:
    England
    Country:
    United Kingdom
    Well then, it looks like ur gpu is faulty, or you could try a fresh re-install of windows [​IMG]
     
  16. Licardo7
    OP

    Member Licardo7 GBAtemp Fan

    Joined:
    Jul 29, 2008
    Messages:
    498
    Country:
    United States
    ok, thanks for everyone's feedback. After about 4 hours of pissing me off, i finally got all the issues fixed. I had to uninstall EVERYTHING video card related and install the 10.6 drivers and just go up one by one. urg
     
  17. dysan

    Member dysan GBAtemp Advanced Fan

    Joined:
    Jan 31, 2010
    Messages:
    577
    Country:
    Greece
    so you had to uninstall the ati drivers as well?

    hmm...should have known but I wasn't too sure so I didn't mention it earlier.

    anyway,if it works then it's good [​IMG]
     
  18. Licardo7
    OP

    Member Licardo7 GBAtemp Fan

    Joined:
    Jul 29, 2008
    Messages:
    498
    Country:
    United States
    urg, i'd hate to bring this up but the same problem is happening again. I mean it worked earlier and when i came back home (with a brand spanking new 24 inch monitor) it is giving me the same problems again.

    would you think it's the video card it'self?
     
  19. dysan

    Member dysan GBAtemp Advanced Fan

    Joined:
    Jan 31, 2010
    Messages:
    577
    Country:
    Greece
    it could be the video card although I doubt it...

    give us a quick rundown of your system...motherboard,ram,everything.

    maybe the card is getting too hot and it shuts down...although if it did that, the game wouldn't just simply crash but your pc would switch off.

    what's your PSU? maybe the card isn't getting enough power when it's being stressed and stopps working.

    describe your crashes.
    is it just a simple crash to desktop and then you can just click the game again and play? any messages after crashing?any wierd sounds or beeps or things like that?altered resolution after crashing?PC reboots-shuts down itself?

    FYI- to me, at this moment it seems like your PSU can't handle your card.
    if it's 500W-600W and above I guess you're good...but anything below that could be too low
     
  20. Licardo7
    OP

    Member Licardo7 GBAtemp Fan

    Joined:
    Jul 29, 2008
    Messages:
    498
    Country:
    United States
    Mobo: gigabyte ma785g-ud3h
    cpu: amd phenomII x2 550 3.1 GHz oced to 3.2 (yeh i know, its just a test)
    ram: corsair four 1gig sticks of ddr2
    hdd: a shitty 320gig one from an old hp computer (sata)
    psu: 700w coolmax (i think it is good enough for this card)

    It crashes as in:
    i start the game up
    it goes fullscreen black
    then it goes half the size of the screen and gives me a "program not responding error"


    i haven't overclocked this card either and i have the drivers at 10.10
     

Share This Page